View Issue Details

IDProjectCategoryView StatusLast Update
0001369NoesisGUIUnity3Dpublic2019-01-29 13:46
ReportergoldsaucerAssigned Tojsantos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.1.0f1 
Target Version2.2.0Fixed in Version2.2.0b6 
Summary0001369: Noesis fails to load XAML files due to NoesisException: invalid token
DescriptionEverytime we pushes changes to our git repository and someone pulls those, the XAML files cannot be loaded anymore in Unity due to a Noesis exception. Sometimes it says there is no content, sometimes something about an invalid token in the XML.

Right now I have the same problem with the Noesis examples even.
This is particularly bad with the ControlGalery example where I now have to touch (as in make some random change and save it again) every single xaml file to make it work again.

Here's the stack trace:

NoesisException: Assets/NoesisGUI/Samples/ControlGallery/Resources/SimpleStyle.xaml(1): Invalid token.
Rethrow as NoesisException
Noesis.Error.Check () (at Assets/NoesisGUI/Plugins/API/Core/NoesisError.cs:17)
Noesis.GUI.Noesis_LoadXaml_ (System.String xaml) (at Assets/NoesisGUI/Plugins/API/Core/NoesisGUI.cs:275)
Noesis.GUI.LoadXaml (System.String xaml) (at Assets/NoesisGUI/Plugins/API/Core/NoesisGUI.cs:125)
NoesisXaml.Load () (at Assets/NoesisGUI/Plugins/NoesisXaml.cs:31)
ControlGallery.MainWindow.LoadXaml (System.String xaml) (at Assets/NoesisGUI/Samples/ControlGallery/MainWindow.xaml.cs:137)
ControlGallery.MainWindow.OnInitialized (System.Object sender, Noesis.EventArgs args) (at Assets/NoesisGUI/Samples/ControlGallery/MainWindow.xaml.cs:41)
Noesis.FrameworkElement.RaiseInitialized (System.IntPtr cPtr, System.IntPtr sender, System.IntPtr e) (at Assets/NoesisGUI/Plugins/API/Proxies/FrameworkElement.cs:247)
Rethrow as NoesisException
Noesis.Error.Check () (at Assets/NoesisGUI/Plugins/API/Core/NoesisError.cs:17)
Noesis.View.Noesis_View_Create_ (System.Runtime.InteropServices.HandleRef content) (at Assets/NoesisGUI/Plugins/API/Core/NoesisView.cs:402)
Noesis.View..ctor (Noesis.FrameworkElement content) (at Assets/NoesisGUI/Plugins/API/Core/NoesisView.cs:386)
NoesisView.CreateView (Noesis.FrameworkElement content) (at Assets/NoesisGUI/Plugins/NoesisView.cs:1036)
NoesisView.LoadXaml (System.Boolean force) (at Assets/NoesisGUI/Plugins/NoesisView.cs:340)
NoesisView.OnEnable () (at Assets/NoesisGUI/Plugins/NoesisView.cs:398)
Steps To ReproduceGiven there is a unity project using noesis which is tracked using git.

1. A: Make change to XAML file.
2. A: Commit change to XAML and asset file.
3. A: Push changes to repository.
4. B: Pull these changes.
5. B: Try to run the scene using this XAML file.
TagsUnity
PlatformWindows

Activities

goldsaucer

goldsaucer

2018-12-06 20:57

reporter  

noesis-unity-bug.PNG (81,449 bytes)
noesis-unity-bug.PNG (81,449 bytes)
goldsaucer

goldsaucer

2018-12-08 13:49

reporter   ~0005355

Update: I just had the problem again. But I figured out that just selecting the Noesis folder in Unity and reimporting it fixes the issue. Until it happens again. Then I have to reimport it again etc.
jsantos

jsantos

2018-12-10 17:08

manager   ~0005360

Thanks for this report!
jsantos

jsantos

2019-01-18 14:51

manager   ~0005401

I am working on this issue today but I am unable to reproduce. I need you to confirm the following:

- When you make a change and push changes, those changes are: the XAML itself, and the asset corresponding to that XAMl righ? When you update in a different machine you get those two files. And then going to Unity you get the error without doing anything. Is that correct?

Thanks!
jsantos

jsantos

2019-01-19 21:34

manager   ~0005402

I created a github repository today for testing. I was unable to reproduce this...

I need your help :)

Issue History

Date Modified Username Field Change
2018-12-06 20:57 goldsaucer New Issue
2018-12-06 20:57 goldsaucer Tag Attached: Unity
2018-12-06 20:57 goldsaucer File Added: noesis-unity-bug.PNG
2018-12-06 20:58 goldsaucer Description Updated View Revisions
2018-12-06 20:58 goldsaucer Steps to Reproduce Updated View Revisions
2018-12-08 13:49 goldsaucer Severity block => minor
2018-12-08 13:49 goldsaucer Note Added: 0005355
2018-12-10 17:07 jsantos Assigned To => jsantos
2018-12-10 17:07 jsantos Status new => assigned
2018-12-10 17:07 jsantos Target Version => 2.2.0
2018-12-10 17:08 jsantos Note Added: 0005360
2019-01-18 14:51 jsantos Note Added: 0005401
2019-01-18 14:51 jsantos Status assigned => feedback
2019-01-19 21:34 jsantos Note Added: 0005402
2019-01-28 23:14 jsantos Status feedback => resolved
2019-01-28 23:14 jsantos Resolution open => fixed
2019-01-28 23:14 jsantos Fixed in Version => 2.2.0b6