View Issue Details

IDProjectCategoryView StatusLast Update
0001408NoesisGUIUnity3Dpublic2019-04-30 06:19
ReporternokolaAssigned Tojsantos 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version2.2.0b6 
Target VersionFixed in Version 
Summary0001408: Reimport all: Noesis 2.2b6 fails to find images (Ok in 2.1)
DescriptionError during Reimport All:
[Error] [None] [noesis] Assets/XAMLs/FantasiaPhone/UnityShared/Resources/TipCopyClone.xaml(57): Image not found 'Assets/icons/open.96.png'

[b]Assets\XAMLs\FantasiaPhone\UnityShared\Resources[/b]\TipCopyClone.xaml:
[code]
<Image Source="/FantasiaPhone;component/Assets/icons/open.96.png" Stretch="Uniform" Width="40" Height="40" Margin="10"/>
[/code]

The open.96.png is in this folder: [b]Assets\icons[/b]\open.96.png

I also get this, assuming since the root xaml didn't load:
[Exception] NullReferenceException: Object reference not set to an instance of an object
(wrapper dynamic-method) System.Object:lambda_method(System.Runtime.CompilerServices.Closure)
NoesisExtensions.SetupView() Assets/XAMLs/FantasiaPhone/NoesisExtensions.cs:32
30: {
31: _guiView = Camera.main.gameObject.AddComponent<NoesisView>();
-->32: _guiView.Xaml = (NoesisXaml) Resources.Load(mainViewXamlName);
33: _guiView.LoadXaml(true);

Globals.LateInitializeIfNeeded() Assets/Scripts/FantasiaPhone/Globals.cs:1267
1265: NoesisExtensions.SetupView("MainView"); // comment out to test without Noesis
1266: #else
-->1267: NoesisExtensions.SetupView("MainView");
1268: #endif

RecentSavedColorsControl.InitializeCommon() Assets/XAMLs/FantasiaPhone/UnityShared/RecentSavedColorsControl.xaml.cs:60
58: chkSave.Unchecked += chkSave_Unchecked;
-->60: Globals.LateInitializeIfNeeded(); // needed to avoid Noesis crash during Reimport All. Not needed at runtime but doesn't hurt
62: // recent colors

FantasiaPhone.RecentSavedColorsControl..ctor() Assets/XAMLs/FantasiaPhone/UnityShared/RecentSavedColorsControl.xaml.cs:13
11: {
12: InitializeComponent();
-->13: InitializeCommon();
14: }

Extend.CreateInstance() Assets/NoesisGUI/Plugins/API/Core/NoesisExtend.cs:3826
3824: info.Type.FullName));
3825: }
-->3826: object instance = info.Creator();
3828: if (isBaseComponent)

Debug.LogException()

NoesisUnity.OnUnhandledException() Assets/NoesisGUI/Plugins/NoesisUnity.cs:142
140: private static void OnUnhandledException(System.Exception e)
141: {
-->142: UnityEngine.Debug.LogException(e);
143: }
144: #endregion

Error.UnhandledException() Assets/NoesisGUI/Plugins/API/Core/NoesisError.cs:18
16: if (_unhandledCallback != null)
17: {
-->18: _unhandledCallback(exception);
19: }
20: }

Extend.CreateInstance() Assets/NoesisGUI/Plugins/API/Core/NoesisExtend.cs:3844
3842: catch (Exception e)
3843: {
-->3844: Error.UnhandledException(e);
3845: }
3846: }

GUI.Noesis_LoadXaml()

GUI.LoadXaml() Assets/NoesisGUI/Plugins/API/Core/NoesisGUI.cs:191
189: public static object LoadXaml(string filename)
190: {
-->191: IntPtr root = Noesis_LoadXaml(filename);
192: return Extend.GetProxy(root, true);
193: }

NoesisXaml.Load() Assets/NoesisGUI/Plugins/NoesisXaml.cs:30
29: RegisterDependencies();
-->30: return Noesis.GUI.LoadXaml(source);
31: }

NoesisPostprocessor.ImportXaml() Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:353
351: try
352: {
-->353: xaml.Load();
354: }
355: catch (Exception e)

NoesisPostprocessor.ImportXaml() Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:283
281: {
282: bool changed;
-->283: return ImportXaml(filename, reimport, out changed);
284: }

NoesisPostprocessor.ImportAssets() Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:76
74: else if (IsXaml(asset))
75: {
-->76: ImportXaml(asset, true);
77: }
78: }

NoesisPostprocessor.ImportAllAssets() Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:28
26: .Distinct().ToArray();
-->28: NoesisPostprocessor.ImportAssets(assets, d);
29: }

NoesisPostprocessor.ImportAllAssets() Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:15
13: public static void ImportAllAssets()
14: {
-->15: NoesisPostprocessor.ImportAllAssets((progress, asset) => EditorUtility.DisplayProgressBar("Reimport All XAMLs", asset, progress));
16: EditorUtility.ClearProgressBar();
17: }

NoesisSettingsEditor.OnInspectorGUI() Assets/NoesisGUI/Plugins/Editor/NoesisSettingsEditor.cs:78
76: if(GUILayout.Button("Reimport All XAMLs", GUILayout.MaxWidth(175), GUILayout.MinHeight(20)))
77: {
-->78: NoesisPostprocessor.ImportAllAssets();
79: }

NoesisSettingsEditor.OnInspectorGUI() Assets/NoesisGUI/Plugins/Editor/NoesisSettingsEditor.cs:10
8: public override void OnInspectorGUI()
9: {
-->10: OnInspectorGUI(new SerializedObject((NoesisSettings)target));
11: }

GUIUtility.ProcessEvent()
Steps To Reproduce1. Create XAML file and image at the folders specified in Description above
2. Reimport all
Expected: all OK
Actual: [Error] [None] [noesis] Assets/XAMLs/FantasiaPhone/UnityShared/Resources/TipCopyClone.xaml(57): Image not found 'Assets/icons/open.96.png'
TagsNo tags attached.
PlatformAny

Activities

jsantos

jsantos

2019-02-24 04:14

manager   ~0005453

is this happening only once in that XAML or do you see this error in more XAMLs? We are not able to reproduce the error, could you please attach the XAML?
Thanks!
nokola

nokola

2019-02-24 06:34

reporter   ~0005455

Error just went away on it's own - after Unity restart. Can't reproduce it either. I propose close this bug. If it happens again I can add a note
jsantos

jsantos

2019-02-24 21:04

manager   ~0005460

Last edited: 2019-02-24 21:04

View 2 revisions

This was happening doing 'ReimportALL' from our settings panel right?

nokola

nokola

2019-02-24 21:13

reporter   ~0005462

Yes, did this:
0. Close Unity
1. Deleted old Noesis folder
2. Start Unity
3. Import Noesis 2.2b6
3.5 Fix all compile issues due to breaking changes from 2.1
4. Restart Unity
5. Tools | Noesis settings -> "Reimport All XAMLs"
I think it happened once more after restart, but suddenly stopped reproducing, not sure why.
jsantos

jsantos

2019-02-24 21:17

manager   ~0005463

Only in that XAML?
nokola

nokola

2019-02-26 05:02

reporter   ~0005473

It was perhaps in 2-3 XAML files (out of say 15)
I didn't notice any specific pattern. Perhaps something failed to reimport or the importer crashed in the middle causing subsequent errors that recovered on restart. I propose close the bug (at least I have no more info, might be a dead end) and I'll ping you if it happens again.

Issue History

Date Modified Username Field Change
2019-02-23 05:21 nokola New Issue
2019-02-24 04:14 jsantos Note Added: 0005453
2019-02-24 04:14 jsantos Assigned To => jsantos
2019-02-24 04:14 jsantos Status new => feedback
2019-02-24 06:34 nokola Note Added: 0005455
2019-02-24 06:34 nokola Status feedback => assigned
2019-02-24 21:04 jsantos Note Added: 0005460
2019-02-24 21:04 jsantos Note Edited: 0005460 View Revisions
2019-02-24 21:04 jsantos Status assigned => feedback
2019-02-24 21:13 nokola Note Added: 0005462
2019-02-24 21:13 nokola Status feedback => assigned
2019-02-24 21:17 jsantos Status assigned => feedback
2019-02-24 21:17 jsantos Note Added: 0005463
2019-02-26 05:02 nokola Note Added: 0005473
2019-02-26 05:02 nokola Status feedback => assigned
2019-03-18 20:05 jsantos Status assigned => resolved
2019-03-18 20:05 jsantos Resolution open => fixed
2019-04-30 06:19 nokola Status resolved => closed