View Issue Details

IDProjectCategoryView StatusLast Update
0001428NoesisGUIUnity3Dpublic2019-04-02 01:43
ReporterC4usticAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0001428: Complete Unity Crash if a popup is open when we change scene.
DescriptionI have not tried this with an empty example project but hopefully it is the same there. NoesisGUI and the whole unity editor crashes if any NoesisView have a popup open when SceneManager.LoadScene("newSceneName"); is run.

Closing the popup the same frame doesn't work either, the popup must have been closed for at least one frame to avoid the crash (or never opened).
I'm opening and closing my popups from script with pupup.IsOpen = false/true;

I think this was a problem before I updated to 2.0 too I just never saw a pattern until today when during the update process I run into this many times.
Steps To ReproduceCreate a menu with a popup.
Open the pupup with script.
change Unity scene with: SceneManager.LoadScene("newSceneName");
The whole Unity editor crashes.
TagsNo tags attached.
PlatformWindows

Activities

C4ustic

C4ustic

2019-03-17 21:56

reporter   ~0005536

Maybe the repro wasn't as simple as I though. It looks like I have to open the popup the same frame as I change scene to get the 100% repro.
I can also get the crash at other points if I have changed scene and then later on open a popup.

I will do some more research.
C4ustic

C4ustic

2019-03-17 22:23

reporter   ~0005537

I have two ways of getting the crash now, one is to run pupup.IsOpen = true; the same frame as SceneManager.LoadScene("newSceneName"); the other is to have the popup open then change scene and then change scene again back to the first one and open the popup again.

To sum it up, bad things happen if you have popups open when you do scene changes. Opening the popup the same frame seems to be the best repro case.

The workaround I use now is that before I change scene I find all NoesisViews in the scene and make sure they have all popups closed. Then I wait for a few frames, and then run LoadScene doing this seem to prevent the crash totally.
sfernandez

sfernandez

2019-03-18 22:19

manager   ~0005540

Thanks for all the details, will take a look as soon as possible to fix it for the next release.
sfernandez

sfernandez

2019-04-02 01:43

manager   ~0005588

We found the source of the problem and fixed it for the next release, thanks again for your collaboration.

Issue History

Date Modified Username Field Change
2019-03-17 21:46 C4ustic New Issue
2019-03-17 21:56 C4ustic Note Added: 0005536
2019-03-17 22:23 C4ustic Note Added: 0005537
2019-03-18 22:19 sfernandez Assigned To => sfernandez
2019-03-18 22:19 sfernandez Status new => assigned
2019-03-18 22:19 sfernandez Target Version => 2.2.1
2019-03-18 22:19 sfernandez Note Added: 0005540
2019-04-02 01:19 sfernandez Status assigned => resolved
2019-04-02 01:19 sfernandez Resolution open => fixed
2019-04-02 01:19 sfernandez Fixed in Version => 2.2.1
2019-04-02 01:43 sfernandez Note Added: 0005588