View Issue Details

IDProjectCategoryView StatusLast Update
0001442NoesisGUIUnity3Dpublic2019-04-04 18:07
ReporterstonstadAssigned Tojsantos 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version2.2.0rc1 
Target Version2.2.1Fixed in Version2.2.1 
Summary0001442: XAML Import Causes Unity to Freeze
DescriptionUnity freezes and Noesis blocks on the main thread. From forums, this is related to a mutex lock getting destroyed before it is released.

https://www.noesisengine.com/forums/viewtopic.php?f=3&t=1616&p=9417#p9417
Steps To Reproduce1) Modify XAML external to Unity.
2) Tab back into Unity. Unity is running but apparently waiting for Noesis to release control back on the Main thread.

It's a threading race condition issue -- it happens about 1 in 10 times when external XAML is modified. Because it is threading related, it can happen three times in a row or not at all.
TagsNo tags attached.
PlatformAny

Activities

jsantos

jsantos

2019-04-04 18:07

manager   ~0005591

Thanks for your feedback! Your dump was really helpful

Issue History

Date Modified Username Field Change
2019-04-03 17:10 stonstad New Issue
2019-04-03 17:12 stonstad Description Updated View Revisions
2019-04-04 17:44 jsantos Assigned To => jsantos
2019-04-04 17:44 jsantos Status new => assigned
2019-04-04 17:44 jsantos Target Version => 2.2.1
2019-04-04 18:07 jsantos Status assigned => resolved
2019-04-04 18:07 jsantos Resolution open => fixed
2019-04-04 18:07 jsantos Fixed in Version => 2.2.1
2019-04-04 18:07 jsantos Note Added: 0005591