View Issue Details

IDProjectCategoryView StatusLast Update
0001503NoesisGUIC# SDKpublic2019-07-04 18:23
Reporterai_enabledAssigned Tosfernandez 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.2.3 
Target Version2.2.4Fixed in Version 
Summary0001503: Click on the currently selected listbox item will deselect it
DescriptionHi guys,

after updating to 2.2.3 I've noticed that click on the currently selected Listbox item will deselect it. Is this intended? Is there any way to restore the previous behavior? Unfortunately, in our case, it's a critical issue.

Regards!
TagsNo tags attached.
PlatformAny

Activities

sfernandez

sfernandez

2019-06-21 17:34

manager   ~0005758

I'm not able to reproduce that behavior in a normal ListBox.
Are you using SelectionMode="Multiple"? That is the only mode that behaves as you explained.
Where in your game can I test this to investigate what is happening?
ai_enabled

ai_enabled

2019-06-21 18:14

updater   ~0005759

Thanks for the quick reply, Sergio!
I've just updated to 2.2.3 and noticed the issue. Secondary click on the selected item in any listbox (skills list, structures list, etc) resulted in de-selection.
SelectionMode="Multiple" is definitely not used.
However, right now I cannot reproduce the issue even though it happened for two-three first launches. That's confusing as I'm certain I didn't changed anything. Ok, I will keep watching.
Regards!
ai_enabled

ai_enabled

2019-07-04 14:46

updater   ~0005802

Last edited: 2019-07-04 14:46

View 2 revisions

I was unable to reproduce the issue again. This was really weird.

Please close this ticket. Sorry for disturbing you!

sfernandez

sfernandez

2019-07-04 18:23

manager   ~0005803

Thanks for the update, closing this.

Issue History

Date Modified Username Field Change
2019-06-21 14:27 ai_enabled New Issue
2019-06-21 14:27 ai_enabled Priority normal => urgent
2019-06-21 14:27 ai_enabled Description Updated View Revisions
2019-06-21 17:34 sfernandez Assigned To => sfernandez
2019-06-21 17:34 sfernandez Status new => feedback
2019-06-21 17:34 sfernandez Note Added: 0005758
2019-06-21 17:35 sfernandez Target Version => 2.2.4
2019-06-21 18:14 ai_enabled Note Added: 0005759
2019-06-21 18:14 ai_enabled Status feedback => assigned
2019-07-04 14:46 ai_enabled Note Added: 0005802
2019-07-04 14:46 ai_enabled Note Edited: 0005802 View Revisions
2019-07-04 18:23 sfernandez Status assigned => resolved
2019-07-04 18:23 sfernandez Resolution open => no change required
2019-07-04 18:23 sfernandez Note Added: 0005803