View Issue Details

IDProjectCategoryView StatusLast Update
0001508NoesisGUIUnity3Dpublic2019-08-22 19:26
ReporterhoreaperAssigned Tojsantos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0001508: Using NoesisGUI with ProGrid together cause some errors.
DescriptionNoesisGUI 2.2.3 with Unity 2019.1.7.
When ProGrid and NoesisGUI exist together, the following error happens:

[code]
Read only asset Packages/com.unity.progrids/Font/Asap-Regular-ProGrids.asset has no meta file.
UnityEditor.AssetDatabase:CreateAsset(Object, String)
NoesisPostprocessor:ImportFont(String, Boolean) (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:139)
NoesisPostprocessor:ImportAssets(String[], UpdateProgress) (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:72)
<>c__DisplayClass4_1:<OnPostprocessAllAssets>b__0() (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:107)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions()
[/code]
[code]
Read only asset Packages/com.unity.progrids/Font/Asap-Medium-ProGrids.asset has no meta file.
UnityEditor.AssetDatabase:CreateAsset(Object, String)
NoesisPostprocessor:ImportFont(String, Boolean) (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:139)
NoesisPostprocessor:ImportAssets(String[], UpdateProgress) (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:72)
<>c__DisplayClass4_1:<OnPostprocessAllAssets>b__0() (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:107)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions()
[/code]

The solution are to remove [i]Asap-Medium-ProGrids.asset[/i] and [i]Asap-Regular-ProGrids.asset[/i] from "Library\PackageCache\com.unity.progrids@(whatever.the.version.is)\Font" directory, then reopen the project.

Looks like those were generated by Noesis's font importer.
Steps To Reproduce1. Import NoesisGUI package.
2. Add ProGrid from package manager.
    The error will pop up.
4. Delete Asap-Medium-ProGrids.asset and Asap-Regular-ProGrids.asset in ProGrid's cache directory.
    Errors will go away after reopen the project.
5. Hit "Reimport All XAMLs", or re-import NoesisGUI.
   Errors will come back.
TagsUnity
PlatformWindows

Relationships

has duplicate 0001544 resolvedjsantos Unity plugin modifies packages 

Activities

horeaper

horeaper

2019-06-25 06:50

reporter  

20190625125042.png (61,764 bytes)
20190625125042.png (61,764 bytes)

Issue History

Date Modified Username Field Change
2019-06-25 06:50 horeaper New Issue
2019-06-25 06:50 horeaper Tag Attached: Unity
2019-06-25 06:50 horeaper File Added: 20190625125042.png
2019-06-25 10:54 sfernandez Assigned To => jsantos
2019-06-25 10:54 sfernandez Status new => assigned
2019-06-25 10:54 sfernandez Target Version => 2.2.4
2019-06-25 10:54 sfernandez Description Updated View Revisions
2019-06-25 10:54 sfernandez Steps to Reproduce Updated View Revisions
2019-08-10 04:26 jsantos Status assigned => resolved
2019-08-10 04:26 jsantos Resolution open => fixed
2019-08-10 04:26 jsantos Fixed in Version => 2.2.4
2019-08-22 19:26 jsantos Relationship added has duplicate 0001544