View Issue Details

IDProjectCategoryView StatusLast Update
0001510NoesisGUIUnity3Dpublic2019-07-09 23:53
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionreopened 
Product Version2.2.4 
Target Version2.2.4Fixed in Version2.2.4 
Summary0001510: Crash On Mouse Over
DescriptionTesting with debug/preview version of 2.2.4 shared here: https://www.noesisengine.com/bugs/view.php?id=1491. If this is a one-off caused by a diagnostic DLL or breakpoint firing please feel free to close/disregard this bug.

I have a UI element that crashes consistently whenever I mouse over. The stack trace leads me to believe it is somehow associated with an easing function assigned to the screen,.

========== OUTPUTTING STACK TRACE ==================

0x00007FFE6FB422B8 (Noesis) Unbox_EasingMode
0x00007FFE6FB3A960 (Noesis) Unbox_EasingMode
0x00007FFE6F51B89A (Noesis) Unbox_EasingMode
0x00007FFE6F72CB0D (Noesis) Unbox_EasingMode
0x00007FFE6F7CFFF1 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFF81 (Noesis) Unbox_EasingMode
0x00007FFE6F7CFC20 (Noesis) Unbox_EasingMode
0x00007FFE6F7D9166 (Noesis) Unbox_EasingMode
0x00007FFE6F623C3A (Noesis) Unbox_EasingMode
0x00007FFE6F623A46 (Noesis) Unbox_EasingMode
0x00007FFE6F6213A0 (Noesis) Unbox_EasingMode
0x00007FFE6F7B0BA7 (Noesis) Unbox_EasingMode
0x00007FFE6F909E0D (Noesis) Unbox_EasingMode
0x000002C59C834862 (Mono JIT Code) (wrapper managed-to-native) Noesis.View:Noesis_View_MouseMove (System.Runtime.InteropServices.HandleRef,int,int)
0x000002C59C8346EB (Mono JIT Code) [C:\Users\stons\GitHub\StellarConquest-New\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\API\Core\View.cs:114] Noesis.View:MouseMove (int,int)
0x000002C59C8324FB (Mono JIT Code) [C:\Users\stons\GitHub\StellarConquest-New\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\NoesisView.cs:595] NoesisView:UpdateMouse ()
0x000002C59C831DDB (Mono JIT Code) [C:\Users\stons\GitHub\StellarConquest-New\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\NoesisView.cs:721] NoesisView:UpdateInputs ()
0x000002C59C8318E3 (Mono JIT Code) [C:\Users\stons\GitHub\StellarConquest-New\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\NoesisView.cs:753] NoesisView:LateUpdate ()
0x000002C59BC7B918 (Mono JIT Code) (wrapper runtime-invoke) object:runtime_invoke_void__this__ (object,intptr,intptr,intptr)
0x00007FFE608EBBCB (mono-2.0-bdwgc) [c:\users\builduser\builds\_cjcc5tm\0\vm\mono\mono\mini\mini-runtime.c:2809] mono_jit_runtime_invoke
0x00007FFE60872252 (mono-2.0-bdwgc) [c:\users\builduser\builds\_cjcc5tm\0\vm\mono\mono\metadata\object.c:2919] do_runtime_invoke
0x00007FFE6087B25F (mono-2.0-bdwgc) [c:\users\builduser\builds\_cjcc5tm\0\vm\mono\mono\metadata\object.c:2966] mono_runtime_invoke
0x00007FF72D010256 (Unity) scripting_method_invoke
0x00007FF72D00A545 (Unity) ScriptingInvocation::Invoke
0x00007FF72CFC6C32 (Unity) MonoBehaviour::CallMethodIfAvailable
0x00007FF72CFC6FD6 (Unity) MonoBehaviour::CallUpdateMethod
0x00007FF72C6ECB74 (Unity) BaseBehaviourManager::CommonUpdate<LateBehaviourManager>
0x00007FF72C6F4FD4 (Unity) LateBehaviourManager::Update
0x00007FF72CB25BF3 (Unity) `InitPlayerLoopCallbacks'::`2'::PreLateUpdateScriptRunBehaviourLateUpdateRegistrator::Forward
0x00007FF72CB0F2C8 (Unity) ExecutePlayerLoop
0x00007FF72CB0F3A6 (Unity) ExecutePlayerLoop
0x00007FF72CB13F60 (Unity) PlayerLoop
0x00007FF72B830AA0 (Unity) PlayerLoopController::UpdateScene
0x00007FF72B82DB28 (Unity) Application::TickTimer
0x00007FF72BAEC1EB (Unity) MainMessageLoop
0x00007FF72BAF5BF7 (Unity) WinMain
0x00007FF72E438B5E (Unity) __scrt_common_main_seh
0x00007FFEE8A77974 (KERNEL32) BaseThreadInitThunk
0x00007FFEEB86A271 (ntdll) RtlUserThreadStart

========== END OF STACKTRACE ===========
Steps To ReproduceVideo
http://clarion.blob.core.windows.net/$root/Action%207-1-2019%203-39-00%20PM.mp4
TagsNo tags attached.
PlatformAny

Activities

stonstad

stonstad

2019-07-01 22:41

reporter  

Crashes.zip (1,160,557 bytes)
stonstad

stonstad

2019-07-02 00:20

reporter   ~0005796

The same behavior happens with textboxes. This must be related to the debug assembly...
sfernandez

sfernandez

2019-07-05 12:48

manager   ~0005805

Yes, this is an assert we already fixed for 2.2.4.
I generated a new debug library that includes that fix (along with the other fixes for issue 1491).

https://drive.google.com/open?id=1asJnFk8-1FIBq9dRxc6glMej8XpHgIrX
stonstad

stonstad

2019-07-09 22:05

reporter   ~0005827

Thanks Sergio. This works!
stonstad

stonstad

2019-07-09 23:09

reporter   ~0005828

Encountered a runtime crash with identical or similar stacktrace. Reopening.
stonstad

stonstad

2019-07-09 23:10

reporter   ~0005829

I'm using the assembly above. The stack trace looks similar or identical. Runtime breakpoint exception.

AssetDatabase Save disabled
Preview disabled

Crash_2019-07-09_170857502.zip (370,077 bytes)
stonstad

stonstad

2019-07-09 23:14

reporter   ~0005830

This is likely caused by invalid code on my part in an initialize method. I had the following test code to try to unset a min width. Please feel free to close.

_TitleLayer.ColumnDefinitions[1].MinWidth = float.NaN; // invalid
 _TitleLayer.ColumnDefinitions[1].Width = new GridLength(1, GridUnitType.Auto);
 Grid.SetColumn(_TitleTextBlock, 0);
 Grid.SetColumnSpan(_TitleTextBlock, 3);
sfernandez

sfernandez

2019-07-09 23:53

manager   ~0005832

Yes, it was an assert for an invalid ColumnDefinition.MinWidth value, but we should add validation callbacks to prevent it and correctly report them as errors.
I created a ticket for that: https://www.noesisengine.com/bugs/view.php?id=1516

Issue History

Date Modified Username Field Change
2019-07-01 22:41 stonstad New Issue
2019-07-01 22:41 stonstad File Added: Crashes.zip
2019-07-02 00:20 stonstad Note Added: 0005796
2019-07-05 12:48 sfernandez Assigned To => sfernandez
2019-07-05 12:48 sfernandez Status new => feedback
2019-07-05 12:48 sfernandez Note Added: 0005805
2019-07-05 12:52 sfernandez Target Version => 2.2.4
2019-07-05 12:52 sfernandez Description Updated View Revisions
2019-07-05 12:52 sfernandez Steps to Reproduce Updated View Revisions
2019-07-09 22:05 stonstad Note Added: 0005827
2019-07-09 22:05 stonstad Status feedback => assigned
2019-07-09 22:09 sfernandez Status assigned => resolved
2019-07-09 22:09 sfernandez Resolution open => fixed
2019-07-09 22:10 sfernandez Fixed in Version => 2.2.4
2019-07-09 23:09 stonstad Status resolved => feedback
2019-07-09 23:09 stonstad Resolution fixed => reopened
2019-07-09 23:09 stonstad Note Added: 0005828
2019-07-09 23:10 stonstad File Added: Crash_2019-07-09_170857502.zip
2019-07-09 23:10 stonstad Note Added: 0005829
2019-07-09 23:10 stonstad Status feedback => assigned
2019-07-09 23:14 stonstad Note Added: 0005830
2019-07-09 23:53 sfernandez Status assigned => resolved
2019-07-09 23:53 sfernandez Note Added: 0005832