View Issue Details

IDProjectCategoryView StatusLast Update
0001513NoesisGUIC# SDKpublic2019-07-05 18:37
ReporterinediAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001513: UserControl IsTabStop not work
Description<UserControl ....
            IsTabStop="False" >
not work in noesis

will be comfortable if work like WPF tab stop for user control
Steps To Reproduce <UserControl ...
IsTabStop="False">

    <Grid>
        <StackPanel Width="300" HorizontalAlignment="Right">
            <TextBlock Foreground="White">
                <Run Text="Stars "/>
                <Run Text="{Binding ExposureStars}"/>
            </TextBlock>
            <Slider Value="{Binding ExposureStars}"
                    Minimum="0"
                    Maximum="8"
                    LargeChange="1"
                    SmallChange="0.1"
                    IsSnapToTickEnabled="True"
                    TickFrequency="0.01"/>
            
            <TextBlock Foreground="White">
                <Run Text="Figures "/>
                <Run Text="{Binding ExposureFigures}"/>
            </TextBlock>
            <Slider Value="{Binding ExposureFigures}"
                    Minimum="0"
                    Maximum="8"
                    LargeChange="1"
                    SmallChange="0.1"
                    IsSnapToTickEnabled="True"
                    TickFrequency="0.01"/>
....
Tagsxaml
PlatformAny

Activities

sfernandez

sfernandez

2019-07-05 12:54

manager   ~0005807

Last edited: 2019-07-05 12:55

View 2 revisions

Sorry, but I'm not understanding what is the problem here, UserControl.IsTabStop default value is already set to False, and user controls don't get focused because of that.
What are you trying to do?

inedi

inedi

2019-07-05 14:57

reporter   ~0005808

user controls children's get focused if IsTabStop true and false on UserControl

in WPF children's don't get focused if IsTabStop="False"on UserControl
sfernandez

sfernandez

2019-07-05 16:32

manager   ~0005809

I just verified that WPF allows the keyboard focus to move inside the UserControl children when pressing the Tab key, even if IsTabStop property is set to false in the UserControl.
That property just indicates that the UserControl itself, if it is set to Focusable="True", will get or not the focus when pressing the Tab key, but it doesn't apply to children.
If you don't want the controls inside the user control to receive tab focus you can set KeyboardNavigation.TabNavigation="None" in the UserControl. Is that what you need?
inedi

inedi

2019-07-05 17:51

reporter   ~0005811

yes, thank you, i just rechecked the WPF project
everything works also Noesis
I lost KeyboardNavigation property in Noesis and got a different result

Excuse for troubling )

Issue History

Date Modified Username Field Change
2019-07-03 19:37 inedi New Issue
2019-07-03 19:37 inedi Tag Attached: xaml
2019-07-05 12:54 sfernandez Assigned To => sfernandez
2019-07-05 12:54 sfernandez Status new => feedback
2019-07-05 12:54 sfernandez Note Added: 0005807
2019-07-05 12:55 sfernandez Note Edited: 0005807 View Revisions
2019-07-05 14:57 inedi Note Added: 0005808
2019-07-05 14:57 inedi Status feedback => assigned
2019-07-05 16:32 sfernandez Status assigned => feedback
2019-07-05 16:32 sfernandez Note Added: 0005809
2019-07-05 17:51 inedi Note Added: 0005811
2019-07-05 17:51 inedi Status feedback => assigned
2019-07-05 18:37 sfernandez Status assigned => resolved
2019-07-05 18:37 sfernandez Resolution open => no change required