View Issue Details

IDProjectCategoryView StatusLast Update
0001520NoesisGUIUnity3Dpublic2019-08-12 20:55
Reporterivan_bAssigned Tojsantos 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.0 
Target Version2.2.4Fixed in Version2.2.4 
Summary0001520: Using sytsem fonts on iPad 2 crashes the app
DescriptionI have tried with Haiti SC, PingFang SC and Helvetica one at a time and I am always getting the same error.
Those were the only fonts used and I have only used them one at a time.
In the attachment is the screenshoot of the XCode project.
TagsNo tags attached.
PlatformAny

Activities

ivan_b

ivan_b

2019-07-17 19:35

reporter  

WhatsApp Image 2019-07-17 at 15.12.51.jpeg (400,462 bytes)
jsantos

jsantos

2019-07-17 19:38

manager   ~0005866

If you use a different system font to those 3 you mention, the crash doesn't happen?
ivan_b

ivan_b

2019-07-17 19:49

reporter   ~0005867

Those are the only system fonts that I have tried for now.
jsantos

jsantos

2019-07-17 21:20

manager   ~0005875

Could you try more system fonts to see if it is happening with ALL system fonts? Thanks
ivan_b

ivan_b

2019-07-20 19:54

reporter   ~0005890

I have tried some other fonts but the problem remains.
I have extracted the Helvetica.ttc font from /System/Library/Fonts/Core on the iPad 2 and imported it as a normal font inside the unity project.
I was able to use it this way on the iPad 2.
What could be my next step?
jsantos

jsantos

2019-07-23 03:23

manager   ~0005894

Could you please do the following things:

1. That the device with problems is an A1395, A1396 or A1397 (can check the number in the back of the iPad)
2. Attach a minimal unity project reproducing the issue (for example a single XAML with a textblock using a system font)
3. Verify the the minimal sample works in rest of iPads but crash on iPad2.

Thanks!
ivan_b

ivan_b

2019-07-23 20:31

reporter   ~0005896

Yes, the iPad model is A1395. I will create a small project and submit it.
If it is possible can I know what is the problem :)?
jsantos

jsantos

2019-07-24 16:19

manager   ~0005900

I don't know what is going on because I am not able to reproduce it in the iPads we have here. I ordered an iPad2 for testing.
ivan_b

ivan_b

2019-07-25 21:37

reporter   ~0005902

Here is the project.
I have tested it on the iPad 2 and the problem is still there.
I will just need to check that it works on the iPad Air.
I will let you know as soon as possible.

Assets.zip (5,940 bytes)
ivan_b

ivan_b

2019-07-25 21:47

reporter   ~0005903

I Have uploaded the wrong Assests folder.
This should be the correct one.

Assets-2.zip (6,217 bytes)
jsantos

jsantos

2019-07-25 21:52

manager   ~0005904

Thanks, please, let me know when you verify it works in the iPad Air.
ivan_b

ivan_b

2019-07-30 21:49

reporter   ~0005913

Sorry for the late reply but I could test this only today.
I can confirm that it works on the iPad Air.
jsantos

jsantos

2019-08-08 17:19

manager   ~0005917

Thanks for the feedback! I will keep you posted.
jsantos

jsantos

2019-08-12 17:44

manager   ~0005922

I already tested this on iPad2 and I am able to reproduce the issue. That's a good start... :)

Issue History

Date Modified Username Field Change
2019-07-17 19:35 ivan_b New Issue
2019-07-17 19:35 ivan_b File Added: WhatsApp Image 2019-07-17 at 15.12.51.jpeg
2019-07-17 19:38 jsantos Note Added: 0005866
2019-07-17 19:38 jsantos Assigned To => jsantos
2019-07-17 19:38 jsantos Status new => assigned
2019-07-17 19:38 jsantos Status assigned => feedback
2019-07-17 19:49 ivan_b Note Added: 0005867
2019-07-17 19:49 ivan_b Status feedback => assigned
2019-07-17 21:20 jsantos Note Added: 0005875
2019-07-17 21:20 jsantos Status assigned => feedback
2019-07-20 19:54 ivan_b Note Added: 0005890
2019-07-20 19:54 ivan_b Status feedback => assigned
2019-07-23 03:23 jsantos Note Added: 0005894
2019-07-23 03:23 jsantos Status assigned => feedback
2019-07-23 20:31 ivan_b Note Added: 0005896
2019-07-23 20:31 ivan_b Status feedback => assigned
2019-07-24 16:19 jsantos Note Added: 0005900
2019-07-25 21:37 ivan_b File Added: Assets.zip
2019-07-25 21:37 ivan_b Note Added: 0005902
2019-07-25 21:47 ivan_b File Added: Assets-2.zip
2019-07-25 21:47 ivan_b Note Added: 0005903
2019-07-25 21:52 jsantos Note Added: 0005904
2019-07-25 21:52 jsantos Status assigned => feedback
2019-07-30 21:49 ivan_b Note Added: 0005913
2019-07-30 21:49 ivan_b Status feedback => assigned
2019-08-08 13:08 jsantos Target Version => 2.2.4
2019-08-08 17:19 jsantos Note Added: 0005917
2019-08-12 17:44 jsantos Note Added: 0005922
2019-08-12 20:55 jsantos Status assigned => resolved
2019-08-12 20:55 jsantos Resolution open => fixed
2019-08-12 20:55 jsantos Fixed in Version => 2.2.4