View Issue Details

IDProjectCategoryView StatusLast Update
0001546NoesisGUIUnity3Dpublic2019-11-17 18:04
ReporterbungarraAssigned Tojsantos 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001546: PS4 Controller "Noesis_Accept" does not work.
Descriptionclicking on a button with a PS4 controller does not register, the click event has been called but does not execute the function on the button, have tested with other controllers and it works as well as mouse and keyboard.
Steps To Reproduceplug in a ps4 controller and use on every example scene
TagsC#, Unity
PlatformAny

Activities

sfernandez

sfernandez

2019-08-26 11:01

manager   ~0005939

Is this happening even if you apply the workaround in https://www.noesisengine.com/bugs/view.php?id=1524#c5907?
bungarra

bungarra

2019-08-27 02:34

reporter   ~0005940

Yes, I have applied these workarounds, everything works fine on the Xbox controller just not the PS4
jsantos

jsantos

2019-08-28 18:32

manager   ~0005944

I tried with a PS4 controller and was able to reproduce the issue. The problem is that the axis and buttons in this controller are not compatible with the default mapping we provide with our samples, we configured the Input Manager with a Xbox controller in mind. If you want support for more controllers you need to configure them following our mapping.

I am not sure what's the best way to do this, I would say the current Input implementation in Unity is quite trivial and incomplete and probably extra work is needed.

This is not a bug. Ok with closing this?
bungarra

bungarra

2019-08-29 02:58

reporter   ~0005946

We have created a system using unity new Input system, which maps the controllers correctly, the problem is that it doesn't call the click event on any of the buttons. the Noesis_Accept doesn't call the accept button on any PS4 controller but works with Xbox, Switch and generic Logitech. I have uploaded the noesisView edited without input system.

NoesisView.cs (44,719 bytes)
jsantos

jsantos

2019-08-29 10:27

manager   ~0005948

Last edited: 2019-08-29 10:27

View 3 revisions

That's happening because 'Noesis_Scroll' or 'Noesis_HScroll' are still being triggered with the incorrect input in the following lines:

line 692:        try { float v = Input.GetAxisRaw("Noesis_Scroll"); if (Math.Abs(v) > 0.05f) _uiView.Scroll(v); } catch (Exception) {}
line 693:        try { float v = Input.GetAxisRaw("Noesis_HScroll"); if (Math.Abs(v) > 0.05f) _uiView.HScroll(v); } catch (Exception) {}

I fixed it here, by properly adjusting all the axis for the PS4 controller. If you comment out that code, I am sure it will work for you. But I am not sure what's the right solution. Is that new Input System already stable?

bungarra

bungarra

2019-08-29 10:43

reporter   ~0005949

We are using 2.2.4 which has these added in, I have also attached a gif of it working with an xbox and not working with the PS4. The noesis View is still using the old system in regards to the new lines, the only thing that has changed is the Accept call, but does not deviate away from your system and still calls the accept button.
jsantos

jsantos

2019-08-29 10:46

manager   ~0005950

Comment out those lines and you will see it works (it should :) ).

Problem is, our default Input System settings is incorrectly mapping the axis for the PS4 Controller because it is configured for Xbox controller.

Yesterday, I attached a PS4 controller, properly configured it and everything was working,
bungarra

bungarra

2019-08-29 10:53

reporter   ~0005951

Removing the lines fixed thank you :).
jsantos

jsantos

2019-08-29 10:55

manager   ~0005952

Yes, but the right solution is not removing the lines. It is properly configuring the axis for the PS4 controller.

Issue History

Date Modified Username Field Change
2019-08-26 06:57 bungarra New Issue
2019-08-26 06:57 bungarra Tag Attached: C#
2019-08-26 06:57 bungarra Tag Attached: Unity
2019-08-26 11:01 sfernandez Assigned To => sfernandez
2019-08-26 11:01 sfernandez Status new => feedback
2019-08-26 11:01 sfernandez Note Added: 0005939
2019-08-27 02:34 bungarra Note Added: 0005940
2019-08-27 02:34 bungarra Status feedback => assigned
2019-08-28 18:28 jsantos Assigned To sfernandez => jsantos
2019-08-28 18:32 jsantos Note Added: 0005944
2019-08-28 18:32 jsantos Status assigned => feedback
2019-08-29 02:58 bungarra File Added: NoesisView.cs
2019-08-29 02:58 bungarra Note Added: 0005946
2019-08-29 02:58 bungarra Status feedback => assigned
2019-08-29 10:27 jsantos Note Added: 0005948
2019-08-29 10:27 jsantos Status assigned => feedback
2019-08-29 10:27 jsantos Note Edited: 0005948 View Revisions
2019-08-29 10:27 jsantos Note Edited: 0005948 View Revisions
2019-08-29 10:43 bungarra Note Added: 0005949
2019-08-29 10:43 bungarra Status feedback => assigned
2019-08-29 10:46 jsantos Note Added: 0005950
2019-08-29 10:46 jsantos Status assigned => feedback
2019-08-29 10:53 bungarra Note Added: 0005951
2019-08-29 10:53 bungarra Status feedback => assigned
2019-08-29 10:55 jsantos Note Added: 0005952
2019-11-17 18:04 jsantos Status assigned => resolved
2019-11-17 18:04 jsantos Resolution open => no change required