View Issue Details

IDProjectCategoryView StatusLast Update
0001549NoesisGUIUnity3Dpublic2020-09-14 01:56
ReporterbungarraAssigned Tojsantos 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version2.2.4 
Target VersionFixed in Version 
Summary0001549: Noesis 2.2.3 - 2.2.4 Crash, Editor and builds
DescriptionThis is the crash log of unity, We are sure that it is being caused by noesis. as it is across both 2.2.4 and 2.2.3,

we have also only been experiencing crashes in unity while only NoesisView is present.
Using unity 2019.2.2f, and HDRP by unity, with our own workaround.

we changed the rendering to be at the end of the frame

        UnityEngine.Rendering.RenderPipelineManager.beginFrameRendering += BeginCameraRendering;
        UnityEngine.Rendering.RenderPipelineManager.endFrameRendering += EndCameraRendering;

This, however, does not affect the GPUreadback. I have attached our version of NoesisView


0x00007FFA4BB39A9D (ntdll) RtlEnterCriticalSection
0x00007FFA1003ADE3 (mono-2.0-bdwgc) [c:\build\output\unity-technologies\mono\mono\metadata\image.c:2723] mono_image_alloc
0x00007FFA1000FD31 (mono-2.0-bdwgc) [c:\build\output\unity-technologies\mono\mono\metadata\class.c:2438] mono_class_setup_methods
0x00007FFA1000A534 (mono-2.0-bdwgc) [c:\build\output\unity-technologies\mono\mono\metadata\class.c:9250] mono_class_get_methods
0x00007FF6CB9D312B (Unity) scripting_class_get_method_from_name_filter
0x00007FF6CB9D2F0E (Unity) scripting_class_get_method_from_name
0x00007FF6CB9C9E83 (Unity) ScriptingInvocation::ScriptingInvocation
0x00007FF6CB1526BE (Unity) AsyncGPUReadbackManagedBuffer::InvokeScriptingCallback
0x00007FF6CB15099D (Unity) `AsyncGPUReadbackManager::InitializeClass'::`2'::EarlyUpdateUpdateAsyncReadbackManagerRegistrator::Forward
0x00007FF6CB496CA8 (Unity) ExecutePlayerLoop
0x00007FF6CB496D89 (Unity) ExecutePlayerLoop
0x00007FF6CB49BBFB (Unity) PlayerLoop
0x00007FF6C9A6F1EB (Unity) PlayerLoopController::UpdateScene
0x00007FF6C9A6CCEC (Unity) Application::TickTimer
0x00007FF6CA2FC7E0 (Unity) MainMessageLoop
0x00007FF6CA2FF1FF (Unity) WinMain
0x00007FF6CCF92742 (Unity) __scrt_common_main_seh
0x00007FFA49847974 (KERNEL32) BaseThreadInitThunk
0x00007FFA4BB9A271 (ntdll) RtlUserThreadStart
Steps To Reproducesit in any scene with noesis view with generic buttons, with styles and triggers.
TagsC#, Unity
PlatformWindows

Activities

bungarra

bungarra

2019-08-28 09:40

reporter  

NoesisView.cs (44,719 bytes)
jsantos

jsantos

2019-08-28 12:04

manager   ~0005942

The changes you made to NoesisView are not safe and even if they work they are not going to be very efficient if you have more than one camera active at the same time. I assume, you only use one camera right?

I also assume that this is only happening with HDRP right? HDRP is still quite unstable in Unity and the API is still being changed (https://www.noesisengine.com/forums/viewtopic.php?f=3&t=1669). We recommend doing the changes in the HDRP code itself, because that's the way it will work in the final version (right now, they are not invoking the callbacks).

Regarding crashes, the callstack is not as useful as a minidump, could you please attach it? (for 2.2.4)
bungarra

bungarra

2019-08-29 02:43

reporter   ~0005945

We have attached the crash dump

crash.zip (333,518 bytes)
jsantos

jsantos

2020-09-14 01:42

manager   ~0006625

This should be fixed in 3.0.X, please reopen again if you still observe the issue.

Issue History

Date Modified Username Field Change
2019-08-28 09:40 bungarra New Issue
2019-08-28 09:40 bungarra Tag Attached: C#
2019-08-28 09:40 bungarra Tag Attached: Unity
2019-08-28 09:40 bungarra File Added: NoesisView.cs
2019-08-28 12:00 jsantos Assigned To => jsantos
2019-08-28 12:00 jsantos Status new => assigned
2019-08-28 12:04 jsantos Note Added: 0005942
2019-08-29 02:43 bungarra File Added: crash.zip
2019-08-29 02:43 bungarra Note Added: 0005945
2020-09-14 01:42 jsantos Status assigned => resolved
2020-09-14 01:42 jsantos Resolution open => fixed
2020-09-14 01:42 jsantos Note Added: 0006625
2020-09-14 01:56 jsantos View Status private => public
2020-09-14 01:56 jsantos Description Updated View Revisions