View Issue Details

IDProjectCategoryView StatusLast Update
0001565NoesisGUIUnity3Dpublic2019-10-21 16:36
ReporternokolaAssigned Tosfernandez 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.5 
Target Version2.2.6Fixed in Version2.2.6 
Summary0001565: Regression from 2.2.*: Image not visible if clipped outside of screen with opacity less than 1
DescriptionAn image in XAML isn't visible when following conditions are met:
1) its opacity is < 1
2) the parent canvas Clip height is such that canvas goes beyond screen bottom edge
3) image TranslateY is such that image's bottom edge is outside the screen

See attached minimal project to reproduce
Steps To Reproduce1. Open attached project, open SampleScene
2. Run in editor -> all OK
3. In CopyPastePage.xaml, uncomment line to change canvas opacity to 0.6 (from 1):
            <!-- ATTENTION: to reproduce image disappearing change opacity to < 1, like 0.6 -->
            <!-- <Canvas IsHitTestVisible="False" Visibility="Visible" x:Name="panelClone" Opacity="0.6"> -->
            <Canvas IsHitTestVisible="False" Visibility="Visible" x:Name="panelClone" Opacity="0.9">
4. Run again
Expected: all OK
Actual: image disappears

This is a blocker for us, because we are working on a paint app and if the customer rotates their canvas to have one edge exit the screen, the whole image disappears.
TagsNo tags attached.
PlatformAny

Relationships

related to 0001574 resolvedsfernandez Opacity groups disappear when overlap bottom screen edge 
has duplicate 0001564 closedsfernandez Regression from 2.2.*: Image disappears if rendered outside of screen with clipping and opacity less than 1 

Activities

nokola

nokola

2019-10-12 18:06

reporter  

NoesisCanvasImageIssue.7z (2,962,764 bytes)

Issue History

Date Modified Username Field Change
2019-10-12 18:06 nokola New Issue
2019-10-12 18:06 nokola File Added: NoesisCanvasImageIssue.7z
2019-10-14 13:04 sfernandez Relationship added has duplicate 0001564
2019-10-14 13:04 sfernandez Assigned To => sfernandez
2019-10-14 13:04 sfernandez Status new => assigned
2019-10-14 13:04 sfernandez Target Version => 2.2.6
2019-10-14 13:04 sfernandez Description Updated View Revisions
2019-10-14 13:04 sfernandez Steps to Reproduce Updated View Revisions
2019-10-21 16:35 sfernandez Status assigned => resolved
2019-10-21 16:35 sfernandez Resolution open => fixed
2019-10-21 16:35 sfernandez Fixed in Version => 2.2.6
2019-10-21 16:36 sfernandez Relationship added related to 0001574