View Issue Details

IDProjectCategoryView StatusLast Update
0001564NoesisGUIUnity3Dpublic2019-10-14 13:04
ReporternokolaAssigned Tosfernandez 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version2.2.5 
Target VersionFixed in Version 
Summary0001564: Regression from 2.2.*: Image disappears if rendered outside of screen with clipping and opacity less than 1
DescriptionAn image in canvas isn't visible when following conditions are met:
1) it's opacity is < 1
2) the parent canvas Clip height is such that canvas goes beyond screen bottom edge
3) image TranslateY is such that image's bottom edge is outside the screen

This used to work in a past version of Noesis (OK on 2.2.1 - confirmed, not sure about the other)
See sample minimal project to reproduce
Steps To Reproduce1. Open attached project, open SampleScene
2. Run in Editor -> all OK
3. In CopyPastePage.xaml, uncomment the debug line (and comment the one below):
            <!-- ATTENTION: to reproduce image disappearing change opacity to < 1, like 0.6 -->
            <!-- <Canvas IsHitTestVisible="False" Visibility="Visible" x:Name="panelClone" Opacity="0.6"> -->
            <Canvas IsHitTestVisible="False" Visibility="Visible" x:Name="panelClone" Opacity="1">
4. Run again
Expected: all OK
Actual: image not visible

Blocker for us, since we are working on image painting program and can't rotate the canvas anymore - if the user rotates it and an edge exits the screen, the whole canvas disappears.
TagsNo tags attached.
Platform

Relationships

duplicate of 0001565 resolvedsfernandez Regression from 2.2.*: Image not visible if clipped outside of screen with opacity less than 1 

Activities

nokola

nokola

2019-10-12 18:15

reporter   ~0005991

This is duplicate of https://www.noesisengine.com/bugs/view.php?id=1565
The file upload initially failed (> 5MB) and I think the system created this bug accidentally.

Please close this bug and keep open https://www.noesisengine.com/bugs/view.php?id=1565

https://www.noesisengine.com/bugs/view.php?id=1565 has the project file attached.

Issue History

Date Modified Username Field Change
2019-10-12 18:02 nokola New Issue
2019-10-12 18:15 nokola Note Added: 0005991
2019-10-14 13:04 sfernandez Relationship added duplicate of 0001565
2019-10-14 13:04 sfernandez Assigned To => sfernandez
2019-10-14 13:04 sfernandez Status new => closed
2019-10-14 13:04 sfernandez Resolution open => duplicate