View Issue Details

IDProjectCategoryView StatusLast Update
0001604NoesisGUIUnity3Dpublic2019-12-19 17:53
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.5 
Target Version2.2.6Fixed in Version2.2.6 
Summary0001604: Keyboard/Joystick Selection Fails If Intermediary UI Element Collapsed
DescriptionGiven N focusable controls, if a control with index > 1 and < N is collapsed, keyboard and gamepad focus cannot move beyond the collapsed element. Tab selection works but keyboard (and gamepad) selection does not work. In the attached video, the following is shown:

1. All buttons are displayed. Gamepad selection and focus may traverse all visible buttons.
2. Buttons are collapsed in the middle of the container.
3. Selection may not proceed beyond the element preceding the collapsed buttons.
4. However, tab focus and selection still works.

Video:
http://stellarconquest.blob.core.windows.net/$root/Selection%20Bug.mp4

Encl. Identity Selection Control.xaml

We are submitting this as major because it is currently a release blocker for the XBOX platform and SC Alpha 2 release.


TagsNo tags attached.
PlatformAny

Activities

stonstad

stonstad

2019-12-17 16:48

reporter  

IdentitySelectionControl.cs (22,813 bytes)
IdentitySelectionControl.xaml (34,626 bytes)
stonstad

stonstad

2019-12-18 20:35

reporter   ~0006043

To clarify, I see this with containers having both collapsed and disabled user controls. Please let us know if you need anything at all to better test/recreate/resolve this behavior.
sfernandez

sfernandez

2019-12-19 12:20

manager   ~0006044

Last edited: 2019-12-19 12:22

View 2 revisions

I'm investigating the issue, and so far with basic examples like a stackpanel with buttons and even your xaml after commenting your BorderControl and RenderControl, if I hide elements in the xaml, gamepad navigation works as expected.
I will try to change the visibility in runtime from code like you do to see if that is the problem.

sfernandez

sfernandez

2019-12-19 12:38

manager   ~0006045

I've been able to reproduce it by changing visibility in code.
I'll let you know what I found.
stonstad

stonstad

2019-12-19 16:32

reporter   ~0006046

Thank goodness, thank you sir!
sfernandez

sfernandez

2019-12-19 17:53

manager   ~0006047

The problem was that directional navigation was not correctly discarding element sub-trees that were hidden/disabled, it was only checking the Visibility/IsEnabled on the individual controls.
Until we release the version (that should be very soon) you can workaround the bug by Collapsing the Buttons not the parent container.
Sorry for the inconvenience.

Issue History

Date Modified Username Field Change
2019-12-17 16:48 stonstad New Issue
2019-12-17 16:48 stonstad File Added: IdentitySelectionControl.cs
2019-12-17 16:48 stonstad File Added: IdentitySelectionControl.xaml
2019-12-17 17:46 sfernandez Assigned To => sfernandez
2019-12-17 17:46 sfernandez Status new => assigned
2019-12-17 17:46 sfernandez Target Version => 2.2.6
2019-12-17 17:46 sfernandez Description Updated View Revisions
2019-12-18 20:35 stonstad Note Added: 0006043
2019-12-19 12:20 sfernandez Note Added: 0006044
2019-12-19 12:22 sfernandez Note Edited: 0006044 View Revisions
2019-12-19 12:38 sfernandez Note Added: 0006045
2019-12-19 16:32 stonstad Note Added: 0006046
2019-12-19 17:53 sfernandez Status assigned => resolved
2019-12-19 17:53 sfernandez Resolution open => fixed
2019-12-19 17:53 sfernandez Fixed in Version => 2.2.6
2019-12-19 17:53 sfernandez Note Added: 0006047