View Issue Details

IDProjectCategoryView StatusLast Update
0001608NoesisGUIUnity3Dpublic2019-12-30 12:22
ReporterGwynnethAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0001608: StringFormat produces different symbols when using [, ] or | in the binding of a default ComboBox.
DescriptionStringFormat produces different symbols when using [, ] or | in a binding for the default ComboBox. Using a custom ComboBox does not have this problem.
Steps To ReproduceUse an ItemTemplate like the following with the default ComboBox:

                    <ComboBox.ItemTemplate>
                        <DataTemplate">
                            <TextBlock Text="{Binding Name, StringFormat='{}[Tag] |{0}| [Tag]'}" />
                        </DataTemplate>
                    </ComboBox.ItemTemplate>

The brackets will show as arrows and the pipe symbols will be double pipe symbols.
TagsNo tags attached.
PlatformWindows

Activities

sfernandez

sfernandez

2019-12-30 10:21

manager   ~0006048

Last edited: 2019-12-30 10:22

View 2 revisions

Those are the glyphs in our default font, you will see the same using them in a plain TextBlock:
<TextBlock Text="[Tag] | something | [Tag]"/>

But if you set a different FontFamily like Arial the result should be fine:
<TextBlock Text="[Tag] | something | [Tag]" FontFamily="Arial"/>


Gwynneth

Gwynneth

2019-12-30 11:07

reporter   ~0006049

That explains why it works with my custom controls. Is there a reason though why Noesis uses different glyphs in its font? Now that I know this it is easy to work around, but I reckon it could be confusing for more people. Especially since it is not documented as far as I know? Anyways, I'll leave it up to you to decide whether or not you'd like to make any changes or mark this as resolved. Now that I know the cause of this previously unknown behavior I can rest easy.
sfernandez

sfernandez

2019-12-30 12:06

manager   ~0006050

We are using ModeNine (https://www.dafont.com/modenine.font) as our default font.
We decided for that font because it is monospaced (good for showing debug stats) and it is a very small file (small memory footprint) as it gets embedded in our native library.
jsantos

jsantos

2019-12-30 12:22

manager   ~0006052

This is changing in 3.0 by the way, we are no longer going to embed that font by default. Thanks for your feedback

Issue History

Date Modified Username Field Change
2019-12-28 14:35 Gwynneth New Issue
2019-12-30 10:21 sfernandez Assigned To => sfernandez
2019-12-30 10:21 sfernandez Status new => feedback
2019-12-30 10:21 sfernandez Note Added: 0006048
2019-12-30 10:22 sfernandez Note Edited: 0006048 View Revisions
2019-12-30 11:07 Gwynneth Note Added: 0006049
2019-12-30 11:07 Gwynneth Status feedback => assigned
2019-12-30 12:06 sfernandez Status assigned => resolved
2019-12-30 12:06 sfernandez Resolution open => no change required
2019-12-30 12:06 sfernandez Note Added: 0006050
2019-12-30 12:22 jsantos Note Added: 0006052