View Issue Details

IDProjectCategoryView StatusLast Update
0001623NoesisGUIUnity3Dpublic2020-03-20 16:48
ReporterJinFoxAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version2.2.6 
Target Version3.0.0Fixed in Version3.0.0 
Summary0001623: Unity Engine Editor crashing randomly after hitting play a after having played previously.
DescriptionHello,
We are experiencing an issue at the moment where Noesis crashes randomly when we Run the editor after having played previously :
- We click "Play" do our tests.
- Click "stop".
- Then click "play again"
- The editor crashes entirely.

 It does not systematically happen at the second attempt (sometime after 3, 4 or 5 "stop then start" of the editor).

When the issue occurs, the full editor is crashing and we then have the attached crash logs.

Here is an extract of the stacktrace of when the issue occurs :
Steps To Reproduce- We click "Play" do our tests.
- Click "stop".
- Then click "play again"
- The editor crashes entirely.
TagsUnity
PlatformWindows

Activities

JinFox

JinFox

2020-02-03 10:56

reporter  

Crash_2020-01-30_170649167.zip (322,787 bytes)
sfernandez

sfernandez

2020-02-03 13:18

manager   ~0006080

Hi, we were able to find some bug in our code related to the attached crash. Please try with the following library and let me know if you still get crashes:
https://drive.google.com/open?id=1yWQS0hC4aRUqPs-eW_Q1ZhfvHGmQsa8O

If you get any more crashes please attach the dump, maybe it corresponds to another bug.

Thanks for your feedback.
JinFox

JinFox

2020-02-03 16:18

reporter   ~0006081

Hello,

Thank, you for the quick answer.
It seems that this dll does not work. No more error appear but the UI does not appear at all. I have tested Using the following steps :
1 - Clean Unity GI cache (and disabling it), to make sure no cached version of the dll was present.
2 - Close Unity Editor
3 - Swapped the Noesis.dll present in Assets\NoesisGUI\Plugins\Libraries\Windows\x86_64 byt the new one
4 - Relaunch Unity, click play
5 - UI does not show up, as if I was loading an empty xaml.

Doing the same steps and re-introducing the old dll is re-introducing the bug but the UI re-appear.

Would you have a reason for this?

Thank you again for your time.
sfernandez

sfernandez

2020-02-04 10:35

manager   ~0006082

Sorry, this one should work fine: https://drive.google.com/open?id=17HM9vlxzVRtq4S1kD4MATAeJ87d1KBzv
JinFox

JinFox

2020-02-04 11:47

reporter   ~0006083

Hello,

Unfortunately same symptoms with this version (p2), the Crash doesn't occur anymore and Noesis logs seem to be called and loading all the xamls, but the actual UI is not rendered).
sfernandez

sfernandez

2020-02-04 12:03

manager   ~0006084

It is strange, I'm testing our samples and they render fine in Unity using that library.
Could you please try with one of our sample too and confirm it also fails for you?
sfernandez

sfernandez

2020-02-04 12:06

manager   ~0006085

Forget it, I was able to reproduce the black screen with one of our samples.
I'll get back to you when I find what is happening.
sfernandez

sfernandez

2020-02-04 16:43

manager   ~0006087

Sorry for the inconvenience.

Please try with the following library: https://drive.google.com/open?id=1s3NeriOHdoc3QUFu87Zc2YOsQOKXmuwS
I tried this library and works fine with all our samples, it should work for you too.
JinFox

JinFox

2020-02-05 14:13

reporter   ~0006089

Hello sfernandez!, This one works and it seems to be solving the original problem as well! Thanks very much!

Issue History

Date Modified Username Field Change
2020-02-03 10:56 JinFox New Issue
2020-02-03 10:56 JinFox Tag Attached: Unity
2020-02-03 10:56 JinFox File Added: Crash_2020-01-30_170649167.zip
2020-02-03 12:00 sfernandez Assigned To => sfernandez
2020-02-03 12:00 sfernandez Status new => assigned
2020-02-03 13:18 sfernandez Status assigned => feedback
2020-02-03 13:18 sfernandez Note Added: 0006080
2020-02-03 16:18 JinFox Note Added: 0006081
2020-02-03 16:18 JinFox Status feedback => assigned
2020-02-04 10:35 sfernandez Status assigned => feedback
2020-02-04 10:35 sfernandez Note Added: 0006082
2020-02-04 11:47 JinFox Note Added: 0006083
2020-02-04 11:47 JinFox Status feedback => assigned
2020-02-04 12:03 sfernandez Status assigned => feedback
2020-02-04 12:03 sfernandez Note Added: 0006084
2020-02-04 12:06 sfernandez Note Added: 0006085
2020-02-04 16:43 sfernandez Note Added: 0006087
2020-02-05 14:13 JinFox Note Added: 0006089
2020-02-05 14:13 JinFox Status feedback => assigned
2020-03-20 16:48 sfernandez Status assigned => resolved
2020-03-20 16:48 sfernandez Resolution open => fixed
2020-03-20 16:48 sfernandez Fixed in Version => 3.0.0
2020-03-20 16:48 sfernandez Target Version => 3.0.0
2020-03-20 16:48 sfernandez Description Updated View Revisions
2020-03-20 16:48 sfernandez Steps to Reproduce Updated View Revisions