View Issue Details

IDProjectCategoryView StatusLast Update
0001632NoesisGUIC# SDKpublic2020-03-21 19:27
Reporterai_enabledAssigned Tojsantos 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.2.5 
Target Version3.0.0Fixed in Version3.0.0 
Summary0001632: Twemoji not supported
DescriptionHi guys,

I have success with Segoe UI Emoji but looking for a crossplatform opensource alternative.
It seems Twemoji is the most popular and used widely (e.g. Discord)

Here is the COLR version https://github.com/mozilla/twemoji-colr
However, it's rendered as blank glyphs by NoesisGUI. According to the readme:
"Systems that do not support such color fonts will show blank glyphs if they try to use this font."

Here is SVGinOT version https://github.com/eosrei/twemoji-color-font/releases
SVGinOT version results in black-and-white glyps only.

I wish to see it implemented—either COLR or SVGinOT.

Regards!
TagsNo tags attached.
PlatformAny

Activities

jsantos

jsantos

2020-03-02 20:42

manager   ~0006120

Hmm, that's strange because we already support COLR/PAL tables. That font must have something different. I will have a look at it as soon as possible.
ai_enabled

ai_enabled

2020-03-06 21:41

updater   ~0006125

Last edited: 2020-03-06 21:41

View 2 revisions

Thanks, Jesús!
I hope it could be done easily, at least for COLR version.
We want to provide certain improvements but don't have much extra time so the idea with emojis support seemed like a perfect one.

NoesisGUI works great with Segoe UI Emoji but due to Microsoft license, we cannot add it into the game Core.cpk. If we use only installed Windows font, Windows 7/8.1 customers will be unable to see the emojis...

If you know any alternative open-source emoji font please let me know. So far I've found only Twemoji and Noto Color Emoji (which is totally incompatible as it never received proper TTF support).

Regards!

jsantos

jsantos

2020-03-09 02:25

manager   ~0006126

No sure if I am trying the right font. I just downloaded v.0.5.0 from here (https://github.com/mozilla/twemoji-colr/releases) and using the attached XAML I am not able to display anything. Once we release first beta of 3.0 I will be able to analyze this with more detail but could you confirm that with the given XAML you can see black glyphs?

Twem.xaml (383 bytes)
jsantos

jsantos

2020-03-09 02:26

manager   ~0006127

By the way, skin tones and things like that are still not supported. It's been requested many times so I think this is something we will start to solve 'soon' :)
ai_enabled

ai_enabled

2020-03-09 14:47

updater   ~0006128

Last edited: 2020-03-09 14:48

View 2 revisions

Thanks for checking this.

Mozilla COLR's version of the font is indeed not rendered. I've tried it before and tried again (you can see the attached screenshot #1).

SVGinOT of the font is rendered in black glyphs.

Segoe UI Emoji works fine (see the attached screenshot #2).

I wish we can get support for Twemoji in 2.2.x as so far it's the only viable alternative to Segoe UI Emoji.
We're happy to have just basic emojis support without skin color or other options. It's way better than nothing ha-ha! Actually, it's really incredible, our players who have seen the screenshot of my experiment are totally hyped up! :-)

Regards!



Screenshot at 22-40-27.jpg (136,303 bytes)
Screenshot at 22-40-27.jpg (136,303 bytes)
jsantos

jsantos

2020-03-09 16:28

manager   ~0006129

Last edited: 2020-03-09 16:29

View 2 revisions

I would say that COLR version is broken. Not sure if related to this (https://github.com/mozilla/twemoji-colr/issues/31).

Does the font work for you out of Noesis?

SVGinOT is an incredibly complex format, we don't have plans to support it right now... This is something we need to think about again after 3.0...

ai_enabled

ai_enabled

2020-03-09 16:35

updater   ~0006130

Last edited: 2020-03-09 16:35

View 2 revisions

I've just installed it (as usual — clicked on the font -> Install) and tried in different applications. Most of my apps don't support any Emoji fonts but I had success with MailBird application and Mozilla's COLR version of Twemoji. The second screenshot is Segoe UI Emoji font.

I've simply copypasted emojis from https://getemoji.com/



Screenshot at 19-33-14.jpg (135,262 bytes)
Screenshot at 19-33-14.jpg (135,262 bytes)
Screenshot at 19-33-33.jpg (184,056 bytes)
Screenshot at 19-33-33.jpg (184,056 bytes)
jsantos

jsantos

2020-03-09 16:36

manager   ~0006131

Last edited: 2020-03-09 16:37

View 2 revisions

Could you attach the TTF here? just to make sure we are using the same version.

ai_enabled

ai_enabled

2020-03-09 16:37

updater   ~0006132

Sure, here it is:

TwemojiMozilla(2).ttf (1,244,336 bytes)
jsantos

jsantos

2020-03-20 21:18

manager   ~0006168

Last edited: 2020-03-20 21:19

View 2 revisions

Ok, finally I found time for this. The problem is, this font is not providing black and white fallback glyphs and we are expecting that. This is a bug in Noesis, I am fixing it right now in 3.0, but I am not sure when I will find time for this for 2.2. Could you create a new version of the TTF with black and white fallbacks?

I am attaching the XAML I am using and a screenshot. The font is cool!



emojis.jpg (379,908 bytes)
Emojis.xaml (7,220 bytes)
ai_enabled

ai_enabled

2020-03-20 21:25

updater   ~0006169

Good to know!
If 3.0 release is coming in mid/late April it would be fine for us :-) no need to implement this in 2.2 then. Otherwise, we would be more than happy to have the fix for 2.2.7...

I'm afraid it's too complicated to rebuild the TTF by injecting the fallback glyphs. I have no experience with this and not enough time to research the idea.

This font is great! Discord is using it so many players would be excited to see this font in their beloved games too!
jsantos

jsantos

2020-03-21 19:27

manager   ~0006170

Yes, the plan is having the final 3.0 earlier. I fixed this (took me more changes than expected to do it efficiently) and will be available in beta 4. Thansk!

Issue History

Date Modified Username Field Change
2020-03-02 20:29 ai_enabled New Issue
2020-03-02 20:29 ai_enabled Summary Twemoji COLR not supported => Twemoji not supported
2020-03-02 20:29 ai_enabled Description Updated View Revisions
2020-03-02 20:30 ai_enabled Description Updated View Revisions
2020-03-02 20:30 ai_enabled Description Updated View Revisions
2020-03-02 20:42 jsantos Note Added: 0006120
2020-03-02 20:42 jsantos Assigned To => jsantos
2020-03-02 20:42 jsantos Status new => assigned
2020-03-06 21:41 ai_enabled Note Added: 0006125
2020-03-06 21:41 ai_enabled Note Edited: 0006125 View Revisions
2020-03-09 02:25 jsantos File Added: Twem.xaml
2020-03-09 02:25 jsantos Note Added: 0006126
2020-03-09 02:25 jsantos Status assigned => feedback
2020-03-09 02:26 jsantos Note Added: 0006127
2020-03-09 02:27 jsantos Target Version => 3.0.0
2020-03-09 14:47 ai_enabled File Added: Screenshot at 17-35-45.jpg
2020-03-09 14:47 ai_enabled File Added: Screenshot at 22-40-27.jpg
2020-03-09 14:47 ai_enabled Note Added: 0006128
2020-03-09 14:47 ai_enabled Status feedback => assigned
2020-03-09 14:48 ai_enabled Note Edited: 0006128 View Revisions
2020-03-09 16:28 jsantos Note Added: 0006129
2020-03-09 16:28 jsantos Status assigned => feedback
2020-03-09 16:29 jsantos Note Edited: 0006129 View Revisions
2020-03-09 16:35 ai_enabled File Added: Screenshot at 19-33-14.jpg
2020-03-09 16:35 ai_enabled File Added: Screenshot at 19-33-33.jpg
2020-03-09 16:35 ai_enabled Note Added: 0006130
2020-03-09 16:35 ai_enabled Status feedback => assigned
2020-03-09 16:35 ai_enabled Note Edited: 0006130 View Revisions
2020-03-09 16:36 jsantos Note Added: 0006131
2020-03-09 16:36 jsantos Status assigned => feedback
2020-03-09 16:37 jsantos Note Edited: 0006131 View Revisions
2020-03-09 16:37 ai_enabled File Added: TwemojiMozilla(2).ttf
2020-03-09 16:37 ai_enabled Note Added: 0006132
2020-03-09 16:37 ai_enabled Status feedback => assigned
2020-03-20 21:18 jsantos File Added: emojis.jpg
2020-03-20 21:18 jsantos File Added: Emojis.xaml
2020-03-20 21:18 jsantos Note Added: 0006168
2020-03-20 21:18 jsantos Status assigned => feedback
2020-03-20 21:19 jsantos Note Edited: 0006168 View Revisions
2020-03-20 21:25 ai_enabled Note Added: 0006169
2020-03-20 21:25 ai_enabled Status feedback => assigned
2020-03-21 19:27 jsantos Status assigned => resolved
2020-03-21 19:27 jsantos Resolution open => fixed
2020-03-21 19:27 jsantos Fixed in Version => 3.0.0
2020-03-21 19:27 jsantos Note Added: 0006170