View Issue Details

IDProjectCategoryView StatusLast Update
0001655NoesisGUIUnity3Dpublic2020-06-11 18:29
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.0.2Fixed in Version3.0.2 
Summary0001655: DropShadowEffect And Visual Corruption w/ Virtualizing Container
DescriptionDropShadowEffect causes visual corruption in virtualizing/scrolling containers.

No Shadow.png. No DropShadowEffect applied.
Shadow OK.png. DropShadowEffect works as expected.
Shadow Broken.png. DropShadowEffect is broken.
TagsNo tags attached.
PlatformAny

Relationships

related to 0001654 resolvedsfernandez DropShadowEffect Side Effect 

Activities

stonstad

stonstad

2020-04-10 19:55

reporter  

No Shadow.PNG (82,863 bytes)
No Shadow.PNG (82,863 bytes)
Shadow OK.PNG (94,175 bytes)
Shadow OK.PNG (94,175 bytes)
Shadow Broken.PNG (28,481 bytes)
Shadow Broken.PNG (28,481 bytes)
stonstad

stonstad

2020-04-10 20:17

reporter   ~0006188

It seems like the process of adding a DropShadowEffect to a container causes it to have infinite bounds when a slider appears. If I don't add the effect the bounds of the container works as expected.
sfernandez

sfernandez

2020-04-10 20:50

manager   ~0006190

I'm unable to reproduce it, could you please create a sample project and attach it here, maybe I'm missing some configuration option.
stonstad

stonstad

2020-04-14 15:55

reporter   ~0006203

Yes -- I'll work to provide a sample project.
stonstad

stonstad

2020-04-17 18:27

reporter  

No Shadow-2.PNG (69,341 bytes)
No Shadow-2.PNG (69,341 bytes)
WithShadow.PNG (66,333 bytes)
WithShadow.PNG (66,333 bytes)
stonstad

stonstad

2020-04-29 19:05

reporter   ~0006296

Any updates on this bug/behavior?
sfernandez

sfernandez

2020-04-30 00:43

manager   ~0006298

Hi, we found the problem arises when shadow bounds intersect with window edges. It is a corner case we don't have correctly implemented.
In the meantime you can probably add to the panel a margin enough to fit the shadow inside screen size.

Issue History

Date Modified Username Field Change
2020-04-10 19:55 stonstad New Issue
2020-04-10 19:55 stonstad File Added: No Shadow.PNG
2020-04-10 19:55 stonstad File Added: Shadow OK.PNG
2020-04-10 19:55 stonstad File Added: Shadow Broken.PNG
2020-04-10 20:17 stonstad Note Added: 0006188
2020-04-10 20:50 sfernandez Assigned To => sfernandez
2020-04-10 20:50 sfernandez Status new => feedback
2020-04-10 20:50 sfernandez Note Added: 0006190
2020-04-13 16:39 jsantos Target Version => 3.0.0
2020-04-13 16:39 jsantos Description Updated View Revisions
2020-04-14 15:55 stonstad Note Added: 0006203
2020-04-14 15:55 stonstad Status feedback => assigned
2020-04-17 18:27 stonstad File Added: No Shadow-2.PNG
2020-04-17 18:27 stonstad File Added: WithShadow.PNG
2020-04-23 20:22 sfernandez Relationship added related to 0001654
2020-04-29 19:05 stonstad Note Added: 0006296
2020-04-30 00:43 sfernandez Note Added: 0006298
2020-05-25 10:56 jsantos Target Version 3.0.0 => 3.0
2020-06-11 18:29 sfernandez Status assigned => resolved
2020-06-11 18:29 sfernandez Resolution open => fixed
2020-06-11 18:29 sfernandez Fixed in Version => 3.0.2
2020-06-11 18:29 sfernandez Target Version 3.0 => 3.0.2