View Issue Details

IDProjectCategoryView StatusLast Update
0001678NoesisGUIUnity3Dpublic2020-07-30 20:05
ReporterstonstadAssigned Tojsantos 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0 
Target Version3.0.4Fixed in Version3.0.4 
Summary0001678: WebGL Build Produces Different XAML Colors
DescriptionIn the Unity editor and x86 builds, XAML themes and colors behave as expected. However, for WebGL builds I am seeing red colors appear 'washed out'. Like a linear vs gamma color space issue, or something else. The red color is defined in a resource dictionary. There are no apparent errors accessing the resource dictionary or the associated color.

Editor.png. This is how the color appears in the editor and x86 player builds.
WebGL.png. This is how the color appears in WebGL builds.

You can try it, here: https://customerselectunitysvcs.blob.core.windows.net/test/WebGL/index.html?projectid=f8ce5ffa-a2db-40d4-b4f5-deaea653353a&revision=22


TagsNo tags attached.
PlatformAny

Activities

stonstad

stonstad

2020-05-01 21:46

reporter  

Editor.PNG (205,373 bytes)
Editor.PNG (205,373 bytes)
WebGL.PNG (218,115 bytes)
WebGL.PNG (218,115 bytes)
stonstad

stonstad

2020-05-04 18:51

reporter   ~0006313

I've ruled out XAML not loading properly. This is a color issue.
jsantos

jsantos

2020-05-04 18:54

manager   ~0006314

This is related to linear rendering. It is not implemented in OpenGL/WebGL. If you disable linear rendering in Unity it should work.
stonstad

stonstad

2020-05-04 19:05

reporter   ~0006315

According to Unity it is supported: https://blogs.unity3d.com/2017/07/17/linear-rendering-support-with-webgl-2-0/ Are you saying that Noesis does not support it?
jsantos

jsantos

2020-05-04 19:07

manager   ~0006316

Yes, sorry, I was talking about Noesis. I will see if I can have this for final 3.0.0. If that's not possible it will be in 3.0.1
jsantos

jsantos

2020-05-07 12:53

manager   ~0006327

I am marking this as a feature and moving in to the 3.0 roadmap.
stonstad

stonstad

2020-05-08 16:23

reporter   ~0006336

Re: deprecation. They are continuing to make investments in WebGL. i.e. new features in 2020.1, 2020.2.
stonstad

stonstad

2020-05-18 17:33

reporter   ~0006370

Noesis licensee, MBI, has identified this as a critical issue because it prevents release of their product to the web.
jsantos

jsantos

2020-05-18 17:36

manager   ~0006371

Thanks for the feedback! 3.0.0 is locked now but we will add this feature to 3.0.1
stonstad

stonstad

2020-07-01 19:38

reporter   ~0006486

Just reaching out to see if there are any updates around this? We are unable to release to WebGL w/ Linear rendering, as Gamma changes color and post processing significantly.
jsantos

jsantos

2020-07-02 19:19

manager   ~0006496

Last edited: 2020-07-02 19:19

View 2 revisions

Hi! I have been working on this but it is taking more time than expected. If we can't finish this for 3.0.3 I will try to provide you a hotfix. Sorry for the inconvenience.

stonstad

stonstad

2020-07-06 16:35

reporter   ~0006503

Thank you -- much appreciated!
jsantos

jsantos

2020-07-28 22:27

manager   ~0006544

We just committed a fix for this. A preview can be downloaded from here. It should be compatible with 3.0.3, but I haven't checked

https://drive.google.com/file/d/16A9ZfXMoROggaF2_GcmkCIrFbkuLIwKG/view?usp=sharing

Issue History

Date Modified Username Field Change
2020-05-01 21:46 stonstad New Issue
2020-05-01 21:46 stonstad File Added: Editor.PNG
2020-05-01 21:46 stonstad File Added: WebGL.PNG
2020-05-04 13:38 sfernandez Assigned To => jsantos
2020-05-04 13:38 sfernandez Status new => assigned
2020-05-04 13:38 sfernandez Target Version => 3.0.0
2020-05-04 13:38 sfernandez Description Updated View Revisions
2020-05-04 18:51 stonstad Note Added: 0006313
2020-05-04 18:54 jsantos Note Added: 0006314
2020-05-04 19:05 stonstad Note Added: 0006315
2020-05-04 19:07 jsantos Note Added: 0006316
2020-05-07 12:52 jsantos Severity minor => feature
2020-05-07 12:53 jsantos Note Added: 0006327
2020-05-07 12:53 jsantos Target Version 3.0.0 => 3.0
2020-05-08 16:23 stonstad Note Added: 0006336
2020-05-18 17:33 stonstad Note Added: 0006370
2020-05-18 17:36 jsantos Note Added: 0006371
2020-07-01 19:38 stonstad Note Added: 0006486
2020-07-02 19:19 jsantos Note Added: 0006496
2020-07-02 19:19 jsantos Note Edited: 0006496 View Revisions
2020-07-02 19:20 jsantos Target Version 3.0 => 3.0.3
2020-07-06 16:35 stonstad Note Added: 0006503
2020-07-13 13:34 jsantos Target Version 3.0.3 => 3.0.4
2020-07-28 22:27 jsantos Note Added: 0006544
2020-07-28 22:27 jsantos Status assigned => feedback
2020-07-30 20:05 jsantos Status feedback => resolved
2020-07-30 20:05 jsantos Resolution open => fixed
2020-07-30 20:05 jsantos Fixed in Version => 3.0.4