View Issue Details

IDProjectCategoryView StatusLast Update
0001683NoesisGUIC# SDKpublic2020-06-29 20:27
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0 
Target Version3.0Fixed in Version3.0.0 
Summary0001683: SetManipulationContainerHelper Causes Fatal Crash
Description0x00007FFE878EB82B (Noesis) ManipulationStartingEventArgs_SetManipulationContainerHelper
0x00007FFE878F2379 (Noesis) ManipulationStartingEventArgs_SetManipulationContainerHelper
0x00007FFE878EC6B4 (Noesis) ManipulationStartingEventArgs_SetManipulationContainerHelper
0x00007FFE878EAB44 (Noesis) ManipulationStartingEventArgs_SetManipulationContainerHelper
0x00007FFE87A16776 (Noesis) Noesis_RegisterLogCallback
0x00007FF60746892E (Unity) GfxDeviceWorker::RunCommand
0x00007FF60747073C (Unity) GfxDeviceWorker::RunExt
0x00007FF607470B28 (Unity) GfxDeviceWorker::RunGfxDeviceWorker
0x00007FF6083046D3 (Unity) Thread::RunThreadWrapper
0x00007FFF3C787BD4 (KERNEL32) BaseThreadInitThunk
0x00007FFF3E3ECE51 (ntdll) RtlUserThreadStart
Steps To ReproduceIt happens when a starship destroys a building in Stellar Conquest. This is likely some form of user error on my part -- but the game/editor should not crash. I'll provide more information once I learn more.
TagsNo tags attached.
PlatformAny

Activities

stonstad

stonstad

2020-05-08 18:31

reporter  

Crash_2020-05-08_162809306.zip (565,993 bytes)
sfernandez

sfernandez

2020-05-08 22:05

manager   ~0006337

I generated a debug version of the library to see if hits an assert that could help me understand where the problem is coming from.
https://drive.google.com/file/d/1ncuu7WxGHdKxV5M-esLo1s-pUIPNd8CS/view?usp=sharing

Could you please try it and attach the crash dump?
stonstad

stonstad

2020-06-29 20:19

reporter   ~0006473

Hey Sergio -- I haven't seen this bug reoccur -- I think it is likely an issue that was resolved in the beta. I'm good with us closing/resolving this issue. Thank you for your assistance.
sfernandez

sfernandez

2020-06-29 20:27

manager   ~0006475

Ok, if you find this error again feel free to reopen it, thanks.

Issue History

Date Modified Username Field Change
2020-05-08 18:31 stonstad New Issue
2020-05-08 18:31 stonstad File Added: Crash_2020-05-08_162809306.zip
2020-05-08 18:32 stonstad Description Updated View Revisions
2020-05-08 18:32 stonstad Steps to Reproduce Updated View Revisions
2020-05-08 22:05 sfernandez Assigned To => sfernandez
2020-05-08 22:05 sfernandez Status new => feedback
2020-05-08 22:05 sfernandez Note Added: 0006337
2020-06-29 20:19 stonstad Note Added: 0006473
2020-06-29 20:19 stonstad Status feedback => assigned
2020-06-29 20:27 sfernandez Status assigned => resolved
2020-06-29 20:27 sfernandez Resolution open => fixed
2020-06-29 20:27 sfernandez Fixed in Version => 3.0.0
2020-06-29 20:27 sfernandez Target Version => 3.0
2020-06-29 20:27 sfernandez Note Added: 0006475