View Issue Details

IDProjectCategoryView StatusLast Update
0001686NoesisGUIC# SDKpublic2020-10-29 17:55
Reporterai_enabledAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.0.0 
Target Version3.0.7Fixed in Version 
Summary0001686: Antialiasing doesn't work when element has DropShadowEffect
DescriptionHi guys,

the DropShadowEffect is awesome but I've noticed a little issue with the rounded corners.
See the attached screenshots, pay attention to the rounded labels such as "PvP", "OFFICIAL", etc. I've tested with MSAA and PPAA. Both don't work.

I can remove rounded corners for now but I wish it could be fixed (especially if the fix is straightforward).

Good job on the DropShadowEffect overall as it allows me to add depth into the UI where necessary, and improve the text effects! :-)

Regards!
TagsNo tags attached.
PlatformAny

Relationships

related to 0001805 assignedjsantos Allow adjusting OffscreenSampleCount at any time 

Activities

ai_enabled

ai_enabled

2020-05-15 20:52

updater  

MSAA_NoShadow.png (839,656 bytes)
MSAA_WithShadow.png (876,752 bytes)
jsantos

jsantos

2020-05-20 10:58

manager   ~0006385

This is probably a silly thing but we locked 3.0.0, we will solve it in 3.0.1. Thanks for your feedback, as always!
sfernandez

sfernandez

2020-06-30 13:34

manager   ~0006478

I've been doing some tests and it looks like PPAA is not disabled when using effects. I created a xamltoy showing it: https://www.noesisengine.com/xamltoy/44de34a2f908121cca23d6d94885474c
I don't remember changing anything related in our latest releases, but could you please check again to confirm you are still having this issue?
ai_enabled

ai_enabled

2020-07-02 17:43

updater   ~0006495

Last edited: 2020-07-02 17:45

View 2 revisions

It's broken for both PPAA and MSAA as I've just checked.
The screenshot above is without the drop shadow effect and the MSAA works fine there.



sfernandez

sfernandez

2020-07-03 12:26

manager   ~0006498

So those images are using MSAA only, PPAA is not enabled when Views are created, right?
I think it makes more sense to me now, what is happening is that offscreen textures are created without the correct MSAA samples.
Can you check if, before initializing the Renderer, you are calling RenderDevice.SetOffscreenSampleCount() to the appropriate number of samples?

Have you considered using PPAA only or do you need MSAA for anything else in your game?
ai_enabled

ai_enabled

2020-09-28 13:47

updater   ~0006654

Last edited: 2020-09-28 13:52

View 2 revisions

Hi Sergio,
sorry for the late reply.

We utilize MSAA for a few other features in the game. I always prefer MSAA for NoesisGUI as it doesn't have any side effects (thicker lines). PPAA is fine when MSAA is not available or too expensive to use.

I got a chance to work on this. You're 100% right, the issue is with the OffscreenSampleCount.
The big problem here is that the game allows the player to change MSAA setting on the fly (off/2x/4x/8x). Currently, the Noesis View must be recreated in order to initialize it with new RenderDeviceD3D11 (that has new OffscreenSampleCount). Simply changing OffscreenSampleCount for the existing RenderDeviceD3D11 instance is not enough and I can guess why.

I wish we could change this on the fly as recreating a View object is a big no-no. It causes an issue with a multitude of other systems.
E.g. allowing the call to view.Renderer.Init(renderDeviceD3D11) again after it was already initialized would solve this problem (as I can change device's OffscreenSampleCount and call view.Renderer.Init). Currently, it's not supported as further access to the renderer object results in a memory access violation.

Regards!

jsantos

jsantos

2020-10-29 17:55

manager   ~0006710

Last edited: 2020-10-29 17:55

View 2 revisions

I am going to close this, as this is not related to DropShadowEffect.

Let's move the discussion to 0001805

Issue History

Date Modified Username Field Change
2020-05-15 20:52 ai_enabled New Issue
2020-05-15 20:52 ai_enabled File Added: MSAA_NoShadow.png
2020-05-15 20:52 ai_enabled File Added: MSAA_WithShadow.png
2020-05-20 10:57 jsantos Assigned To => sfernandez
2020-05-20 10:57 jsantos Status new => assigned
2020-05-20 10:58 jsantos Target Version => 3.0
2020-05-20 10:58 jsantos Note Added: 0006385
2020-06-11 21:38 jsantos Target Version 3.0 => 3.0.3
2020-06-30 13:34 sfernandez Status assigned => feedback
2020-06-30 13:34 sfernandez Note Added: 0006478
2020-07-02 17:43 ai_enabled File Added: Screenshot at 19-32-15.png
2020-07-02 17:43 ai_enabled File Added: Screenshot at 19-31-59.png
2020-07-02 17:43 ai_enabled Note Added: 0006495
2020-07-02 17:43 ai_enabled Status feedback => assigned
2020-07-02 17:45 ai_enabled Note Edited: 0006495 View Revisions
2020-07-03 12:26 sfernandez Status assigned => feedback
2020-07-03 12:26 sfernandez Note Added: 0006498
2020-07-13 13:35 jsantos Target Version 3.0.3 => 3.0.4
2020-08-02 10:56 jsantos Target Version 3.0.4 => 3.0.5
2020-09-18 14:12 jsantos Target Version 3.0.5 => 3.0.6
2020-09-25 14:00 jsantos Target Version 3.0.6 => 3.0.7
2020-09-28 13:47 ai_enabled Note Added: 0006654
2020-09-28 13:47 ai_enabled Status feedback => assigned
2020-09-28 13:52 ai_enabled Note Edited: 0006654 View Revisions
2020-10-29 17:53 jsantos Relationship added related to 0001805
2020-10-29 17:55 jsantos Status assigned => resolved
2020-10-29 17:55 jsantos Resolution open => no change required
2020-10-29 17:55 jsantos Note Added: 0006710
2020-10-29 17:55 jsantos Note Edited: 0006710 View Revisions