View Issue Details

IDProjectCategoryView StatusLast Update
0001703NoesisGUIUnity3Dpublic2020-08-31 19:21
ReporterasusralisAssigned Tojsantos 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionno change required 
Product Version2.2.6 
Target Version3.0.5Fixed in Version3.0.5 
Summary0001703: Unity editor crashes during play
DescriptionFrom forum thread https://www.noesisengine.com/forums/viewtopic.php?f=3&t=1981

 	Noesis.dll!NoesisApp::D3D11RenderDevice::WrapTexture(ID3D11Texture2D * texture, unsigned int width, unsigned int height, unsigned int levels, bool isInverted) Line 445	C++
>	Noesis.dll!NoesisApp::D3D11Factory::WrapTexture(ID3D11Texture2D * texture, unsigned int width, unsigned int height, unsigned int levels, bool isInverted) Line 28	C++
     [Inline Frame] Noesis.dll!Noesis_WrapD3D11Texture(const void *) Line 124	C++
     Noesis.dll!Noesis::UnityDeviceD3D11::WrapTexture(void * texture, int width, int height, int numLevels) Line 130	C++
     Noesis.dll!`anonymous namespace'::TextureProviderUnity::LoadTexture(const char * filename, Noesis::RenderDevice * __formal) Line 615	C++
     Noesis.dll!Noesis::VGLContext::CreateImage(const char * filename) Line 359	C++
     Noesis.dll!Noesis::BitmapImageProxy::CreateImage(Noesis::RenderTree * tree) Line 45	C++
     Noesis.dll!Noesis::ImageSourceProxy::GetImage(Noesis::RenderTree * tree) Line 34	C++
     Noesis.dll!Noesis::RenderTreeHelper::DrawCommands(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, Noesis::DrawingCommandsProxy * drawCommands, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, unsigned int bitmapScalingMode) Line 269	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderDraw(Noesis::RenderNode *) Line 684	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren(Noesis::RenderNode *) Line 701	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive(Noesis::RenderNode * node, const Noesis::Recti & surfaceRect, const Noesis::Transform2<float> & transform, const Noesis::Matrix4<float> & projection, bool isProjectionIdentity, float opacity, unsigned int depth) Line 644	C++
     Noesis.dll!Noesis::RenderTreeHelper::Render(Noesis::RenderNode * node, float x, float y, float width, float height, bool flipY) Line 128	C++
     Noesis.dll!Noesis::RenderTree::Render(float x, float y, float width, float height, bool flipY) Line 309	C++
     Noesis.dll!Noesis::Renderer::Render(bool flipY) Line 209	C++
     Noesis.dll!Noesis_GetRenderOnscreenCallback::__l2::<lambda>(int flipY, void * data) Line 454	C++
TagsNo tags attached.
PlatformAny

Activities

sfernandez

sfernandez

2020-05-27 10:55

manager  

CrashDump.7z (355,044 bytes)
sfernandez

sfernandez

2020-05-27 10:58

manager   ~0006393

This was using 2.2.6 version, could you please try latest 3.0 and let us know if you get the same kind of crashes?
asusralis

asusralis

2020-05-27 11:06

reporter   ~0006394

Hello. Sorry, I was going to create an issue but I became busy. Is 2.2.6 not going to be supported for bug fixes?
jsantos

jsantos

2020-05-28 11:22

manager   ~0006410

Last edited: 2020-05-28 11:22

View 2 revisions

Yes, but right now the priority is 3.0. If you could verify if this was fixed in 3.0 that would help us a lot. Besides, the callstack is not enough, I wonder if you have repro steps that could help us to reproduce this consistently.
Thanks!

asusralis

asusralis

2020-06-02 20:23

reporter   ~0006419

Last edited: 2020-06-02 20:24

View 2 revisions

Here it is on 3.0.1. It seems to happen often after Unity compiles changes, but I think it has happened in the past a few plays after changes have complied as well. I have no repo steps as it didn't really start at a particular time. Is there any other way to help?



Crash_2020-06-02_181836586.rar (325,535 bytes)
jsantos

jsantos

2020-06-02 20:31

manager   ~0006420

Thanks for the dump! For now this is enough, I will write here again once I have more information.
asusralis

asusralis

2020-06-02 23:54

reporter   ~0006421

Looking into it, maybe that was caused by something else? This is also in 3.0.1 and it seems closer to what I sent you before.

Crash_2020-05-31_141149363.rar (271,599 bytes)
jsantos

jsantos

2020-08-31 18:19

manager   ~0006609

Is this still happening in 3.0.4?
asusralis

asusralis

2020-08-31 18:47

reporter   ~0006610

I don't think so.
jsantos

jsantos

2020-08-31 19:21

manager   ~0006612

Ok, I am going to close it for now. Please, reopen if you see this again in the upcoming 3.0.5

Issue History

Date Modified Username Field Change
2020-05-27 10:55 sfernandez New Issue
2020-05-27 10:55 sfernandez File Added: CrashDump.7z
2020-05-27 10:58 sfernandez Reporter sfernandez => asusralis
2020-05-27 10:58 sfernandez Assigned To => jsantos
2020-05-27 10:58 sfernandez Status new => assigned
2020-05-27 10:58 sfernandez Target Version => 3.0
2020-05-27 10:58 sfernandez Description Updated View Revisions
2020-05-27 10:58 sfernandez Status assigned => feedback
2020-05-27 10:58 sfernandez Note Added: 0006393
2020-05-27 11:06 asusralis Note Added: 0006394
2020-05-27 11:06 asusralis Status feedback => assigned
2020-05-28 11:22 jsantos Note Added: 0006410
2020-05-28 11:22 jsantos Note Edited: 0006410 View Revisions
2020-05-28 11:22 jsantos Status assigned => feedback
2020-06-02 20:23 asusralis File Added: Crash_2020-06-02_181836586.rar
2020-06-02 20:23 asusralis Note Added: 0006419
2020-06-02 20:23 asusralis Status feedback => assigned
2020-06-02 20:24 asusralis Note Edited: 0006419 View Revisions
2020-06-02 20:31 jsantos Target Version 3.0 => 3.0.2
2020-06-02 20:31 jsantos Note Added: 0006420
2020-06-02 23:54 asusralis File Added: Crash_2020-05-31_141149363.rar
2020-06-02 23:54 asusralis Note Added: 0006421
2020-06-11 21:37 jsantos Target Version 3.0.2 => 3.0.3
2020-07-13 13:31 jsantos Target Version 3.0.3 => 3.0.4
2020-08-02 10:55 jsantos Target Version 3.0.4 => 3.0.5
2020-08-31 18:19 jsantos Note Added: 0006609
2020-08-31 18:19 jsantos Status assigned => feedback
2020-08-31 18:47 asusralis Note Added: 0006610
2020-08-31 18:47 asusralis Status feedback => assigned
2020-08-31 19:21 jsantos Status assigned => resolved
2020-08-31 19:21 jsantos Resolution open => no change required
2020-08-31 19:21 jsantos Fixed in Version => 3.0.5
2020-08-31 19:21 jsantos Note Added: 0006612