View Issue Details

IDProjectCategoryView StatusLast Update
0001744NoesisGUIUnity3Dpublic2020-09-22 19:46
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionno change required 
Product Version3.0.1 
Target Version3.0.6Fixed in Version3.0.6 
Summary0001744: MouseEventArgs_MiddleButton_get(), Noesis.dll Access Violation
DescriptionNoesis 3.0.1.

Noesis.dll caused an Access Violation (0xc0000005)
  in module Noesis.dll at 0033:064dc178.

Error occurred at 2020-07-01_155616.
C:\Users\stons\Source\StellarConquest\StellarConquest.Builds\StellarConquest.PC\Stellar Conquest.exe, run by stons.

67% physical memory in use.
32481 MB physical memory [10457 MB free].
8712 MB process peak paging file [8464 MB used].
4206 MB process peak working set [4094 MB used].
System Commit Total/Limit/Peak: 35452MB/39683MB/35638MB
System Physical Total/Available: 32481MB/10457MB
System Process Count: 296
System Thread Count: 4011
System Handle Count: 140254
Disk space data for 'C:\Users\stons\AppData\Local\Temp\Stellar Conquest\Stellar Conquest\Crashes\Crash_2020-07-01_205614424\': 160426635264 bytes free of 493602467840 total.

Read from location FFFFFFFF00000018 caused an access violation.

Context:
RDI: 0x00000000295d2827 RSI: 0x0000024c6f9bf658 RAX: 0xffffffff00000000
RBX: 0x00000057a42fa630 RCX: 0x0000024c6f9bf658 RDX: 0x00000057a42fa5b8
RIP: 0x00007ff8064dc178 RBP: 0x0000000000000200 SegCs: 0x0000005700000033
EFlags: 0x0000000000010202 RSP: 0x00000057a42fa510 SegSs: 0x000000570000002b
R8: 0x0000000000000200 R9: 0x0000000000000200 R10: 0x00000000000007ff
R11: 0x8080808080808080 R12: 0x00000057a42fad08 R13: 0x0000024be21ec1e0
R14: 0x0000000000000200 R15: 0x00000057a42fad20


Bytes at CS:EIP:
ff 50 18 48 8b 06 48 8d 54 24 50 48 8b ce ff 50

No mono DLL path set. This app is either running IL2CPP, or the crash occurred before mono was initialized.


Stack Trace of Crashed Thread 10780:
0x00007FF8064DC178 (Noesis) MouseEventArgs_MiddleButton_get
0x00007FF8064DC3EF (Noesis) MouseEventArgs_MiddleButton_get
0x00007FF8067188B3 (Noesis) UnityPluginUnload
0x00007FF806717E03 (Noesis) Noesis_RegisterLogCallback
0x00007FF80658ECB3 (Noesis) QueryContinueDragEventArgs_GetKeyStatesHelper
0x00007FF806775CD0 (Noesis) FreeString
0x00007FF80650492B (Noesis) BindingExpression_UpdateSource
0x00007FF8065885A6 (Noesis) ViewBase_PrepareItem
0x00007FF8065875CA (Noesis) Noesis_GetPlatformID
0x00007FF8065EFF61 (Noesis) ManipulationStartingEventArgs_Mode_get
0x00007FF8065EFBDA (Noesis) ManipulationStartingEventArgs_Mode_get
0x00007FF8065EE7C2 (Noesis) ManipulationStartingEventArgs_Mode_get
0x00007FF8065EC272 (Noesis) ManipulationStartingEventArgs_Mode_get
0x00007FF8065E9800 (Noesis) ManipulationStartingEventArgs_Mode_get
0x00007FF8065E9A6B (Noesis) ManipulationStartingEventArgs_Mode_get
0x00007FF806717271 (Noesis) Noesis_RegisterLogCallback
ERROR: SymGetSymFromAddr64, GetLastError: 'Attempt to access invalid address.' (Address: 00007FFFFEB61144)
0x00007FFFFEB61144 (UnityPlayer) (function-name not available)
ERROR: SymGetSymFromAddr64, GetLastError: 'Attempt to access invalid address.' (Address: 00007FFFFEB6701D)
0x00007FFFFEB6701D (UnityPlayer) (function-name not available)
ERROR: SymGetSymFromAddr64, GetLastError: 'Attempt to access invalid address.' (Address: 00007FFFFEB670F8)
0x00007FFFFEB670F8 (UnityPlayer) (function-name not available)
0x00007FFFFEE88B78 (UnityPlayer) UnityMain
0x00007FF88E287BD4 (KERNEL32) BaseThreadInitThunk
0x00007FF88F9ECE51 (ntdll) RtlUserThreadStart
Steps To ReproduceFast switching between XAML/Noesis UI screens in Stellar Conquest. Encl. Crash dump.
TagsNo tags attached.
PlatformAny

Activities

stonstad

stonstad

2020-07-01 23:02

reporter  

Crash_2020-07-01_205614424.zip (52,755 bytes)
stonstad

stonstad

2020-07-01 23:05

reporter   ~0006487

Last edited: 2020-07-01 23:06

View 2 revisions

Reproducibility is random when ANY screen is shown. Within Unity no errors are shown. Only happens with compiled/built binary of game.

stonstad

stonstad

2020-07-01 23:07

reporter   ~0006488

The stack trace above (MouseEventArgs_MiddleButton_get) is very suspect. At no point am I pressing the middle button. From experience, the IL2CPP compiled build stack traces are garbage stack traces.
stonstad

stonstad

2020-07-01 23:10

reporter   ~0006489

This log and dump is more brief. The crash happens in first 30 seconds of gameplay which yields a shorter log.

Crash_2020-07-01_210633473.zip (52,192 bytes)
stonstad

stonstad

2020-07-01 23:15

reporter   ~0006490

Last edited: 2020-07-01 23:17

View 2 revisions

I checked the Stellar Conquest code base and the only code which calls NoesisGUI_PINVOKE.MouseEventArgs_MiddleButton_get is Noesis class MouseEventArgs in get accessor MouseEventArgs.MiddleButton. However, this C# property has 0 references in our code. I don't know why the stack trace references this property prior to the crash/access violation in Noesis!

sfernandez

sfernandez

2020-07-06 10:47

manager   ~0006500

Without symbols the names of the functions don't usually correspond to the real callstack. In this case the crash is not related to MouseEventArgs at all, it happens when trying to load a Unity texture, its native pointer seems to be invalid.

I will prepare a library with some extra logs to try get more information.

I also noticed that In both dumps the logs contains this just before crashing:
WARNING: Shader Unsupported: 'Hidden/Nature/Terrain/Utilities' - All passes removed
WARNING: Shader Did you use #pragma only_renderers and omit this platform?
ERROR: Shader Hidden/Nature/Terrain/Utilities shader is not supported on this GPU (none of subshaders/fallbacks are suitable)
Shader 'Nature/Terrain/Diffuse': dependency 'Details2' shader 'Hidden/TerrainEngine/Details/BillboardWavingDoublePass' not found
sfernandez

sfernandez

2020-07-06 14:00

manager   ~0006501

Please try this library with "Log Verbosity" set to "Normal" in Noesis Settings:
https://drive.google.com/file/d/1r0fGHOEtkmvcQTaYI04dKS9hx_xE2aEd

Attach the dump and logs when it crashes again.

Thanks for your collaboration.
stonstad

stonstad

2020-08-17 22:10

reporter   ~0006584

Thank you for the response. I haven't been able to test Stellar Conquest but hope to return to it soon.
stonstad

stonstad

2020-09-22 19:39

reporter   ~0006642

Sergio, I haven't seen this error in over a month of active development. I think it is resolved by a subsequent release, and I'm good with us closing.

Issue History

Date Modified Username Field Change
2020-07-01 23:02 stonstad New Issue
2020-07-01 23:02 stonstad File Added: Crash_2020-07-01_205614424.zip
2020-07-01 23:05 stonstad Note Added: 0006487
2020-07-01 23:06 stonstad Note Edited: 0006487 View Revisions
2020-07-01 23:07 stonstad Note Added: 0006488
2020-07-01 23:10 stonstad File Added: Crash_2020-07-01_210633473.zip
2020-07-01 23:10 stonstad Note Added: 0006489
2020-07-01 23:15 stonstad Note Added: 0006490
2020-07-01 23:17 stonstad Note Edited: 0006490 View Revisions
2020-07-06 10:47 sfernandez Assigned To => sfernandez
2020-07-06 10:47 sfernandez Status new => feedback
2020-07-06 10:47 sfernandez Note Added: 0006500
2020-07-06 10:47 sfernandez Target Version => 3.0.3
2020-07-06 10:47 sfernandez Description Updated View Revisions
2020-07-06 14:00 sfernandez Note Added: 0006501
2020-07-13 13:36 jsantos Target Version 3.0.3 => 3.0.4
2020-08-02 10:56 jsantos Target Version 3.0.4 => 3.0.5
2020-08-17 22:10 stonstad Note Added: 0006584
2020-08-17 22:10 stonstad Status feedback => assigned
2020-09-18 14:12 jsantos Target Version 3.0.5 => 3.0.6
2020-09-22 19:39 stonstad Note Added: 0006642
2020-09-22 19:46 sfernandez Status assigned => resolved
2020-09-22 19:46 sfernandez Resolution open => no change required
2020-09-22 19:46 sfernandez Fixed in Version => 3.0.6