View Issue Details

IDProjectCategoryView StatusLast Update
0001749NoesisGUIUnity3Dpublic2020-07-09 11:15
ReporterjamiehAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.2 
Target Version3.0.3Fixed in Version3.0.3 
Summary0001749: Crash in View.Update after upgrading to 3.0
DescriptionFrom forum post https://www.noesisengine.com/forums/viewtopic.php?f=3&t=2039

Crashes happen in Unity Editor and also on Android standalone:

2020/07/07 00:08:32.285 24130 24151 Error CRASH *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
2020/07/07 00:08:32.285 24130 24151 Error CRASH Version '2019.3.15f1 (59ff3e03856d)', Build type 'Release', Scripting Backend 'mono', CPU 'armeabi-v7a'
2020/07/07 00:08:32.285 24130 24151 Error CRASH Build fingerprint: 'samsung/gta3xlwifixx/gta3xlwifi:9/PPR1.180610.011/T510XXS3ATB4:user/release-keys'
2020/07/07 00:08:32.285 24130 24151 Error CRASH Revision: '4'
2020/07/07 00:08:32.285 24130 24151 Error CRASH ABI: 'arm'
2020/07/07 00:08:32.285 24130 24151 Error CRASH Timestamp: 2020-07-07 00:08:32-0500
2020/07/07 00:08:32.285 24130 24151 Error CRASH pid: 24130, tid: 24151, name: UnityMain >>> com.DesignDepot.DynastyClient <<<
2020/07/07 00:08:32.285 24130 24151 Error CRASH uid: 10158
2020/07/07 00:08:32.285 24130 24151 Error CRASH signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x28
2020/07/07 00:08:32.285 24130 24151 Error CRASH Cause: null pointer dereference
2020/07/07 00:08:32.285 24130 24151 Error CRASH r0 bed8c780 r1 00000000 r2 00000000 r3 00000008
2020/07/07 00:08:32.285 24130 24151 Error CRASH r4 c4abd680 r5 bed8c720 r6 cf86e534 r7 cf86e560
2020/07/07 00:08:32.285 24130 24151 Error CRASH r8 00000000 r9 00000000 r10 c4abd680 r11 c1c97c40
2020/07/07 00:08:32.285 24130 24151 Error CRASH ip 00000007 sp cf86e530 lr c347ea7b pc c347ea7e
2020/07/07 00:08:32.285 24130 24151 Error CRASH
2020/07/07 00:08:32.285 24130 24151 Error CRASH backtrace:
2020/07/07 00:08:32.285 24130 24151 Error CRASH #00 pc 001d6a7e /data/app/com.DesignDepot.DynastyClient-B5R_FCxbfqD_oQWxROoGAA==/lib/arm/libNoesis.so
2020/07/07 00:08:32.285 24130 24151 Error CRASH
2020/07/07 00:08:32.285 24130 24151 Error CRASH managed backtrace:
2020/07/07 00:08:32.285 24130 24151 Error CRASH #00 (wrapper managed-to-native) Noesis.View:Noesis_View_Update (System.Runtime.InteropServices.HandleRef,double)
2020/07/07 00:08:32.286 24130 24151 Error CRASH #01 Noesis.View:Update (double) <0x57>
2020/07/07 00:08:32.286 24130 24151 Error CRASH #02 NoesisView:LateUpdate () <0xa7>
2020/07/07 00:08:32.286 24130 24151 Error CRASH #03 (wrapper runtime-invoke) object:runtime_invoke_void__this__ (object,intptr,intptr,intptr)
2020/07/07 00:08:33.006 24130 24151 Error CRASH Tombstone written to: /storage/emulated/0/Android/data/com.DesignDepot.DynastyClient/files/tombstone_01
0001/01/01 00:00:00.000 -1 -1 Info --------- beginning of crash
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime FATAL EXCEPTION: UnityMain
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime Process: com.DesignDepot.DynastyClient, PID: 24130
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime java.lang.Error: *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime Version '2019.3.15f1 (59ff3e03856d)', Build type 'Release', Scripting Backend 'mono', CPU 'armeabi-v7a'
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime Build fingerprint: 'samsung/gta3xlwifixx/gta3xlwifi:9/PPR1.180610.011/T510XXS3ATB4:user/release-keys'
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime Revision: '4'
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime ABI: 'arm'
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime Timestamp: 2020-07-07 00:08:32-0500
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime pid: 24130, tid: 24151, name: UnityMain >>> com.DesignDepot.DynastyClient <<<
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime uid: 10158
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x28
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime Cause: null pointer dereference
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime r0 bed8c780 r1 00000000 r2 00000000 r3 00000008
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime r4 c4abd680 r5 bed8c720 r6 cf86e534 r7 cf86e560
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime r8 00000000 r9 00000000 r10 c4abd680 r11 c1c97c40
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime ip 00000007 sp cf86e530 lr c347ea7b pc c347ea7e
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime backtrace:
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime #00 pc 001d6a7e /data/app/com.DesignDepot.DynastyClient-B5R_FCxbfqD_oQWxROoGAA==/lib/arm/libNoesis.so
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime managed backtrace:
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime #00 (wrapper managed-to-native) Noesis.View:Noesis_View_Update (System.Runtime.InteropServices.HandleRef,double)
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime #01 Noesis.View:Update (double) <0x57>
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime #02 NoesisView:LateUpdate () <0xa7>
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime #03 (wrapper runtime-invoke) object:runtime_invoke_void__this__ (object,intptr,intptr,intptr)
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime at libNoesis.0x1d6a7e(Native Method)
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime at Noesis.View.Noesis_View_Update (System.Runtime.InteropServices.HandleRef,double)(Native Method)
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime at Noesis.View.Update (double)(0x57:87)
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime at NoesisView.LateUpdate ()(0xa7:167)
2020/07/07 00:08:33.008 24130 24151 Error AndroidRuntime at System.Object.runtime_invoke_void__this__ (object,intptr,intptr,intptr)(Native Method)
TagsNo tags attached.
PlatformAny

Activities

sfernandez

sfernandez

2020-07-07 11:09

manager   ~0006506

When Unity crashes it creates a crash report and shows a dialog to send it to Unity, there you can find where crash data is stored in your HD, usually at C:\Users\<username>\AppData\Local\Temp\Unity\Editor\Crashes.

If that fails you can try to attach a Visual Studio instance to debug Unity (Debug > Attach to Process...). Then you can play the game in the editor and when it crashes it should stop in Visual Studio, allowing you to save a minidump (Debug > Save Dump As...).

Anyway, I will try to get the crash information from the android callstack, which version were you using, 3.0.2?
jamieh

jamieh

2020-07-07 16:46

reporter   ~0006512

Last edited: 2020-07-07 16:46

View 2 revisions

When I have VS attached, I don't get a break on the crash.

I've tried to locate the Unity crash logs, but while I can find the unity stuff in both AppData/Local and AppData/LocalLow, I'm not seeing a crash log.

I am using Noesis 3.0.2 and Unity 2019.3.15f1

The crash seems to happening in a consistent place (at the end of a "turn") so I may be able to do additional work to isolate exactly what is causing the issue. A lot of updates happen there, but I can try to isolate.

sfernandez

sfernandez

2020-07-07 17:01

manager   ~0006513

Ok, thanks for your collaboration.

Just want to remark, Unity crashes are placed in AppData/Local/TEMP/Unity/Editor/Crashes, not in AppData/Local/Unity.
And in VS you probably need to change Exception Settings under Debug > Windows > Exceptions Settings. You should toggle Win32 Exceptions, so VS break for all exceptions.
jamieh

jamieh

2020-07-08 01:39

reporter   ~0006514

I have not been able to find crash logs, but I did find a .dmp file if that is useful at all.

https://1drv.ms/u/s!AjEAlWO9Yl9unMIrXdmrkMFJKixYRw?e=SWiUQY
jamieh

jamieh

2020-07-08 02:05

reporter   ~0006515

As far as I can tell, it is crashing right after updating a class that is being tracked via PropertyChanged and triggers a bunch of buttons to enable/disable and change text. Seems pretty harmless.

I don't know that that is the cause of the crash, but that seems to be the last thing that happens before it.
sfernandez

sfernandez

2020-07-08 11:23

manager   ~0006516

Thanks for the dump, I think I have an idea on what could be happening.
I generated a new library with the possible fix, could you please try it and let me know if it worked?

https://drive.google.com/file/d/1wfiuIfIQr2P6_EW4IhzCW4qSYtKtXW3A
jamieh

jamieh

2020-07-08 18:47

reporter   ~0006521

I'm only seeing a pdb file in the zip. Was that intended?
sfernandez

sfernandez

2020-07-08 21:14

manager   ~0006523

Sorry, my bad, I uploaded the incorrect file :)
Here your are: https://drive.google.com/file/d/1zusZQX4jFdJP_iGgtuV9KBZykdBTvdzh
jamieh

jamieh

2020-07-08 22:26

reporter   ~0006524

From just very quick testing, I'm not getting the crash in the editor, at least not nearly as fast as I was before. I couldn't go through more than about 1.5 innings before without hitting it, and I just went through 4 without a problem.

I'm assuming your DLL will only fix Windows/Editor and the fix would need to be propagated to Android etc.? I tried firing up the Android build and I was still seeing the crash there.
jamieh

jamieh

2020-07-09 02:54

reporter   ~0006525

Last edited: 2020-07-09 05:58

View 2 revisions

Yeah, I've played through an entire game now without a crash. Looks like that did fix the issue.

sfernandez

sfernandez

2020-07-09 11:15

manager   ~0006526

The library I shared before was only valid for windows, android would require a different one.
The bug is now fixed for next release including all our supported platforms.

Issue History

Date Modified Username Field Change
2020-07-07 10:58 sfernandez New Issue
2020-07-07 11:02 sfernandez Reporter sfernandez => jamieh
2020-07-07 11:02 sfernandez Assigned To => sfernandez
2020-07-07 11:02 sfernandez Status new => assigned
2020-07-07 11:02 sfernandez Product Version 3.0.3 => 3.0.2
2020-07-07 11:02 sfernandez Target Version => 3.0.3
2020-07-07 11:09 sfernandez Status assigned => feedback
2020-07-07 11:09 sfernandez Note Added: 0006506
2020-07-07 16:46 jamieh Note Added: 0006512
2020-07-07 16:46 jamieh Status feedback => assigned
2020-07-07 16:46 jamieh Note Edited: 0006512 View Revisions
2020-07-07 17:01 sfernandez Note Added: 0006513
2020-07-08 01:39 jamieh Note Added: 0006514
2020-07-08 02:05 jamieh Note Added: 0006515
2020-07-08 11:23 sfernandez Status assigned => feedback
2020-07-08 11:23 sfernandez Note Added: 0006516
2020-07-08 18:47 jamieh Note Added: 0006521
2020-07-08 18:47 jamieh Status feedback => assigned
2020-07-08 21:14 sfernandez Status assigned => feedback
2020-07-08 21:14 sfernandez Note Added: 0006523
2020-07-08 22:26 jamieh Note Added: 0006524
2020-07-08 22:26 jamieh Status feedback => assigned
2020-07-09 02:54 jamieh Note Added: 0006525
2020-07-09 05:58 jamieh Note Edited: 0006525 View Revisions
2020-07-09 11:15 sfernandez Status assigned => resolved
2020-07-09 11:15 sfernandez Resolution open => fixed
2020-07-09 11:15 sfernandez Fixed in Version => 3.0.3
2020-07-09 11:15 sfernandez Note Added: 0006526