View Issue Details

IDProjectCategoryView StatusLast Update
0001750NoesisGUIC++ SDKpublic2020-07-30 20:01
ReporterExt3hAssigned Tojsantos 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version3.0.1 
Target Version3.0.4Fixed in Version3.0.4 
Summary0001750: Random crash in complex scenes
DescriptionNested ItemsControl (StackPanel, not virtualized, vertical then horizontal), rendering a total of 200 times 45 buttons. Depending on the complexity of the templates, actual numbers may need to be increased.

Expected behavior:
It's slow to compute the layout.

Actual behavior:
It's slow to compute the layout, followed by various callstacks ending up with a write access violation in these top 3 frames:

     vcruntime140.dll!memcpy() Line 243
     Noesis.dll!Noesis::DragDrop::GetClassType() + 4657 bytes
     Noesis.dll!00007ffda806bce4()
     ...
     IView::Update()

The cause is not entirely clear, but it appears to happen whenever scene complexity approaches ~30k allocations.
The system is still far from going out-of-memory (just 200MB used reported by Noesis itself), and it doesn't appear to be dependent on effective render resolution either.

Attached is a minidump for one of the crahes.
TagsNo tags attached.
PlatformWindows

Activities

Ext3h

Ext3h

2020-07-07 13:45

reporter  

complex.dmp (89,650 bytes)
jsantos

jsantos

2020-07-13 13:35

manager   ~0006533

Thanks for this, the dump contains all the information we need. There is an internal overflow in our command queue.
jsantos

jsantos

2020-07-30 20:01

manager   ~0006549

Thanks for the feedback!

Issue History

Date Modified Username Field Change
2020-07-07 13:45 Ext3h New Issue
2020-07-07 13:45 Ext3h File Added: complex.dmp
2020-07-07 13:48 Ext3h Description Updated View Revisions
2020-07-07 13:49 Ext3h Description Updated View Revisions
2020-07-08 11:27 jsantos Assigned To => sfernandez
2020-07-08 11:27 jsantos Status new => assigned
2020-07-08 11:27 jsantos Target Version => 3.0.3
2020-07-08 17:49 sfernandez Assigned To sfernandez => jsantos
2020-07-13 13:34 jsantos Target Version 3.0.3 => 3.0.4
2020-07-13 13:35 jsantos Note Added: 0006533
2020-07-30 20:01 jsantos Status assigned => resolved
2020-07-30 20:01 jsantos Resolution open => fixed
2020-07-30 20:01 jsantos Fixed in Version => 3.0.4
2020-07-30 20:01 jsantos Note Added: 0006549