View Issue Details

IDProjectCategoryView StatusLast Update
0001798NoesisGUIC++ SDKpublic2020-10-15 18:45
ReportersatorpAssigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.0.7Fixed in Version3.0.7 
Summary0001798: Memory leak when using ContextMenuService.PlacementTarget
DescriptionSpecifying context menu placement target to owner element seems to cause memory leak (reported by Noesis memory check and CRT memory leak report). Possibly caused by circular reference?
Steps To ReproduceSample XAML (TextBlock is irrelevant, also reproducible on other elements):

<TextBlock x:Name="MyText" ...
      ContextMenuService.Placement="Center"
      ContextMenuService.IsEnabled="True"
      ContextMenuService.PlacementTarget="{Binding ElementName=MyText}">
   <TextBlock.ContextMenu>...</TextBlock.ContextMenu>
</TextBlock>

Display the context menu and close application.
TagsNo tags attached.
PlatformWindows

Relationships

related to 0001707 assignedjsantos Feature request: Identify and notify the user about cyclic references 

Activities

satorp

satorp

2020-10-09 02:36

reporter   ~0006660

This issue seems not reproducible in previous versions. Is it specific to Noesis 3.0?
sfernandez

sfernandez

2020-10-13 19:51

manager   ~0006662

It seems this leak was introduced in 3.0.4 version, we'll fix it for next release.
Anyway, in this case you don't need to set the PlacementTarget property, because by default a ContextMenu uses its owner as placement target.

Issue History

Date Modified Username Field Change
2020-09-24 08:17 satorp New Issue
2020-09-24 16:38 sfernandez Relationship added related to 0001707
2020-09-24 16:38 sfernandez Assigned To => sfernandez
2020-09-24 16:38 sfernandez Status new => assigned
2020-09-24 16:38 sfernandez Target Version => 3.0
2020-10-09 02:36 satorp Note Added: 0006660
2020-10-13 19:51 sfernandez Target Version 3.0 => 3.0.7
2020-10-13 19:51 sfernandez Note Added: 0006662
2020-10-15 18:45 sfernandez Status assigned => resolved
2020-10-15 18:45 sfernandez Resolution open => fixed
2020-10-15 18:45 sfernandez Fixed in Version => 3.0.7