View Issue Details

IDProjectCategoryView StatusLast Update
0001806NoesisGUIUnity3Dpublic2020-10-19 17:11
ReporterasusralisAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.0.7Fixed in Version3.0.7 
Summary0001806: Crashing when entering play or updating XAMLs
DescriptionUnity 2019.4.1 lts.

It seems to happen randomly. I think they both are from the same issue, but I attached both one that happened from trying to enter play mode and another when updating an XAML. This was not happening on 3.0.4.
Steps To ReproduceEnter play or update an xaml.
TagsNo tags attached.
PlatformAny

Activities

asusralis

asusralis

2020-10-13 18:06

reporter  

Crash_2020-10-13_150928463.rar (342,201 bytes)
Crash_2020-10-13_160259425.rar (372,074 bytes)
sfernandez

sfernandez

2020-10-13 19:33

manager   ~0006661

Yes, both crashes point to the same problem.
I'll let you know if I need your help investigating this issue.
asusralis

asusralis

2020-10-13 22:35

reporter   ~0006663

This actually happens quite a bit now :( I'm not sure what exactly has changed.
sfernandez

sfernandez

2020-10-14 11:36

manager   ~0006664

I need more information to determine the cause of the crash so I generated a debug library with some extra logs:
https://drive.google.com/file/d/10V7MnVrGsDufmS_i_SHVk6zS9osUCCAZ/view?usp=sharing

Could you please try it and also set "Log Verbosity" to "Normal" in NoesisGUI Settings? Once it crashes please send the dump and logs as before.

Thanks for your collaboration.
asusralis

asusralis

2020-10-14 17:05

reporter  

Crash_2020-10-14_150306115.rar (307,978 bytes)
asusralis

asusralis

2020-10-14 17:09

reporter   ~0006671

I'm also now getting another crash just by clicking on any button, but it seems to have started once I put in what you sent me. This seems to be different.

Crash_2020-10-14_150810669.rar (275,220 bytes)
sfernandez

sfernandez

2020-10-14 17:41

manager   ~0006672

Latest crash was from one of the asserts I added to check something, please try this new library:
https://drive.google.com/file/d/1q6VMjOoQgV_aD8rUClK0Fxw07cv8gyvG/view?usp=sharing

If it is possible to get a copy of your unity project it would be even better as I can debug it myself faster.
asusralis

asusralis

2020-10-14 17:56

reporter  

Crash_2020-10-14_155531998.rar (314,451 bytes)
sfernandez

sfernandez

2020-10-14 19:07

manager   ~0006673

It seems you didn't enable the "Log Verbosity" = "Normal" in NoesisGUI Settings.
Could you do that so I can see the logs I'm generating to help identify this crash?
It will spam a lot of messages to Unity console but it is just for this tests.
asusralis

asusralis

2020-10-14 20:08

reporter   ~0006674

Does this work?

Crash_2020-10-14_180635802.rar (372,871 bytes)
sfernandez

sfernandez

2020-10-14 20:32

manager   ~0006675

Sorry, my fault, the verbosity level should have been set to "Binding" :(
Could you please send me the crash dump and logs again with that setting?
asusralis

asusralis

2020-10-14 21:23

reporter   ~0006676

This happened when code unrelated to Noesis was compiling.

Crash_2020-10-14_192103864.rar (385,178 bytes)
sfernandez

sfernandez

2020-10-15 00:33

manager   ~0006677

One question, what is the type of Empis.Unity.ViewModels.LoginVM.Message property?
That property returns an object that is stored in the LoginVM or it creates a new one?
asusralis

asusralis

2020-10-15 00:37

reporter   ~0006678

private NotifyMessage _message;

        public NotifyMessage Message
        {
            get => _message;
            set => Set(ref _message, value);
        }


        public class NotifyMessage
        {
            public string Body { get; }

            public bool IsError { get; }

            public NotifyMessage(string body, bool isError)
            {
                Body = body;
                IsError = isError;
            }
        }
asusralis

asusralis

2020-10-15 00:53

reporter   ~0006679

The NotifyMessage class is nested inside LoginVM.
sfernandez

sfernandez

2020-10-15 12:15

manager   ~0006680

Hi, could it be possible to get a copy of your Unity project so I can test it directly and make sure the bug is correclty fixed?
You can create a private note to avoid sharing that publicly.
sfernandez

sfernandez

2020-10-17 03:17

manager   ~0006686

Hi, I generated a new library with a patch for the crash:
https://drive.google.com/file/d/1QAOaZtCfOICjbzYwAQjx9opM-CYCIHCc/view?usp=sharing

I've been playing with the game a bit and it seems stable.
Please let me know if you find any other issues.
asusralis

asusralis

2020-10-17 03:23

reporter   ~0006687

My savior! Thanks, I'll try it out and report back if I find any problems. Sorry again for it being so involved.
asusralis

asusralis

2020-10-17 03:23

reporter   ~0006688

Did you still need access to the repo?
asusralis

asusralis

2020-10-17 03:25

reporter   ~0006689

Also, I was curious if you could summarize what the problem was? I found it interesting that Noesis was causing crashing in all those different places.
sfernandez

sfernandez

2020-10-19 10:07

manager   ~0006694

You're welcome.

If eveything is working fine for you I think you can remove that repo.

The problem was always the same, a binding that was trying to access some destroyed object because of a wrong data context change notification.
sfernandez

sfernandez

2020-10-19 17:11

manager   ~0006696

I'll mark this as solved, if you find any other issue you can create a new ticket.
Thanks a lot for you help fixing this.

Issue History

Date Modified Username Field Change
2020-10-13 18:06 asusralis New Issue
2020-10-13 18:06 asusralis File Added: Crash_2020-10-13_150928463.rar
2020-10-13 18:06 asusralis File Added: Crash_2020-10-13_160259425.rar
2020-10-13 19:33 sfernandez Assigned To => sfernandez
2020-10-13 19:33 sfernandez Status new => assigned
2020-10-13 19:33 sfernandez Category C++ SDK => Unity3D
2020-10-13 19:33 sfernandez Product Version 3.0.5 => 3.0.6
2020-10-13 19:33 sfernandez Target Version => 3.0.7
2020-10-13 19:33 sfernandez Description Updated View Revisions
2020-10-13 19:33 sfernandez Note Added: 0006661
2020-10-13 22:35 asusralis Note Added: 0006663
2020-10-14 11:36 sfernandez Status assigned => feedback
2020-10-14 11:36 sfernandez Note Added: 0006664
2020-10-14 17:05 asusralis File Added: Crash_2020-10-14_150306115.rar
2020-10-14 17:09 asusralis File Added: Crash_2020-10-14_150810669.rar
2020-10-14 17:09 asusralis Note Added: 0006671
2020-10-14 17:09 asusralis Status feedback => assigned
2020-10-14 17:41 sfernandez Status assigned => feedback
2020-10-14 17:41 sfernandez Note Added: 0006672
2020-10-14 17:56 asusralis File Added: Crash_2020-10-14_155531998.rar
2020-10-14 19:07 sfernandez Note Added: 0006673
2020-10-14 20:08 asusralis File Added: Crash_2020-10-14_180635802.rar
2020-10-14 20:08 asusralis Note Added: 0006674
2020-10-14 20:08 asusralis Status feedback => assigned
2020-10-14 20:32 sfernandez Note Added: 0006675
2020-10-14 20:32 sfernandez Status assigned => feedback
2020-10-14 21:23 asusralis File Added: Crash_2020-10-14_192103864.rar
2020-10-14 21:23 asusralis Note Added: 0006676
2020-10-14 21:23 asusralis Status feedback => assigned
2020-10-15 00:33 sfernandez Status assigned => feedback
2020-10-15 00:33 sfernandez Note Added: 0006677
2020-10-15 00:37 asusralis Note Added: 0006678
2020-10-15 00:37 asusralis Status feedback => assigned
2020-10-15 00:53 asusralis Note Added: 0006679
2020-10-15 12:15 sfernandez Status assigned => feedback
2020-10-15 12:15 sfernandez Note Added: 0006680
2020-10-15 16:45 asusralis Status feedback => assigned
2020-10-17 03:17 sfernandez Status assigned => feedback
2020-10-17 03:17 sfernandez Note Added: 0006686
2020-10-17 03:23 asusralis Note Added: 0006687
2020-10-17 03:23 asusralis Status feedback => assigned
2020-10-17 03:23 asusralis Note Added: 0006688
2020-10-17 03:25 asusralis Note Added: 0006689
2020-10-19 10:07 sfernandez Note Added: 0006694
2020-10-19 17:11 sfernandez Status assigned => resolved
2020-10-19 17:11 sfernandez Resolution open => fixed
2020-10-19 17:11 sfernandez Fixed in Version => 3.0.7
2020-10-19 17:11 sfernandez Note Added: 0006696