View Issue Details

IDProjectCategoryView StatusLast Update
0001915NoesisGUIC# SDKpublic2021-02-04 09:56
ReporterDavidYawCSpeedAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.0.9 
Target Version3.0.10Fixed in Version3.0.10 
Summary0001915: Window.Close() doesn't close, leaves artifact on screen.
DescriptionI have a quit button in my application, separate from the Window's close button.

When Window.Close() is called, the window doesn't close.

- Clicks to this window end up accessing the window behind it.
- D3D Render Context only: Instead of closing, the window changes to be solid white.
- WGL Render Context only: Instead of closing, the window never updates again. Changes to the UI are not redrawn.
Steps To Reproduce
<Button Click="QuitButtonClick" Content="Actually Quit"/>


private void QuitButtonClick(object sender, RoutedEventArgs e)
{
    this.Close();
}


Test Platform: My Windows development PC, running in the Visual Studio debugger. Using Win32Display and either RenderContextWGL or RenderContextD3D11.
TagsNo tags attached.
PlatformWindows

Relationships

related to 0001914 resolvedsfernandez Setting WindowState = WindowState.Minimized leaves artifact on screen 

Activities

sfernandez

sfernandez

2021-02-02 19:08

manager   ~0007011

I'm not able to reproduce this problem, when calling Close() the window and the application is closing fine.
All the closing logic is implemented in the Win32Display class, it shouldn't depend on what RenderContext is used.
Maybe what you are seeing is an effect of previously trying to minimize the window, which was not working as expected (issue 0001914).
sfernandez

sfernandez

2021-02-02 19:09

manager   ~0007012

Attached latest Win32Display with the fix for minimize (issue 0001914) so you can test that Close() is working fine.

Win32Display.cs (88,120 bytes)
DavidYawCSpeed

DavidYawCSpeed

2021-02-04 02:14

reporter   ~0007016

Last edited: 2021-02-04 02:15

View 2 revisions

My apologies. You are correct, this was related to my previous work with trying to minimize from code. Sorry for the false report.

sfernandez

sfernandez

2021-02-04 09:56

manager   ~0007017

Don't worry, glad to help.

Issue History

Date Modified Username Field Change
2021-02-01 21:36 DavidYawCSpeed New Issue
2021-02-01 21:36 DavidYawCSpeed Relationship added related to 0001914
2021-02-01 21:37 DavidYawCSpeed Summary Window.Close() doesn't close. => Window.Close() doesn't close, leaves artifact on screen.
2021-02-01 21:38 jsantos Assigned To => sfernandez
2021-02-01 21:38 jsantos Status new => assigned
2021-02-01 21:38 jsantos Target Version => 3.0.10
2021-02-01 21:42 DavidYawCSpeed Description Updated View Revisions
2021-02-02 19:08 sfernandez Status assigned => feedback
2021-02-02 19:08 sfernandez Note Added: 0007011
2021-02-02 19:09 sfernandez File Added: Win32Display.cs
2021-02-02 19:09 sfernandez Note Added: 0007012
2021-02-04 02:14 DavidYawCSpeed Note Added: 0007016
2021-02-04 02:14 DavidYawCSpeed Status feedback => assigned
2021-02-04 02:15 DavidYawCSpeed Note Edited: 0007016 View Revisions
2021-02-04 09:56 sfernandez Status assigned => resolved
2021-02-04 09:56 sfernandez Resolution open => no change required
2021-02-04 09:56 sfernandez Fixed in Version => 3.0.10
2021-02-04 09:56 sfernandez Note Added: 0007017