View Issue Details

IDProjectCategoryView StatusLast Update
0001968NoesisGUIUnrealpublic2021-04-15 12:52
Reportersergey_sitnikov_ninjatheoryAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.10 
Target Version3.0.12Fixed in Version3.0.12 
Summary0001968: Crash in Noesis.dll on XamlView->SetSize when using ScrollViewer with the name PART_ContentHost in TextBox template
DescriptionHello guys,

I found out that UE4 crashes in UNoesisInstance::Update trying to call XamlView->SetSize(Width, Height) when XAML uses TextBox template with a ScrollViewer that has a name PART_ContentHost.
Please let me know if you need more information on how to reproduce the issue.

Cheers,
Sergey
Steps To Reproduce1. Define a new textbox style

<Style x:Key="TextBox_Test" TargetType="{x:Type TextBox}">
    <Setter Property="Template">
        <Setter.Value>
            <ControlTemplate TargetType="{x:Type TextBox}">
                <ScrollViewer x:Name="PART_ContentHost" Focusable="false" HorizontalScrollBarVisibility="Hidden" VerticalScrollBarVisibility="Hidden"/>
            </ControlTemplate>
        </Setter.Value>
    </Setter>
</Style>

2. Use that style for the TextBox

<TextBox Style="{StaticResource TextBox_Test}" Text="HELLO"/>

3. Reimport xaml in UE4
4. Observe crash
TagsC++, TextBox, UE4, xaml
PlatformAny

Activities

sfernandez

sfernandez

2021-04-14 20:14

manager   ~0007148

Hi Sergey,

I'm not able to reproduce the crash with 3.0.10 plugin, it reimports fine.
Where are you defining the style, in the same xaml where the TextBox uses it?

Could you please collect a minidump of the crash so we can see where is coming from?
sergey_sitnikov_ninjatheory

sergey_sitnikov_ninjatheory

2021-04-15 11:39

reporter   ~0007149

Hi Sergio,

I have prepared a simple xaml that crashes 100% for me on 3.0.10. I have attached both xaml and a crash mini-dump.

UE4Minidump.dmp (1,199,952 bytes)
Gym_Text.xaml (956 bytes)
sfernandez

sfernandez

2021-04-15 12:36

manager   ~0007150

Thanks for the dump, it helped me figure out what was happening and I'm now able to reproduce it.
We'll fix it for the next release.

Issue History

Date Modified Username Field Change
2021-04-13 14:35 sergey_sitnikov_ninjatheory New Issue
2021-04-13 14:35 sergey_sitnikov_ninjatheory Status new => assigned
2021-04-13 14:35 sergey_sitnikov_ninjatheory Assigned To => hcpizzi
2021-04-13 14:35 sergey_sitnikov_ninjatheory Tag Attached: C++
2021-04-13 14:35 sergey_sitnikov_ninjatheory Tag Attached: TextBox
2021-04-13 14:35 sergey_sitnikov_ninjatheory Tag Attached: UE4
2021-04-13 14:35 sergey_sitnikov_ninjatheory Tag Attached: xaml
2021-04-13 14:36 jsantos Target Version => 3.0.12
2021-04-14 10:50 jsantos Assigned To hcpizzi => sfernandez
2021-04-14 20:14 sfernandez Status assigned => feedback
2021-04-14 20:14 sfernandez Note Added: 0007148
2021-04-15 11:39 sergey_sitnikov_ninjatheory File Added: UE4Minidump.dmp
2021-04-15 11:39 sergey_sitnikov_ninjatheory File Added: Gym_Text.xaml
2021-04-15 11:39 sergey_sitnikov_ninjatheory Note Added: 0007149
2021-04-15 11:39 sergey_sitnikov_ninjatheory Status feedback => assigned
2021-04-15 12:36 sfernandez Note Added: 0007150
2021-04-15 12:52 sfernandez Status assigned => resolved
2021-04-15 12:52 sfernandez Resolution open => fixed
2021-04-15 12:52 sfernandez Fixed in Version => 3.0.12