View Issue Details

IDProjectCategoryView StatusLast Update
0002076NoesisGUIC++ SDKpublic2021-08-30 20:12
Reporterasusralis Assigned Tosfernandez  
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version3.0.12 
Target Version3.1.1Fixed in Version3.1.1 
Summary0002076: Crash!
DescriptionI can't tell why this happens, it seems random. It continues to happen.
TagsNo tags attached.
PlatformAny

Activities

asusralis

asusralis

2021-08-07 05:39

reporter  

asusralis

asusralis

2021-08-09 11:27

reporter   ~0007346

Would it be easier if you hop into my repo or me sending a dev build? It happens quite a lot, but I can't tell where it's coming from.
sfernandez

sfernandez

2021-08-09 11:50

manager   ~0007347

The best way to find the source of the problem will be to reproduce it in your project. What steps should I follow?
I have access to your repo, which branch should I use?
asusralis

asusralis

2021-08-09 11:53

reporter   ~0007348

Use tactic-dev. New Game -> Skrimish (Humans). Settle a city. It has happened from clicking end turn, placing buildings, moving units... But I really can't tell what exactly does it. :(
asusralis

asusralis

2021-08-09 11:55

reporter   ~0007349

Here is a video that shows the bug happen. I've repeated what I've done in this video but I can't always make it crash. https://files.catbox.moe/thel0c.mp4
sfernandez

sfernandez

2021-08-09 12:56

manager   ~0007350

I'm getting

NotImplementedException: The method or operation is not implemented.
Zenject.MonoInstallerBase.InstallBindings () (at Assets/Plugins/Zenject/Source/Install/MonoInstallerBase.cs:32)

when clicking Play, probably need to install or configure something to make it work.
asusralis

asusralis

2021-08-09 12:59

reporter   ~0007351

You're on tactic-dev with commit c66aa5f5c16c74b7e4e3faa9ed9c90c27fced11a? How odd. Did you try restarting the editor? And can you send me the callstack for that?
sfernandez

sfernandez

2021-08-09 13:07

manager   ~0007352

Yes I'm on that branch and commit.

I noticed there are some scripts that can't load due to compiler errors (like AppInstaller), and reimporting Project/Source/Core I get this

Assembly 'Library/ScriptAssemblies/Assembly-CSharp.dll' will not be loaded due to errors:
Reference has errors 'Empis.Master'.

Assembly 'Library/ScriptAssemblies/Assembly-CSharp-Editor.dll' will not be loaded due to errors:
Reference has errors 'Assembly-CSharp'.

Assembly 'Assets/Plugins/Empis.Master/netstandard2.0/Empis.Master.dll' will not be loaded due to errors:
Empis.Master references strong named Microsoft.AspNetCore.Http.Features Assembly references: 2.2.0.0 Found in project: 3.1.10.0.
Assembly Version Validation can be disabled in Player Settings "Assembly Version Validation"




asusralis

asusralis

2021-08-09 13:19

reporter   ~0007353

I have no idea why this would happen. Could I send you a development build of the game?
sfernandez

sfernandez

2021-08-09 13:25

manager   ~0007354

Last edited: 2021-08-09 13:26

If I can reproduce the crash in the player then yes.

UPD: Nevermind, I closed Unity, reverted a few files that were modified by Unity and after restarting it works fine.

asusralis

asusralis

2021-08-09 13:46

reporter   ~0007355

Oh, that's great to hear!
sfernandez

sfernandez

2021-08-09 22:32

manager   ~0007357

The problem I'm seeing is that you are raising property change notifications from different threads and our objects can only be invalidated from Unity main thread.

Notify Empis.Unity.ViewModels.ProductVM.CanBuild
UnityEngine.StackTraceUtility:ExtractStackTrace ()
UnityEngine.DebugLogHandler:LogFormat (UnityEngine.LogType,UnityEngine.Object,string,object[])
UnityEngine.Logger:Log (UnityEngine.LogType,object)
UnityEngine.Debug:Log (object)
Noesis.Extend:NotifyPropertyChanged (object,System.ComponentModel.PropertyChangedEventArgs) (at Assets/NoesisGUI/Plugins/API/Core/Extend.cs:5219)
Empis.BindableObject:NotifyPropertyChanged (string) (at Assets/Project/Source/Game/BindableObject.cs:15)
Empis.BindableObject:Set<bool> (bool&,bool,string) (at Assets/Project/Source/Game/BindableObject.cs:22)
Empis.Unity.ViewModels.ProductVM:set_CanBuild (bool) (at Assets/Project/Source/ViewModels/ProductVM.cs:104)
Empis.Unity.ProducerViewer/<>c__DisplayClass46_0:<UpdateProductBindings>b__1 (Empis.Unity.ViewModels.ProductVM) (at Assets/Project/Source/Viewers/Components/ProducerViewer.cs:111)
System.Threading.Tasks.Parallel/<>c__DisplayClass31_0`2<Empis.Unity.ViewModels.ProductVM, object>:<ForEachWorker>b__0 (int)
System.Threading.Tasks.Parallel/<>c__DisplayClass17_0`1<object>:<ForWorker>b__1 ()
System.Threading.Tasks.Task:InnerInvoke ()
System.Threading.Tasks.Task:InnerInvokeWithArg (System.Threading.Tasks.Task)
System.Threading.Tasks.Task/<>c__DisplayClass178_0:<ExecuteSelfReplicating>b__0 (object)
System.Threading.Tasks.Task:InnerInvoke ()
System.Threading.Tasks.Task:Execute ()
System.Threading.Tasks.Task:ExecutionContextCallback (object)
System.Threading.ExecutionContext:RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool)
System.Threading.ExecutionContext:Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool)
System.Threading.Tasks.Task:ExecuteWithThreadLocal (System.Threading.Tasks.Task&)
System.Threading.Tasks.Task:ExecuteEntry (bool)
System.Threading.Tasks.Task:System.Threading.IThreadPoolWorkItem.ExecuteWorkItem ()
System.Threading.ThreadPoolWorkQueue:Dispatch ()
System.Threading._ThreadPoolWaitCallback:PerformWaitCallback ()
asusralis

asusralis

2021-08-10 06:56

reporter   ~0007358

I see, thanks for the info.
sfernandez

sfernandez

2021-08-30 20:12

manager   ~0007393

We added support in Unity for logging from different threads, so errors produced by using the UI elements from different threads are now properly shown.

Issue History

Date Modified Username Field Change
2021-08-07 05:39 asusralis New Issue
2021-08-07 05:39 asusralis File Added: Crash_2021-08-07_003033748.rar
2021-08-09 10:17 sfernandez Assigned To => sfernandez
2021-08-09 10:17 sfernandez Status new => assigned
2021-08-09 10:17 sfernandez Target Version => 3.1.1
2021-08-09 11:27 asusralis Note Added: 0007346
2021-08-09 11:50 sfernandez Status assigned => feedback
2021-08-09 11:50 sfernandez Note Added: 0007347
2021-08-09 11:53 asusralis Note Added: 0007348
2021-08-09 11:53 asusralis Status feedback => assigned
2021-08-09 11:55 asusralis Note Added: 0007349
2021-08-09 12:56 sfernandez Status assigned => feedback
2021-08-09 12:56 sfernandez Note Added: 0007350
2021-08-09 12:59 asusralis Note Added: 0007351
2021-08-09 12:59 asusralis Status feedback => assigned
2021-08-09 13:07 sfernandez Status assigned => feedback
2021-08-09 13:07 sfernandez Note Added: 0007352
2021-08-09 13:19 asusralis Note Added: 0007353
2021-08-09 13:19 asusralis Status feedback => assigned
2021-08-09 13:25 sfernandez Status assigned => feedback
2021-08-09 13:25 sfernandez Note Added: 0007354
2021-08-09 13:26 sfernandez Note Edited: 0007354
2021-08-09 13:46 asusralis Note Added: 0007355
2021-08-09 13:46 asusralis Status feedback => assigned
2021-08-09 22:32 sfernandez Status assigned => feedback
2021-08-09 22:32 sfernandez Note Added: 0007357
2021-08-10 06:56 asusralis Note Added: 0007358
2021-08-10 06:56 asusralis Status feedback => assigned
2021-08-30 20:12 sfernandez Status assigned => resolved
2021-08-30 20:12 sfernandez Resolution open => fixed
2021-08-30 20:12 sfernandez Fixed in Version => 3.1.1
2021-08-30 20:12 sfernandez Note Added: 0007393