View Issue Details

IDProjectCategoryView StatusLast Update
0002099NoesisGUIUnity3Dpublic2021-09-10 20:48
ReporterstonstadAssigned Tojsantos 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.0 
Target Version3.1.1Fixed in Version3.1.1 
Summary0002099: 3.1.x Upgrade Can't Find XAML
DescriptionDespite my best efforts I can't seem to get 3.1.x Noesis to find certain XAML files that worked previously in 3.0.x and that appear to have the correct file path.

My installation workflow entailed deleting all previous NoesisGUI files, and then unzipping Noesis into Assets/Plugins/NoesisGUI. My user interfaces exist in /Assets/User Interface.

I am also seeing Unity errors warning me that unique hashes are not generating correctly for Noesis created .asset files.
Importer(NativeFormatImporter) generated inconsistent result for asset(guid:b1a363256f820204e8499a5afcd2650b) "Assets/User Interface/Controls/Border Control/BorderControl.asset"

I confirmed correct file paths and dependency references in XAML. For some reason I had to keep reimporting fonts to get them to be finally found.

In some instances the issue appears to be static references in OnInitialized. I disabled preview -- but it looks like this Noesis 3.1 *may*? be calling OnInitialized in my non-variant code which has external dependencies.
Steps To ReproduceNo reproduction project yet. I can't run yet.
TagsNo tags attached.
PlatformAny

Relationships

related to 0002077 resolvedsfernandez Woes updating to 3.1 

Activities

stonstad

stonstad

2021-08-31 21:34

reporter  

Errors.PNG (93,911 bytes)
Errors.PNG (93,911 bytes)
stonstad

stonstad

2021-08-31 22:03

reporter   ~0007396

OK, the cause was a user control that had variant code in InitializeComponent. InitializeComponent was failing within Noesis code which in turn caused the XAML to not be found error to appear. The error message shown was incorrect. The new behavior would be fine if the error message was not misleading.
jsantos

jsantos

2021-08-31 22:15

manager   ~0007397

Last edited: 2021-08-31 22:17

View 2 revisions

There are many things wrong in 3.1 if you are upgrading from 3.0, we are solving all of them with the idea of having a 3.1.1 *soon*.

But just a few comments regarding your installation:

1. You shouldn't unzip the package inside /Assets. It must be extracted somewhere else, and then imported from the package manager. The steps are described in the Installation section, but I will review them to make this clearer.
2. We are no longer generating .assets file, you must remove all of them (for xaml and for fonts).

After that, our script should do a *reimport all* to make sure the importer for each XAML is 'XamlImporter' and for each font is NoesisFontImporter. This step is missing in 3.1.0 and must done manually, xaml by xaml and font by font. Yeah, far from ideal. Rigth now, if you do a Unity reimport all, fonts are properly fixed, but XAML won't be changed.

@sfernandez I know you have been doing tests importing projects from 3.0, am I missing something here?

stonstad

stonstad

2021-08-31 22:43

reporter   ~0007398

Understood. I am reading the tutorial and release notes.
stonstad

stonstad

2021-08-31 23:10

reporter   ~0007399

Last edited: 2021-08-31 23:17

View 3 revisions

I deleted the unzipped folder in Unity. I deleted all .asset files. I installed via the documented package installation process. I'm seeing lots of quirks with UI and purple backgrounds in sprites. I seem to recall this was an issue I encountered before with an undefined style. It is possible that I had customizations in theme files.

But the major issue I am seeing is a licensing error. I think I need to take a break from this release to stay productive.

* updated to note that I was successful in installing from a package.



License Error.PNG (131,834 bytes)
License Error.PNG (131,834 bytes)
sfernandez

sfernandez

2021-09-01 10:38

manager   ~0007400

I've just sent you an email with your updated license information, required for NoesisGUI 3.1.
stonstad

stonstad

2021-09-08 18:09

reporter   ~0007422

Thanks, Sergio. Much appreciated.
stonstad

stonstad

2021-09-08 18:43

reporter   ~0007423

This was all largely user error. Please feel free to close -- thank you for the help.
sfernandez

sfernandez

2021-09-08 20:26

manager   ~0007424

We'll keep it open because we should detect if user unzips the plugin inside Assets and avoid throwing a NullReferenceException in that case.
We want to fix that for the next release.
stonstad

stonstad

2021-09-10 17:45

reporter   ~0007432

"1. You shouldn't unzip the package inside /Assets. It must be extracted somewhere else, and then imported from the package manager. The steps are described in the Installation section, but I will review them to make this clearer."

Unity references the package files indefinitely from the external directory location. So although I do not store the package files in Unity I have to place them in SCM with the project. Do you put the files in a folder that is a peer to \assets?
jsantos

jsantos

2021-09-10 20:48

manager   ~0007433

Yeah, we are doing something similar to that.
jsantos

jsantos

2021-09-10 20:48

manager   ~0007434

I think we solved everything here. I am closing this.

Thanks again for your feedback!

Issue History

Date Modified Username Field Change
2021-08-31 21:34 stonstad New Issue
2021-08-31 21:34 stonstad File Added: Errors.PNG
2021-08-31 21:58 sfernandez Assigned To => jsantos
2021-08-31 21:58 sfernandez Status new => assigned
2021-08-31 21:58 sfernandez Product Version 3.1 => 3.1.0
2021-08-31 21:58 sfernandez Target Version => 3.1.1
2021-08-31 21:58 sfernandez Description Updated View Revisions
2021-08-31 22:03 stonstad Note Added: 0007396
2021-08-31 22:15 jsantos Note Added: 0007397
2021-08-31 22:17 jsantos Note Edited: 0007397 View Revisions
2021-08-31 22:17 jsantos Relationship added related to 0002077
2021-08-31 22:43 stonstad Note Added: 0007398
2021-08-31 23:10 stonstad File Added: License Error.PNG
2021-08-31 23:10 stonstad Note Added: 0007399
2021-08-31 23:16 stonstad Note Edited: 0007399 View Revisions
2021-08-31 23:17 stonstad Note Edited: 0007399 View Revisions
2021-09-01 10:38 sfernandez Note Added: 0007400
2021-09-08 18:09 stonstad Note Added: 0007422
2021-09-08 18:43 stonstad Note Added: 0007423
2021-09-08 20:26 sfernandez Note Added: 0007424
2021-09-10 17:45 stonstad Note Added: 0007432
2021-09-10 20:48 jsantos Note Added: 0007433
2021-09-10 20:48 jsantos Status assigned => resolved
2021-09-10 20:48 jsantos Resolution open => fixed
2021-09-10 20:48 jsantos Fixed in Version => 3.1.1
2021-09-10 20:48 jsantos Note Added: 0007434