View Issue Details

IDProjectCategoryView StatusLast Update
0002158NoesisGUIUnrealpublic2021-12-02 18:08
Reporterstaublicht Assigned Tohcpizzi  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.1 
Target Version3.1.2Fixed in Version3.1.2 
Summary0002158: Crash on XAML import
DescriptionUnreal version 4.27.1

I set up a XAML test project and have crash every time on XAML import. XAML is valid. I tried rebuilding the project and plugin but it didn't help with the issue.
Steps To ReproduceOpen the provided project and attempt to reimport XAML changes.
TagsUE4, ValueConverter, xaml
PlatformWindows

Activities

staublicht

staublicht

2021-10-25 15:41

reporter  

TestGUI-blend.zip (3,625,499 bytes)
XAML-import-crash.JPG (88,639 bytes)   
XAML-import-crash.JPG (88,639 bytes)   
staublicht

staublicht

2021-10-25 15:46

reporter   ~0007533

I am not experienced enough with XAML to know whether my project is for some reason invalid and can not be parsed for Noesis because I am using some special or unsupported technique. In this case I was testing inline buttons and a converter that makes text to Uppercase. It looks valid and correct in Blend.
sfernandez

sfernandez

2021-11-29 18:21

manager   ~0007625

The crash is produced by a check in the plugin about font dependencies. It is a bug we have to fix but it is happening because you are referencing system fonts in your xaml and you probably don't want to do that.

As explained in our Text tutorial (https://www.noesisengine.com/docs/Gui.Core.TextTutorial.html#font-family) if the font family does not include a folder and a family name separated by a #, then it means you are using system fonts. We recommend you use fonts included in your Unreal project, so they will work on all platforms.

staublicht

staublicht

2021-12-01 11:43

reporter   ~0007630

thank you for the information
sfernandez

sfernandez

2021-12-02 18:08

manager   ~0007631

Resolved at revision 10975.

Issue History

Date Modified Username Field Change
2021-10-25 15:41 staublicht New Issue
2021-10-25 15:41 staublicht Tag Attached: UE4
2021-10-25 15:41 staublicht Tag Attached: ValueConverter
2021-10-25 15:41 staublicht Tag Attached: xaml
2021-10-25 15:41 staublicht File Added: TestGUI-blend.zip
2021-10-25 15:41 staublicht File Added: UE4CC-Windows-85E4FAF14DA7A50A2A81029C965FC8F6_0000.zip
2021-10-25 15:41 staublicht File Added: XAML-import-crash.JPG
2021-10-25 15:46 staublicht Steps to Reproduce Updated
2021-10-25 15:46 staublicht Note Added: 0007533
2021-10-25 19:27 jsantos Assigned To => hcpizzi
2021-10-25 19:27 jsantos Status new => assigned
2021-10-25 19:27 jsantos Target Version => 3.1.2
2021-11-29 18:21 sfernandez Status assigned => feedback
2021-11-29 18:21 sfernandez Note Added: 0007625
2021-12-01 11:43 staublicht Note Added: 0007630
2021-12-01 11:43 staublicht Status feedback => assigned
2021-12-02 18:08 sfernandez Status assigned => resolved
2021-12-02 18:08 sfernandez Resolution open => fixed
2021-12-02 18:08 sfernandez Fixed in Version => 3.1.2
2021-12-02 18:08 sfernandez Note Added: 0007631