View Issue Details

IDProjectCategoryView StatusLast Update
0002165NoesisGUIC++ SDKpublic2021-11-23 20:49
ReporterLogris Assigned Tojsantos  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.1 
Target Version3.1.2Fixed in Version3.1.2 
Summary0002165: View does not resize when window Restored or Maximized
Descriptionhttps://www.noesisengine.com/forums/viewtopic.php?f=3&t=2456
TagsNo tags attached.
PlatformAny

Activities

Logris

Logris

2021-10-28 13:30

reporter   ~0007550

Last edited: 2021-10-28 14:14

Window::SetWidth() and Window::SetHeight() doesn't work either, due to validation

void Window::OnDisplaySizeChanged(Display*, uint32_t width, uint32_t height)
{
    if (width != (uint32_t)GetWidth() || height != (uint32_t)GetHeight()) !!!!!!!!!!!!!
 ...
}

Issue History

Date Modified Username Field Change
2021-10-27 13:11 Logris New Issue
2021-10-27 13:22 jsantos Assigned To => jsantos
2021-10-27 13:22 jsantos Status new => assigned
2021-10-27 13:22 jsantos Target Version => 3.1.2
2021-10-28 13:30 Logris Note Added: 0007550
2021-10-28 14:14 Logris Note Edited: 0007550
2021-11-23 20:49 jsantos Status assigned => resolved
2021-11-23 20:49 jsantos Resolution open => fixed
2021-11-23 20:49 jsantos Fixed in Version => 3.1.2