View Issue Details

IDProjectCategoryView StatusLast Update
0002229NoesisGUIC# SDKpublic2022-01-26 20:35
Reporterstonstad Assigned Tosfernandez  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.2 
Target Version3.1.3Fixed in Version3.1.3 
Summary0002229: System.Windows.Media.PathSegmentCollection Runtime Compatibility
DescriptionTrivial --

*PathSegmentCollection
PathSegmentCollection.Segments is initialized to an empty collection in the PresentationCore assembly.
PathSegmentCollection.Segments is initialized to null In Noesis.

*PathFigureCollection
PathFigureCollection.Figures is initialized to an empty collection in the PresentationCore assembly.
PathFigureCollection.Figures is initialized to null In Noesis.

I don't know if this is by design. I'm just calling attention to the departure in behavior.
TagsNo tags attached.
PlatformAny

Activities

sfernandez

sfernandez

2022-01-03 11:49

manager   ~0007705

You mean PathGeometry.Figures and PathFigure.Segments collections, right?
This happens when creating a PathGeometry or PathFigure in code.
jsantos

jsantos

2022-01-03 18:01

manager   ~0007708

https://www.noesisengine.com/forums/viewtopic.php?f=3&t=2503
stonstad

stonstad

2022-01-04 17:39

reporter   ~0007711

Re: Sergio, yes. Creating an instance of PathGeometry or PathFigure results in a null collection. I believe WPF behavior is different due to code examples showing these collections being initialized to empty instead of null. This has no impact on my projects -- I'm reporting this if code parity with WPF is desired.

Issue History

Date Modified Username Field Change
2022-01-02 20:31 stonstad New Issue
2022-01-03 11:46 sfernandez Assigned To => sfernandez
2022-01-03 11:46 sfernandez Status new => assigned
2022-01-03 11:46 sfernandez Target Version => 3.1.3
2022-01-03 11:49 sfernandez Status assigned => feedback
2022-01-03 11:49 sfernandez Note Added: 0007705
2022-01-03 18:01 jsantos Note Added: 0007708
2022-01-04 17:39 stonstad Note Added: 0007711
2022-01-04 17:39 stonstad Status feedback => assigned
2022-01-26 20:35 sfernandez Status assigned => resolved
2022-01-26 20:35 sfernandez Resolution open => fixed
2022-01-26 20:35 sfernandez Fixed in Version => 3.1.3