View Issue Details

IDProjectCategoryView StatusLast Update
0002262NoesisGUIUnity3Dpublic2022-07-13 18:25
ReporterNitae Assigned Tojsantos  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.2 
Target Version3.1.3Fixed in Version3.1.3 
Summary0002262: Unity default font cannot be used
DescriptionHi, I'm Nitae I work for Foresight Sports.
I found an issue trying to use Unity's default fonts. When I add a new font, the Noesis importer automatically changes the asset and cannot be used by the Unity Text UI.
In the font properties there is a field to change the importer from "NoesisFontImporter" to "UnityEditor.TrueTypeFontImporter (Default)", but when I try to change it, an error appears (check the screenshot).
I am using Unity 2021.2.0f1 and noesis 3.1.2 in an HDRP project
Steps To ReproduceSteps

Part 1 Unable to assign a font to Unity Text UI:
- Create a new Unity project
- Import noesis 3.1.2
- Import a .tff font
- Create a text UI in the scene
- Tries to assign the imported font to the created Text UI

Part 2 Change the importer mode:
- Select the font in the project
- Change de Importer field showed in the inspector from "NoesisFontImporter" to "UnityEditor.TrueTypeFontImporter (Default)"
TagsFonts, Unity
PlatformWindows

Relationships

has duplicate 0002377 resolvedjsantos Font Importer cannot be changed 

Activities

Nitae

Nitae

2022-02-08 00:19

reporter  

Change importer mode 1.PNG (29,245 bytes)   
Change importer mode 1.PNG (29,245 bytes)   
Change importer mode 2.PNG (123,911 bytes)   
Change importer mode 2.PNG (123,911 bytes)   
jsantos

jsantos

2022-02-08 13:11

manager   ~0007786

Changing the importer from "NoesisFontImporter" to "UnityEditor.TrueTypeFontImporter (Default)" should work. It seems the error is coming from Unity because they are still trying to render a thumbnail. I will have a look at this ASAP.

Does restarting Unity fix the issue?
Nitae

Nitae

2022-02-09 14:47

reporter   ~0007794

I already tried restarting Unity and deleting .meta files but that doesn't work.

I also did the test on a new project and the same thing happens.
jsantos

jsantos

2022-02-14 18:30

manager   ~0007807

The following patch fixes this issue
Index: NoesisPostprocessor.cs
===================================================================
--- NoesisPostprocessor.cs	(revision 11128)
+++ NoesisPostprocessor.cs	(working copy)
@@ -99,7 +99,11 @@
             else if (IsFont(assetPath))
             {
                 // Noesis uses a custom font importer that replaces Unity's default one
-                AssetDatabase.SetImporterOverride<NoesisFontImporter>(assetPath);
+                // If there is not override yet, change the importer to Noesis
+                if (AssetDatabase.GetImporterOverride(assetPath) == null)
+                {
+                    AssetDatabase.SetImporterOverride<NoesisFontImporter>(assetPath);
+                }
             }
         }
     }

Issue History

Date Modified Username Field Change
2022-02-08 00:19 Nitae New Issue
2022-02-08 00:19 Nitae Tag Attached: Fonts
2022-02-08 00:19 Nitae Tag Attached: Unity
2022-02-08 00:19 Nitae File Added: Assign Font To Unity Text UI.PNG
2022-02-08 00:19 Nitae File Added: Change importer mode 1.PNG
2022-02-08 00:19 Nitae File Added: Change importer mode 2.PNG
2022-02-08 11:35 sfernandez Assigned To => jsantos
2022-02-08 11:35 sfernandez Status new => assigned
2022-02-08 11:35 sfernandez Target Version => 3.1.3
2022-02-08 13:11 jsantos Note Added: 0007786
2022-02-08 13:11 jsantos Status assigned => feedback
2022-02-09 14:47 Nitae Note Added: 0007794
2022-02-09 14:47 Nitae Status feedback => assigned
2022-02-14 18:30 jsantos Status assigned => resolved
2022-02-14 18:30 jsantos Resolution open => fixed
2022-02-14 18:30 jsantos Fixed in Version => 3.1.3
2022-02-14 18:30 jsantos Note Added: 0007807
2022-07-13 18:25 jsantos Relationship added has duplicate 0002377