View Issue Details

IDProjectCategoryView StatusLast Update
0002286NoesisGUIUnity3Dpublic2022-02-21 16:09
Reporterstonstad Assigned Tojsantos  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.2 
Target Version3.1.3Fixed in Version3.1.3 
Summary0002286: GamePad Analog Thumbstick Cannot Navigate Dense UI
Description1. See the enclosed sample project with 4x4 grid of buttons. (GamePadBehavior.zip)
2. Navigating from button 1 to button N around the perimeter using a gamepad is easy when using the D-Pad (DPad Works.mp4).
3. Navigating from button 1 to button N around the perimeter is impossible using the left analog thumbstick from (Analog Thumbstick Broken.mp4).
4. Open the Windows 11 settings menu and navigate UI via the same left analog thumbstick. It works as expected. (Windows 11 Works.mp4).
TagsNo tags attached.
PlatformAny

Activities

stonstad

stonstad

2022-02-16 20:06

reporter  

GamePadBehavior.zip (53,548 bytes)
sfernandez

sfernandez

2022-02-16 21:34

manager   ~0007813

I was able to reproduce this issue with the following xaml:
<Grid
  xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
  xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
  Background="Black">
  <UniformGrid Width="300" Height="300" Columns="4" Rows="4" KeyboardNavigation.DirectionalNavigation="Contained">
    <Button Content="1" Margin="5"/>
    <Button Content="2" Margin="5"/>
    <Button Content="3" Margin="5"/>
    <Button Content="4" Margin="5"/>
    <Button Content="5" Margin="5"/>
    <Button Content="6" Margin="5"/>
    <Button Content="7" Margin="5"/>
    <Button Content="8" Margin="5"/>
    <Button Content="9" Margin="5"/>
    <Button Content="10" Margin="5"/>
    <Button Content="11" Margin="5"/>
    <Button Content="12" Margin="5"/>
    <Button Content="13" Margin="5"/>
    <Button Content="14" Margin="5"/>
    <Button Content="15" Margin="5"/>
    <Button Content="16" Margin="5"/>
  </UniformGrid>
</Grid>

The problem is that gamepad input actions configuration is missing the deadzones settings (Processors > Axis Deadzone), so it is not filtering out minimal movements of the stick.
stonstad

stonstad

2022-02-16 23:09

reporter   ~0007815

Thank you!

Issue History

Date Modified Username Field Change
2022-02-16 20:06 stonstad New Issue
2022-02-16 20:06 stonstad File Added: GamePadBehavior.zip
2022-02-16 20:06 stonstad File Added: DPad Works.mp4
2022-02-16 20:06 stonstad File Added: Windows 11 Works.mp4
2022-02-16 20:06 stonstad File Added: Analog Thumbstick Broken.mp4
2022-02-16 21:34 sfernandez Assigned To => jsantos
2022-02-16 21:34 sfernandez Status new => assigned
2022-02-16 21:34 sfernandez Target Version => 3.1.3
2022-02-16 21:34 sfernandez Note Added: 0007813
2022-02-16 23:09 stonstad Note Added: 0007815
2022-02-21 16:09 sfernandez Status assigned => resolved
2022-02-21 16:09 sfernandez Resolution open => fixed
2022-02-21 16:09 sfernandez Fixed in Version => 3.1.3