View Issue Details

IDProjectCategoryView StatusLast Update
0003261NoesisGUIStudiopublic2024-05-07 13:56
Reporterdstewart Assigned Tosfernandez  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Product VersionStudio_A1 
Target VersionStudio_A1Fixed in VersionStudio_A1 
Summary0003261: Grouping Root Grid into a Grid Breaks ItemTemplate Visual States
DescriptionCurrently, if you have an ItemTemplate that has Visual States applied to the root, if you Group the Root Element, the Visual States will be destroyed and no longer accessible.
Steps To ReproduceRepro Steps:

1) Create an ItemTemplate with a couple Visual States that apply changes to the Root Grid.
2) Select the Root Grid, and either press 'Ctrl+G' or right-click and select 'Format-->Group Into-->Grid'.
3) Navigate back to the Visual States Panel under the Animations tab.

Observe that the Visual States previously-created are no longer present.

Expected Results: Layer Navigator Hierarchy does not impact Visual States as long as Element names are conserved.
TagsNo tags attached.
PlatformAny

Relationships

related to 0003273 assignedsfernandez Crash Accessing Visual States of a RootGrid Recently Grouped Into Grid 

Activities

dstewart

dstewart

2024-05-07 11:43

reporter   ~0009477

Still occurs as of 0.0.104 -- new video attached
dstewart

dstewart

2024-05-07 11:43

reporter   ~0009478

sfernandez

sfernandez

2024-05-07 13:56

manager   ~0009485

The problem was with the serialization of the visual state groups, some properties were missing in the VisualTransition.

Issue History

Date Modified Username Field Change
2024-04-23 13:30 dstewart New Issue
2024-04-23 13:45 jsantos Assigned To => sfernandez
2024-04-23 13:45 jsantos Status new => assigned
2024-04-23 13:45 jsantos Target Version => Studio_A1
2024-04-24 11:27 dstewart Relationship added related to 0003273
2024-05-06 20:06 sfernandez Status assigned => resolved
2024-05-06 20:06 sfernandez Resolution open => fixed
2024-05-06 20:06 sfernandez Fixed in Version => Studio_A1
2024-05-07 11:43 dstewart Status resolved => feedback
2024-05-07 11:43 dstewart Resolution fixed => reopened
2024-05-07 11:43 dstewart Note Added: 0009477
2024-05-07 11:43 dstewart Note Added: 0009478
2024-05-07 11:43 dstewart File Added: RootGridVisualStateBreakage_Compressed.mp4
2024-05-07 11:43 dstewart Status feedback => assigned
2024-05-07 13:56 sfernandez Status assigned => resolved
2024-05-07 13:56 sfernandez Note Added: 0009485