View Issue Details

IDProjectCategoryView StatusLast Update
0003357NoesisGUIUnity3Dpublic2024-06-07 20:37
ReporterNirHasson Assigned Tojsantos  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.1 
Target Version3.2.4 
Summary0003357: Wrong Aspect Ratio when Starting on non native orientation: Android
DescriptionThe software seems to use the native dimensions of the device and use them to compute its internal aspect ratio.
The results are stretched and skew user interface.

Steps To Reproduce1. Build any application that uses Noesis GUI.
2. Rotate the target android device to its non native orientation.
3. Launch the application.
TagsNo tags attached.
PlatformAny

Activities

jsantos

jsantos

2024-06-03 12:33

manager   ~0009612

Is this using Vulkan or GL?
NirHasson

NirHasson

2024-06-03 16:32

reporter   ~0009613

OpenGL ES 3
jsantos

jsantos

2024-06-03 17:50

manager   ~0009614

Is this happening in our samples?

What is the "non native orientation" ?

Thank you
jsantos

jsantos

2024-06-03 17:51

manager   ~0009615

Last edited: 2024-06-03 17:52

If I understand this correctly, you app is not correctly transitioning between landscape and portrait right? And I assume, only the UI has this problem
NirHasson

NirHasson

2024-06-04 07:56

reporter   ~0009628

Yes, only the UI.
Try to build your samples and launch the application when the device is in landscape mode.
After that when you rotate the device everything works fine, it’s just the initial loading state issue. We used to ship our app only in landscape mode but due to this issue we can’t do it anymore.
I'm trying it with the latest version 3.2.3 but when applying my license it goes to invalid license state after a few seconds, can you also help with that?
jsantos

jsantos

2024-06-05 11:43

manager   ~0009650

I have sent you an email to solve the license issue.

Issue History

Date Modified Username Field Change
2024-06-03 11:07 NirHasson New Issue
2024-06-03 12:33 jsantos Assigned To => jsantos
2024-06-03 12:33 jsantos Status new => assigned
2024-06-03 12:33 jsantos Note Added: 0009612
2024-06-03 12:33 jsantos Status assigned => feedback
2024-06-03 16:32 NirHasson Note Added: 0009613
2024-06-03 16:32 NirHasson Status feedback => assigned
2024-06-03 17:50 jsantos Note Added: 0009614
2024-06-03 17:50 jsantos Status assigned => feedback
2024-06-03 17:51 jsantos Note Added: 0009615
2024-06-03 17:52 jsantos Note Edited: 0009615
2024-06-04 07:56 NirHasson Note Added: 0009628
2024-06-04 07:56 NirHasson Status feedback => assigned
2024-06-05 11:43 jsantos Note Added: 0009650
2024-06-05 11:43 jsantos Target Version => 3.2.4
2024-06-07 20:37 jsantos Status assigned => resolved
2024-06-07 20:37 jsantos Resolution open => no change required