View Issue Details

IDProjectCategoryView StatusLast Update
0000925NoesisGUIUnity3Dpublic2020-09-21 11:32
Reporterivan_bAssigned Tojsantos 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.6f4 
Target VersionFixed in Version 
Summary0000925: UI rendering problem on iPad
DescriptionThe user interface on the iPad at some point gets streched like in the uploaded picture. The entire user inteface is on the left of the screen. The model is an iPad 4.
TagsNo tags attached.
PlatformAny

Activities

ivan_b

ivan_b

2016-06-29 08:29

reporter  

IMG-20160628-WA0000.jpg (130,080 bytes)
IMG-20160628-WA0000.jpg (130,080 bytes)
jsantos

jsantos

2016-06-30 17:00

manager   ~0004050

Are you able to reproduce the issue someway?
ivan_b

ivan_b

2016-06-30 17:09

reporter   ~0004051

On the two iPads that I tested I could not reproduce this problem.
I can ask our user to reproduce it and then get the logs from the application if that helps?
jsantos

jsantos

2016-06-30 17:16

manager   ~0004053

Yes, please!
ivan_b

ivan_b

2016-06-30 18:14

reporter   ~0004055

Last edited: 2016-06-30 18:14

View 2 revisions

Can I get the instrumented version of Noesis for the iPad because with the current version in the logs I don't see anything?

jsantos

jsantos

2016-07-04 23:38

manager   ~0004059

Sorry for the delay about this, tomorrow I will prepare you the instrumented version.
jsantos

jsantos

2016-07-05 20:43

manager   ~0004063

Instrumented library: https://drive.google.com/file/d/0Bwxw0RW0LwyIbEpLeTE3TkktRFE/view?usp=sharing

This version generates a noesis.log file that I would like to inspect. I will also need the log generated by Unity (I think you need to generate a Developer version for this).
ivan_b

ivan_b

2016-07-07 08:54

reporter   ~0004066

Here is the link for the logs
https://www.dropbox.com/s/f1bgt66i4kv2m3y/appocation_logs.log?dl=0
Both unity logs and noesis logs are in the same file.
jsantos

jsantos

2016-07-07 09:18

manager   ~0004067

1. Why in the same file? How can I split them?
2. I am missing the Unity log there. I see a few messages at the beginning that are not from our logs but they are not definitely the Unity log. Was this a development build?
3. Could you also paste an image with the UI in normal state?
4. Is the problem being reproduced doing always the same thing? If affirmative, could you describe the steps?

Thanks a lot!
ivan_b

ivan_b

2016-07-07 09:38

reporter   ~0004068

Last edited: 2016-07-07 09:39

View 3 revisions

1.The first part is our log and the second is from noesis.
I have removed our logs from the file. You can redownload the file only with the noesis logs
2.This is a development build. This is the only log form Unity that I can get.
I am attaching an even handler to the log messages and then upload the messages to our server because we don't have access to this iPad.
3. https://www.dropbox.com/s/wdf63piy4ancu94/Screenshot_2.png?dl=0
4.The problem always appears and can be reproduced in two ways. First, at the beginning we have a listbox and after you select an item there are some animation that shrinks the listbox and movea the entire listbox to the left and after that the problem happens.
And for the second I don't kow but I can ask. If it would help I could send you the links to the application and create you an account.

jsantos

jsantos

2016-07-07 13:17

manager   ~0004069

I have an account in TestFlight: jesus.de.santos@gmail.com

Is that what you need?
ivan_b

ivan_b

2016-07-07 13:41

reporter   ~0004071

Last edited: 2016-07-07 13:50

View 2 revisions

We have a subsciption based modes so I have created you an account.
You can login with the email "jesus.de.santos@gmail.com" and the password is "test". Here is the link to the download page
http://www.hockeycoachvision.com/hcvweb/download/coach/?
If it helps the problem occours on the iPad 4.
I have investigated further and found out that some people had some rendering problem with the 5.3 version of unity on iOs, this is the link to the topic
https://community.unity.com/t5/Platforms/3D-Rendering-issues-on-iOS-with-Unity-5-3-1/td-p/2526665
Is it possible that some settings on the camera triggers that problem?
Could it be a problem with the viewport rectangle of the camera?

jsantos

jsantos

2016-07-08 12:21

manager   ~0004075

"First, at the beginning we have a listbox and after you select an item there are some animation that shrinks the listbox"

You mean for example clicking on "ANIMATIONS" right? When I do that the panel moves to the left with an animation.

I have been testing your application in iPad mini and it works great (iOS 9.3.2). By the way, the application is amazing! Although I see several improvements to the GUI (mainly, adding more animations) it is a really great work. If you want, you can publicize the application in the ShowCase section (http://www.noesisengine.com/forums/viewforum.php?f=12). Also if you want we can retweet you from our Twitter account.

Yes, the problem is related to the viewport of the camera. I added several logs in the instrumented version but what I see seems to be right. Really suspicious that it works fine in an iOS device and fails in another one, our code is exactly the same...

ivan_b

ivan_b

2016-07-08 15:46

reporter   ~0004076

You have to click on the animation an then the listbox shows
(if you want some content there is a large button at the bottom of the application, after you click on it tehre is a "Purchuased" package, click on that package and then you can download some content).
After that you click on an item and then the details of the item gets displayed, and this is the place where the problem occours.

Thanks. I would be glad to hear any suggestion for the improvement of the GUI.
I will add it to the Showcase section as soon as I find time ( probably in a few days ). No problem, you can retweet about our application.

I have sent to our user a version that logs the viewport rectangle of the camera. If the viewport has been changed I will send a bug report to unity.
jsantos

jsantos

2016-07-08 20:22

manager   ~0004077

One fast question, when you open an animation and play it showing the movement of the players? That part is not Noesis, is it? (I mean the Tactic perspective, no the 1st person one that is Unity for sure)
ivan_b

ivan_b

2016-07-08 20:36

reporter   ~0004078

It is not, i think this is implemented only with unity.
jsantos

jsantos

2020-09-14 01:46

manager   ~0006626

Is this still an issue?
ivan_b

ivan_b

2020-09-19 18:51

reporter   ~0006631

No, it is not an issue any more.
jsantos

jsantos

2020-09-21 11:32

manager   ~0006632

Thanks!

Issue History

Date Modified Username Field Change
2016-06-29 08:29 ivan_b New Issue
2016-06-29 08:29 ivan_b File Added: IMG-20160628-WA0000.jpg
2016-06-30 17:00 jsantos Note Added: 0004050
2016-06-30 17:00 jsantos Assigned To => jsantos
2016-06-30 17:00 jsantos Status new => feedback
2016-06-30 17:09 ivan_b Note Added: 0004051
2016-06-30 17:09 ivan_b Status feedback => assigned
2016-06-30 17:16 jsantos Note Added: 0004053
2016-06-30 18:14 ivan_b Note Added: 0004055
2016-06-30 18:14 ivan_b Note Edited: 0004055 View Revisions
2016-07-04 23:38 jsantos Note Added: 0004059
2016-07-05 20:43 jsantos Note Added: 0004063
2016-07-05 20:43 jsantos Status assigned => feedback
2016-07-07 08:54 ivan_b Note Added: 0004066
2016-07-07 08:54 ivan_b Status feedback => assigned
2016-07-07 09:18 jsantos Note Added: 0004067
2016-07-07 09:18 jsantos Status assigned => feedback
2016-07-07 09:38 ivan_b Note Added: 0004068
2016-07-07 09:38 ivan_b Status feedback => assigned
2016-07-07 09:38 ivan_b Note Edited: 0004068 View Revisions
2016-07-07 09:39 ivan_b Note Edited: 0004068 View Revisions
2016-07-07 13:17 jsantos Note Added: 0004069
2016-07-07 13:17 jsantos Status assigned => feedback
2016-07-07 13:41 ivan_b Note Added: 0004071
2016-07-07 13:41 ivan_b Status feedback => assigned
2016-07-07 13:50 ivan_b Note Edited: 0004071 View Revisions
2016-07-08 12:21 jsantos Note Added: 0004075
2016-07-08 12:21 jsantos Status assigned => feedback
2016-07-08 15:46 ivan_b Note Added: 0004076
2016-07-08 15:46 ivan_b Status feedback => assigned
2016-07-08 20:22 jsantos Note Added: 0004077
2016-07-08 20:22 jsantos Status assigned => feedback
2016-07-08 20:36 ivan_b Note Added: 0004078
2016-07-08 20:36 ivan_b Status feedback => assigned
2018-11-01 02:14 jsantos View Status public => private
2020-09-14 01:46 jsantos Status assigned => feedback
2020-09-14 01:46 jsantos Note Added: 0006626
2020-09-14 01:55 jsantos View Status private => public
2020-09-14 01:55 jsantos Platform => Any
2020-09-19 18:51 ivan_b Note Added: 0006631
2020-09-19 18:51 ivan_b Status feedback => assigned
2020-09-21 11:32 jsantos Status assigned => resolved
2020-09-21 11:32 jsantos Resolution open => fixed
2020-09-21 11:32 jsantos Note Added: 0006632