Jamieh
Topic Author
Posts: 44
Joined: 12 Apr 2019, 00:30

Issues with Alpha Transparency after upgrade to 3.0/Unity 2019.3

26 Jun 2020, 17:30

When I upgraded our Unity project to Noesis 3.0/Unity 2019.3, I've run into an alpha transparency issue. I'm overlaying transparent images onto another (non-transparent) image, and the edges of the transparent image are all raggedy now.

Image in currently released version:
https://1drv.ms/u/s!AjEAlWO9Yl9unMIm1E4 ... g?e=Fczjp7

After upgrade:
https://1drv.ms/u/s!AjEAlWO9Yl9unMIlIJL ... A?e=HFErI0

I still have a script to do Alpha Pre Multiplication in my Assets/Editor folder. I also tried to manually do the pre-multiplication before importing. I'm wondering if I just forgot the settings I used to import from before.

If you have an idea of what I should try to make this work it would be great. Thanks!
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Issues with Alpha Transparency after upgrade to 3.0/Unity 2019.3

26 Jun 2020, 17:38

Could you verify that those images have the Noesis label applied?
Try to reimport them after setting the label and let me know if that solved the problem.
 
Jamieh
Topic Author
Posts: 44
Joined: 12 Apr 2019, 00:30

Re: Issues with Alpha Transparency after upgrade to 3.0/Unity 2019.3

26 Jun 2020, 18:26

Ok I feel a bit foolish here. How do I add the Asset Label? I've done some quick searching but I must be missing something.
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Issues with Alpha Transparency after upgrade to 3.0/Unity 2019.3

26 Jun 2020, 18:59

Select the image asset in the project. In the Inspector panel at the bottom right there is a small round blue icon that will popup a list of labels when clicked. Select or write Noesis. Then reimport the asset.
 
Jamieh
Topic Author
Posts: 44
Joined: 12 Apr 2019, 00:30

Re: Issues with Alpha Transparency after upgrade to 3.0/Unity 2019.3

27 Jun 2020, 00:10

Ok, thanks. So I added the Noesis tag to all my images and reimported as the docs said (Default, Alpha is Transparent checked off).

I'm still seeing the issue around the edges. What else could I be doing wrong?
 
Jamieh
Topic Author
Posts: 44
Joined: 12 Apr 2019, 00:30

Re: Issues with Alpha Transparency after upgrade to 3.0/Unity 2019.3

27 Jun 2020, 03:08

Solved--User error. Amazing how no matter how many times you alter an image, if you aren't actually using that image in your program, it doesn't fix the problem. :)

I have no idea why I had a duplicated Images folder in the project, but I was re-importing the wrong one. Time for project clean up!

Sorry for wasting your time.
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Issues with Alpha Transparency after upgrade to 3.0/Unity 2019.3

29 Jun 2020, 11:01

No problem, thanks for the update :)

Who is online

Users browsing this forum: No registered users and 1 guest