Dvd
Topic Author
Posts: 2
Joined: 23 Feb 2021, 06:16

Couldn't decompress NoesisGUI-3.0.10.unitypackage

23 Feb 2021, 07:06

I downloaded NoesisGUI-3.0.10.unitypackage just now from https://www.noesisengine.com/developers/downloads.php and Unity was unable to extract it.

I'm currently on Unity 2019.4.18f1 using Windows 10 Pro. The documentation at https://www.noesisengine.com/docs/Gui.C ... orial.html didn't seem to mention a specific Unity build.

The error was "Failed to import package with error: Couldn't decompress package".

I checked the archive with 7zip and 7zip reported a CRC error on the archtemp.tar in the archive.
When I sanity checked a known working unitypackage with 7zip, there were no errors reported.

I checked my path (no spaces or weird characters), free disk space (100+ gb), and a dozen other suggestions on the Unity forum for what could cause this error.
I also searched this forum for this error and couldn't find it mentioned here.
 
Dvd
Topic Author
Posts: 2
Joined: 23 Feb 2021, 06:16

Re: Couldn't decompress NoesisGUI-3.0.10.unitypackage

23 Feb 2021, 07:12

For anyone else who runs into this, I was able to download the package from viewtopic.php?f=14&t=1923 and install that one. I'm not sure why the other download didn't work.

Who is online

Users browsing this forum: Google [Bot], MiBa and 1 guest