View Issue Details

IDProjectCategoryView StatusLast Update
0001459NoesisGUIUnity3Dpublic2019-04-30 18:20
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0001459: Noesis DLL Crash on Alt-Tab to Unity or Play Clicked
DescriptionI am using Unity 2019.1.0f2 with Noesis 2.2.2. This happens with 2.2.1 as well.

The Unity editor is fatally crashing every time I alt-tab into the editor or play, stop, and hit play again. Here is the last thing in the Unity editor file.

Refresh: detecting if any assets need to be imported or removed ...

Refresh Completed time: 0.239306s
Asset Scan time: 0.235643s
Asset Hashing: 0.000000s [0 B, 0.000000 mb/s]
Asset Import (Scripting) time: 0.000000s (count: 0)
Post Processs Assets (Scripting) time: 0.000000s
Asset Rehashing: 0.000000s [0 B, 0.000000 mb/s]
Asset Import (Non Scripting) time: 0.000000s (count: 0)
Post Process Assets (Non Scripting) time: 0.000000s
Dependent Assets to Import Queue time: 0.000000s

Reloading assemblies for play mode.
Begin MonoManager ReloadAssembly

Unity does not create a crash dump. I attached Visual Studio to Unity.exe to get the exception and call stack without symbols. I'm including a dump file.

Fatal crash details (no symbols): https://i.imgur.com/8FJ94te.png
Fatal crash call stack (no symbols): https://i.imgur.com/s9cW8gp.png

This issue is causing significant work stoppage due to the frequency and criticality of the error.

Steps To ReproduceI'm sure this is project specific. Let me know if the dump file is not sufficient.
TagsNo tags attached.
PlatformAny

Relationships

has duplicate 0001452 resolvedjsantos Noesis Crashes Unity Sometimes When Editor Window Resizes 

Activities

stonstad

stonstad

2019-04-29 19:24

reporter  

Unity.dmp (1,378,367 bytes)
stonstad

stonstad

2019-04-29 20:32

reporter   ~0005650

This happens when l play once (successfully). I then stop playback. Now, if I alt-tab away and back, minimize, maximize, or hit play again, the editor crashes. Noesis.dll throws a fatal exception corresponding to the minidump shared above.
stonstad

stonstad

2019-04-30 03:08

reporter   ~0005651

I can try with a debug build or with symbols is it is helpful to you.
sfernandez

sfernandez

2019-04-30 09:30

manager   ~0005655

The crash dump points me it is related with the View.Rendering event, could you please confirm you are using it in your game?
If you remove all the handlers subscribed to the event, are the crashes no longer happening?
sfernandez

sfernandez

2019-04-30 14:31

manager   ~0005658

We were able to reproduce the crash and fix it, could you please try the following library (win-x86_64) and confirm it is working for you:
https://drive.google.com/open?id=1ok2dsFzrIrjlyRTx1S-wd4VcqfkanpRW
stonstad

stonstad

2019-04-30 15:25

reporter   ~0005659

Yes! I can confirm the fix and the workflow is resolved.

re: Rendering event. I do hook this event but I made sure to disable it during testing. Before trying the new DLL I retested and commented out all event subscription for Rendering (and it still crashed). I have log statements to make sure I unregister View.Rendering when the event consumer/UserControl is unloaded.

Thank you for the quick turn around -- I am very grateful for your timely assistance resolving this!

Issue History

Date Modified Username Field Change
2019-04-29 19:24 stonstad New Issue
2019-04-29 19:24 stonstad File Added: Unity.dmp
2019-04-29 20:32 stonstad Note Added: 0005650
2019-04-29 23:51 sfernandez Assigned To => sfernandez
2019-04-29 23:51 sfernandez Status new => assigned
2019-04-30 03:08 stonstad Note Added: 0005651
2019-04-30 09:30 sfernandez Status assigned => feedback
2019-04-30 09:30 sfernandez Note Added: 0005655
2019-04-30 10:13 sfernandez Target Version => 2.2.3
2019-04-30 10:13 sfernandez Description Updated View Revisions
2019-04-30 14:31 sfernandez Note Added: 0005658
2019-04-30 15:25 stonstad Note Added: 0005659
2019-04-30 15:25 stonstad Status feedback => assigned
2019-04-30 18:17 jsantos Relationship added has duplicate 0001452
2019-04-30 18:20 sfernandez Status assigned => resolved
2019-04-30 18:20 sfernandez Resolution open => fixed
2019-04-30 18:20 sfernandez Fixed in Version => 2.2.3