View Issue Details

IDProjectCategoryView StatusLast Update
0001490NoesisGUIUnity3Dpublic2019-07-24 12:23
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0001490: Upgrade from 2.2.2 to 2.2.3 Crash and Corruption
DescriptionDuring the progress bar "Upgrading" step of 2.2.3 installation the Unity editor crashed. Upon project restart all game objects using Noesis are missing scripts and associated settings. Editor crash dump included.
TagsNo tags attached.
PlatformWindows

Relationships

related to 0001458 resolvedjsantos Error On Subsequent Package Import 

Activities

stonstad

stonstad

2019-06-13 18:01

reporter  

Crash_2019-06-13_155334807.zip (343,369 bytes)
jsantos

jsantos

2019-06-14 14:07

manager   ~0005701

Last edited: 2019-06-14 14:32

View 2 revisions

do everything work If you upgrade de package following the instructions in https://www.noesisengine.com/bugs/view.php?id=1458#c5700?

stonstad

stonstad

2019-06-14 14:43

reporter   ~0005703

This happened when 1) closed Unity (due to lock), 2) deleted file, 3) reopened Unity, 4) imported package. If I understand correctly, I should delete the entire folder structure and maybe this is why it happened?
sfernandez

sfernandez

2019-06-14 16:31

manager   ~0005712

Following the steps you described I'm not able to make Unity crash. After closing Unity, deleting Noesis.dll and opening Unity again I get an error message indicating that Noesis.dll is missing, but then I import NoesisGUI 2.2.3 again and the installation finishes fine and I can run any sample.

Would it be possible to get a copy of your project so we can debug what is happening? We can make this ticket private for that matter.
jsantos

jsantos

2019-06-14 16:37

manager   ~0005713

Last edited: 2019-06-14 16:39

View 2 revisions

I don't think it makes sense getting the project for this purpose. The plugin is in bad-state (mismatch of source and noesis.dll). I think we should put more emphasis in the upgrading process. And note, that the upgrading process is not deleting Noesis.dll and upgrading again. The procedure is:

1. Close Unity.
2. Remove the plugin (/Assets/NoesisGUI/Plugins and '/Assets/NoesisGUI/Samples')
3. Launch Unity. You will get errors because Noesis is missing, that's fine
4. Import Noesis
5. Errors gone and everything should be working

jsantos

jsantos

2019-06-14 16:38

manager   ~0005714

What I don't understand is why the upgrading is happening, because we detect that the dll is mismatched and recommend restarting Unity. If you restart Unity at that point (without removing noesis.dll), the upgrading process should continue and you should get the welcome screen.
jsantos

jsantos

2019-06-14 16:40

manager   ~0005715

So, just to avoid confusion. If when importing a new version of Noesis, Noesis.dll is locked, we detect it, emit a message about restarting and just restarting should finish the update process and show the welcome screen. That's not happening and we need to understand why.
stonstad

stonstad

2019-06-14 17:00

reporter   ~0005716

In hindsight I suspect the crash during upgrade might be caused by https://www.noesisengine.com/bugs/view.php?id=1491. The non-debug 2.2.3 library crashes about once per hour, but sometimes it crashes more frequently.
sfernandez

sfernandez

2019-07-24 12:23

manager   ~0005898

Related to #1491.

Issue History

Date Modified Username Field Change
2019-06-13 18:01 stonstad New Issue
2019-06-13 18:01 stonstad File Added: Crash_2019-06-13_155334807.zip
2019-06-14 14:05 jsantos Relationship added related to 0001458
2019-06-14 14:05 jsantos Assigned To => sfernandez
2019-06-14 14:05 jsantos Status new => assigned
2019-06-14 14:07 jsantos Note Added: 0005701
2019-06-14 14:07 jsantos Status assigned => feedback
2019-06-14 14:32 sfernandez Note Edited: 0005701 View Revisions
2019-06-14 14:43 stonstad Note Added: 0005703
2019-06-14 14:43 stonstad Status feedback => assigned
2019-06-14 16:31 sfernandez Status assigned => feedback
2019-06-14 16:31 sfernandez Note Added: 0005712
2019-06-14 16:37 jsantos Note Added: 0005713
2019-06-14 16:38 jsantos Note Added: 0005714
2019-06-14 16:39 jsantos Note Edited: 0005713 View Revisions
2019-06-14 16:40 jsantos Note Added: 0005715
2019-06-14 17:00 stonstad Note Added: 0005716
2019-06-14 17:00 stonstad Status feedback => assigned
2019-06-18 17:01 sfernandez Target Version => 2.2.4
2019-06-18 17:01 sfernandez Description Updated View Revisions
2019-07-24 12:23 sfernandez Status assigned => resolved
2019-07-24 12:23 sfernandez Resolution open => fixed
2019-07-24 12:23 sfernandez Fixed in Version => 2.2.4
2019-07-24 12:23 sfernandez Note Added: 0005898