View Issue Details

IDProjectCategoryView StatusLast Update
0001591NoesisGUIUnity3Dpublic2019-12-31 00:48
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.2.5 
Target Version2.2.6Fixed in Version2.2.6 
Summary0001591: Unity Crash w/ Vanilla Noesis Installation if Noesis View Component Not Instantiated
DescriptionI'm enclosing a project that crashes on play. Load the default scene that has a camera, light and nothing else. It's a vanilla Unity project. The short of it is that there is a fatal Unity crash if the Noesis DLL is included but no Noesis view component is instantiated within the hierarchy, and play is pressed. Unity 2019.2.11.f1
Steps To ReproduceReproduction project included w/ log. Crash .dmp not generated, apparently. Resolution is to add a NoesisView component before hittting play.
TagsNo tags attached.
PlatformAny

Relationships

related to 0001592 resolvedsfernandez Listbox Event Routing Causes Unity Crash 

Activities

stonstad

stonstad

2019-11-30 21:43

reporter  

Editor.log (63,648 bytes)
stonstad

stonstad

2019-11-30 21:44

reporter   ~0006024

Last edited: 2019-11-30 21:46

View 2 revisions

Encl. NoesisBugs.zip. Unity project for reproduction.
http://stellarconquest.blob.core.windows.net/$root/Noesis%20Bugs1.zip

sfernandez

sfernandez

2019-12-02 17:12

manager   ~0006026

Last edited: 2019-12-02 17:45

View 2 revisions

Hi, I'm not able to reproduce the crashes with the attached project. I can play the empty scene several times just fine, reimport the included xaml and play the scene again... everything seems fine.
In the attached Editor.log I see a lot of errors coming from Unity itself:
Assertion failed on expression: 'SUCCEEDED(hr)'
 (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/D3D11Window.cpp Line: 186)
d3d11: failed to create 2D texture id=629 width=83 height=17 mips=7 dxgifmt=28 [D3D error was 887a0005]
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)
d3d11: failed to create 2D texture shader resource view id=629 [D3D error was 80070057]
 (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)
d3d11: failed to create buffer (target 0x1 mode 0 size 96) [0x887A0005]
d3d11: failed to create buffer (target 0x2 mode 0 size 12) [0x887A0005]
d3d11: failed to create 2D texture id=631 width=4 height=4 mips=1 dxgifmt=28 [D3D error was 887a0005]
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)
...
d3d11: failed to create buffer (target 0x1 mode 4 size 147456) [0x887A0005]
d3d11: failed to create buffer (target 0x2 mode 4 size 16384) [0x887A0005]
d3d11: attempt to lock null buffer
Crash!!!

I don't think this has anything to do with Noesis, aren't you able to reproduce this without Noesis package being part of the project?

stonstad

stonstad

2019-12-02 17:38

reporter   ~0006028

I can't reproduce it at all today. I opened the same test project and what caused a repeatable error before now doesn't. Sorry sfernandez. I agree -- it must be Unity.

Issue History

Date Modified Username Field Change
2019-11-30 21:43 stonstad New Issue
2019-11-30 21:43 stonstad File Added: Editor.log
2019-11-30 21:44 stonstad Note Added: 0006024
2019-11-30 21:46 stonstad Note Edited: 0006024 View Revisions
2019-12-02 17:12 sfernandez Assigned To => sfernandez
2019-12-02 17:12 sfernandez Status new => feedback
2019-12-02 17:12 sfernandez Note Added: 0006026
2019-12-02 17:38 stonstad Note Added: 0006028
2019-12-02 17:38 stonstad Status feedback => assigned
2019-12-02 17:45 sfernandez Note Edited: 0006026 View Revisions
2019-12-30 10:24 sfernandez Status assigned => resolved
2019-12-30 10:24 sfernandez Resolution open => unable to reproduce
2019-12-31 00:48 sfernandez Fixed in Version => 2.2.6
2019-12-31 00:48 sfernandez Target Version => 2.2.6
2019-12-31 00:48 sfernandez Description Updated View Revisions
2019-12-31 00:48 sfernandez Relationship added related to 0001592