View Issue Details

IDProjectCategoryView StatusLast Update
0001592NoesisGUIUnity3Dpublic2020-01-07 20:21
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.2.5 
Target Version2.2.6Fixed in Version2.2.6 
Summary0001592: Listbox Event Routing Causes Unity Crash
DescriptionWith the enclosed project load "default" scene.
Play/Stop/Play until crash occurs. The offending logic is in Bug1Control.cs.

Reproduduction project, crash logs, and dmp included. A manifestation of this issue with a similar but somewhat different stack trace is an open issue in Stellar Conquest.

TagsNo tags attached.
PlatformAny

Relationships

related to 0001591 resolvedsfernandez Unity Crash w/ Vanilla Noesis Installation if Noesis View Component Not Instantiated 

Activities

stonstad

stonstad

2019-11-30 23:02

reporter  

Crash_2019-11-30_215044902.zip (230,623 bytes)
stonstad

stonstad

2019-11-30 23:05

reporter   ~0006025

Encl. link to reproduction project. See Bug1Control.cs. http://stellarconquest.blob.core.windows.net/$root/NoesisBugs2.zip
sfernandez

sfernandez

2019-12-31 00:46

manager   ~0006053

Last edited: 2019-12-31 12:20

View 2 revisions

I was unable to reproduce the crash after many many Play/Stop/Play... tries.

And attached crash dump and logs are very similar to ticket 0001591, they also show in Editor.log lots of asserts in the render device inside Unity's code:

Assertion failed on expression: 'SUCCEEDED(hr)'
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/D3D11Window.cpp Line: 186)
d3d11: failed to create 2D texture id=875 width=83 height=17 mips=7 dxgifmt=28 [D3D error was 887a0005]
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)
d3d11: failed to create 2D texture shader resource view id=875 [D3D error was 80070057]
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)
d3d11: Failed to create 2D texture in GfxDeviceD3D11
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 605)
d3d11: Failed to create 2D texture in GfxDeviceD3D11
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 605)
d3d11: failed to create buffer (target 0x1 mode 0 size 96) [0x887A0005]
d3d11: failed to create buffer (target 0x2 mode 0 size 12) [0x887A0005]
Assertion failed on expression: 'SUCCEEDED(hr)'
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/D3D11Window.cpp Line: 186)
d3d11: failed to create 2D texture id=877 width=77 height=17 mips=7 dxgifmt=28 [D3D error was 887a0005]
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)
d3d11: failed to create 2D texture shader resource view id=877 [D3D error was 80070057]
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)
d3d11: Failed to create 2D texture in GfxDeviceD3D11
  (Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 605)
...

The dump shows it finally crashes trying to initialize our render device code.

@jsantos Could you confirm this is not a problem in our render device?

stonstad

stonstad

2020-01-01 21:03

reporter   ~0006055

I have not seen this behavior since it was originally reported. I want to say my GPU was in a bad state, somehow, and it is operating system, hardware, or Unity related.
jsantos

jsantos

2020-01-07 20:21

manager   ~0006068

I think this is device corruption. Thanks for your feedback. I am going to close this.

Issue History

Date Modified Username Field Change
2019-11-30 23:02 stonstad New Issue
2019-11-30 23:02 stonstad File Added: Crash_2019-11-30_215044902.zip
2019-11-30 23:05 stonstad Note Added: 0006025
2019-12-16 18:48 sfernandez Assigned To => sfernandez
2019-12-16 18:48 sfernandez Status new => assigned
2019-12-16 18:48 sfernandez Target Version => 2.2.6
2019-12-16 18:48 sfernandez Description Updated View Revisions
2019-12-31 00:46 sfernandez Status assigned => feedback
2019-12-31 00:46 sfernandez Note Added: 0006053
2019-12-31 00:48 sfernandez Relationship added related to 0001591
2019-12-31 12:20 jsantos Note Edited: 0006053 View Revisions
2020-01-01 21:03 stonstad Note Added: 0006055
2020-01-01 21:03 stonstad Status feedback => assigned
2020-01-07 20:21 jsantos Status assigned => resolved
2020-01-07 20:21 jsantos Resolution open => unable to reproduce
2020-01-07 20:21 jsantos Fixed in Version => 2.2.6
2020-01-07 20:21 jsantos Note Added: 0006068