View Issue Details

IDProjectCategoryView StatusLast Update
0001662NoesisGUIC# SDKpublic2020-04-30 22:23
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.0.0Fixed in Version3.0.0 
Summary0001662: MonoManager Reload Assembly Crashes Editor
DescriptionSpecific to b8 -- happens about once every fifteen minutes. I edit code in VS, alt tab back to Unity and Unity crashes. There is no error message, stack trace, or dump.

Last entry in Editor.log:

Refresh completed in 0.288080 seconds.
RefreshInfo: RefreshV2(ForceSynchronousImport)
RefreshProfiler: Total: 287.914ms
    InvokeBeforeRefreshCallbacks: 0.424ms
    ApplyChangesToAssetFolders: 0.063ms
    WriteModifiedImportersToTextMetaFiles: 0.000ms
    CleanLegacyArtifacts: 0.000ms
    Scan: 68.010ms
    OnSourceAssetsModified: 0.506ms
    UnregisterDeletedAssets: 0.000ms
    InitializeImportedAssetsSnapshot: 3.857ms
    GetAllGuidsForCategorization: 0.457ms
    CategorizeAssets: 98.982ms
    ImportAndPostprocessOutOfDateAssets: 52.279ms (5.089ms without children)
        ImportManagerImport: 28.123ms (1.665ms without children)
            ImportInProcess: 26.424ms
            ImportOutOfProcess: 0.000ms
            UpdateCategorizedAssets: 0.033ms
            RemoteAssetCacheGetArtifact: 0.000ms (0.000ms without children)
                RemoteAssetCacheResolve: 0.000ms
                RemoteAssetCacheDownloadFile: 0.000ms
        CompileScripts: 0.000ms
        PostProcessAllAssets: 12.933ms
        ReloadImportedAssets: 0.001ms
        VerifyAssetsAreUpToDateAndCorrect: 0.000ms
        EnsureUptoDateAssetsAreRegisteredWithGuidPM: 0.849ms
        InitializingProgressBar: 0.001ms
        PostProcessAllAssetNotificationsAddChangedAssets: 0.444ms
        OnDemandSchedulerStart: 0.409ms
        RestoreLoadedAssetsState: 1.585ms
    InvokeProjectHasChanged: 0.000ms
    UpdateImportedAssetsSnapshot: 2.845ms
    ReloadSourceAssets: 0.797ms
    UnloadImportedAssets: 0.137ms
    Hotreload: 55.486ms
    FixTempGuids: 0.004ms
    VerifyGuidPMRegistrations: 0.000ms
    GatherAllCurrentPrimaryArtifactRevisions: 0.873ms
    UnloadStreamsBegin: 0.119ms
    LoadedImportedAssetsSnapshotReleaseGCHandles: 0.753ms
    GetLoadedSourceAssetsSnapshot: 3.080ms
    PersistCurrentRevisions: 0.000ms
    UnloadStreamsEnd: 0.112ms
    Untracked: 1.978ms
Start importing Assets/User Interface/Controls/DimensioningControl.cs using Guid(a2314b3cd57974445ad4c7d7f36621ea) Importer(-1,00000000000000000000000000000000)
Done importing asset: 'Assets/User Interface/Controls/DimensioningControl.cs' (target hash: 'f07f5904a78823c3a754f7acd2a0ecec') in 0.016051 seconds
Start importing Assets/Scripts/Controllers/PropController.cs using Guid(3b85387c0f9888e4593b17e2e9afb691) Importer(-1,00000000000000000000000000000000)
Done importing asset: 'Assets/Scripts/Controllers/PropController.cs' (target hash: 'fee00d0d663275d8278d2c116f8ae614') in 0.017731 seconds
AssetDatabase: script compilation time: 0.029070s
- Starting script compilation
- Starting compile Library/ScriptAssemblies/Assembly-CSharp.dll
- Finished compile Library/ScriptAssemblies/Assembly-CSharp.dll in 1.239845 seconds
- Starting compile Library/ScriptAssemblies/Assembly-CSharp-Editor.dll
- Finished compile Library/ScriptAssemblies/Assembly-CSharp-Editor.dll in 0.315812 seconds
- Finished script compilation in 1.585732 seconds
Reloading assemblies after forced synchronous recompile.
Begin MonoManager ReloadAssembly
TagsNo tags attached.
PlatformAny

Relationships

has duplicate 0001670 resolvedsfernandez Noesis.NoesisGUI_PINVOKE:BaseComponent_Release, 'Attempt to access invalid address.' 

Activities

jsantos

jsantos

2020-04-21 11:19

manager   ~0006228

The log doesn't give information. :( We cannot do anything without a dump.

Do you think this is something new for b8?
stonstad

stonstad

2020-04-21 14:20

reporter   ~0006230

I understand my observation is anecdotal. However, I am convinced it is caused by B8 because the behavior started immediately after I upgraded the project from B6 to B8. The last entries in the editor log are always the Noesis reload process, which is caused by my external .cs file modification.
sfernandez

sfernandez

2020-04-21 16:51

manager   ~0006231

Last edited: 2020-04-21 17:00

View 2 revisions

Is this something I could try to reproduce with the new project you attached or is this happening with Stellar Conquest?

To try to get a dump maybe you can attach Visual Studio debugger to Unity before switching back to Unity (I mean keep it attached always, while working with Unity), sometimes it stops in the debugger and you can generate the dump then.

stonstad

stonstad

2020-04-22 16:49

reporter   ~0006234

Yes, it should work with the project I shared -- that project is B4. I'll get a new one ready. The trick will be getting it to crash. It is fairly frequent for me -- about one per 15 minutes. But that's 15 minutes of start/play/.cs edit behavior. I'll get the updated project ready.

Thanks,
Shaun
jsantos

jsantos

2020-04-22 16:55

manager   ~0006237

Thanks Shaun, I wonder also if you could launch the game from Visual Studio and work for 15 minutes. I am sure that way we will be able to get a dump.
stonstad

stonstad

2020-04-22 18:57

reporter  

Full Stack Trace.PNG (83,980 bytes)
Full Stack Trace.PNG (83,980 bytes)
stonstad

stonstad

2020-04-22 18:57

reporter   ~0006238

Encl. stack trace, log, and dmp for aforementioned behavior.

If you have a Noesis PDB, would that allow me to give you a better stack trace?

Unity.dmp (1,621,322 bytes)
Editor.log (354,669 bytes)
stonstad

stonstad

2020-04-22 19:02

reporter   ~0006239

Just an update around the behavior aspect. I wrote a test that edits XAML and CS files and alt-tabs between the editor and Unity. I can run hundreds of automated tests without fail and this is the least reliable way to reproduce the crash. If I just 'work' normally and edit files and play/stop as needed, the issue manifests within a few minutes as described above.
sfernandez

sfernandez

2020-04-23 12:17

manager   ~0006240

Thanks for the dump, we are investigating the issue. It is related to the Rendering event of the View.
sfernandez

sfernandez

2020-04-23 13:08

manager   ~0006241

Could you please try the following library: https://drive.google.com/open?id=1Cy-XY_M5urPW-wK7cTrt3CptBdhrvNk0
stonstad

stonstad

2020-04-23 20:01

reporter   ~0006244

I am trying the new library in Stellar Conquest. It is encountering a runtime crash.


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Crash!!!

Editor-2.log (107,878 bytes)
Crash_2020-04-23_174201910.zip (434,168 bytes)
stonstad

stonstad

2020-04-23 20:03

reporter   ~0006245

I can't use Noesis/Stellar Conquest with the above library. The game crashes consistently on its second screen.
sfernandez

sfernandez

2020-04-23 20:15

manager   ~0006247

Sorry, the fix was not correct, please try this:
https://drive.google.com/open?id=1g76hM5EfQ71xCwGfhPN9DH7E-Oysldso
stonstad

stonstad

2020-04-23 20:56

reporter   ~0006251

kk, no problem. It is no longer crashing with the 4/23 library. I'll use it and report back on stability.
stonstad

stonstad

2020-04-23 21:03

reporter   ~0006252

No change in behavior -- continues to crash with similar call stack.

Stack 04.23.2020.PNG (61,543 bytes)
Stack 04.23.2020.PNG (61,543 bytes)
sfernandez

sfernandez

2020-04-23 21:05

manager   ~0006253

Can we get a dump for the new crash?
stonstad

stonstad

2020-04-23 21:09

reporter   ~0006255

Last edited: 2020-04-23 21:09

View 2 revisions

It didn't attach in this screen -- I must have pulled a full dump at 5.7GB instead of a minidump and I didn't realize it. One moment while I get a new one. I'm actively working the upgrade to v3 and if you want to send over new versions I can quickly retest. It looks like

sfernandez

sfernandez

2020-04-23 21:13

manager   ~0006257

A minidump would be enough to see where the crash is happening.
stonstad

stonstad

2020-04-23 21:13

reporter   ~0006258

Encl. 04.23.2020_NoHeap.dmp

04.23.2020_NoHeap.dmp (1,743,411 bytes)
sfernandez

sfernandez

2020-04-23 21:26

manager   ~0006260

The last dump says you are using Noesis.dll 3.0.0.9073, but the last library I uploaded here: https://drive.google.com/open?id=1g76hM5EfQ71xCwGfhPN9DH7E-Oysldso
has version 3.0.0.9123.
stonstad

stonstad

2020-04-24 17:42

reporter   ~0006265

OK, I double-checked that I extracted the DLL from the link shared above.

04.24.2020.PNG (59,055 bytes)
04.24.2020.PNG (59,055 bytes)
04.24.2020.dmp (1,897,380 bytes)
stonstad

stonstad

2020-04-24 17:54

reporter   ~0006266

Not sure if this matters, but I am not extracting the version text file. Just the DLL, perhaps this relates to the version you are seeing?
sfernandez

sfernandez

2020-04-27 18:40

manager   ~0006286

I have a new library for you to try, could you do some tests with it?
https://drive.google.com/open?id=1fe0e1M7oRSyTDa410Ds6nqow9nZ_3Y_t

The version text file is not needed, our DLL have the assembly information correctly set, so we know what version was used when the dump was generated.
stonstad

stonstad

2020-04-27 22:23

reporter   ~0006287

Using the new assembly... this exception occurred at runtime and it was non-fatal.

04.27.2020.dmp (1,803,749 bytes)
04.27.2020.PNG (71,913 bytes)
04.27.2020.PNG (71,913 bytes)
stonstad

stonstad

2020-04-27 23:29

reporter   ~0006288

I suspect the previous exception is normal and was just a logged NullReferenceException. Sergio, I haven't encountered a crash yet.
sfernandez

sfernandez

2020-04-27 23:55

manager   ~0006289

Yes, it is not crashing in Noesis, it looks like a managed exception.
Glad to hear the patch seems to work and you are not getting more crashes.
stonstad

stonstad

2020-04-28 17:07

reporter   ~0006291

Thanks, Sergio. Any chance I could get an optimized version of the library? A few screens hang and/or are slow with the debug build.
sfernandez

sfernandez

2020-04-28 17:13

manager   ~0006294

Sure, here you are: https://drive.google.com/open?id=19Ek48NJANOu0F1OUqbJEBlAGiVpuFPRo

Issue History

Date Modified Username Field Change
2020-04-21 03:11 stonstad New Issue
2020-04-21 11:19 jsantos Note Added: 0006228
2020-04-21 11:19 jsantos Assigned To => sfernandez
2020-04-21 11:19 jsantos Status new => assigned
2020-04-21 11:19 jsantos Target Version => 3.0.0
2020-04-21 11:19 jsantos Status assigned => feedback
2020-04-21 14:20 stonstad Note Added: 0006230
2020-04-21 14:20 stonstad Status feedback => assigned
2020-04-21 16:51 sfernandez Status assigned => feedback
2020-04-21 16:51 sfernandez Note Added: 0006231
2020-04-21 17:00 sfernandez Note Edited: 0006231 View Revisions
2020-04-22 16:49 stonstad Note Added: 0006234
2020-04-22 16:49 stonstad Status feedback => assigned
2020-04-22 16:55 jsantos Note Added: 0006237
2020-04-22 18:57 stonstad File Added: Full Stack Trace.PNG
2020-04-22 18:57 stonstad File Added: Unity.dmp
2020-04-22 18:57 stonstad File Added: Editor.log
2020-04-22 18:57 stonstad Note Added: 0006238
2020-04-22 19:02 stonstad Note Added: 0006239
2020-04-23 12:17 sfernandez Note Added: 0006240
2020-04-23 13:08 sfernandez Status assigned => feedback
2020-04-23 13:08 sfernandez Note Added: 0006241
2020-04-23 20:01 stonstad File Added: Editor-2.log
2020-04-23 20:01 stonstad File Added: Crash_2020-04-23_174201910.zip
2020-04-23 20:01 stonstad Note Added: 0006244
2020-04-23 20:01 stonstad Status feedback => assigned
2020-04-23 20:03 stonstad Note Added: 0006245
2020-04-23 20:15 sfernandez Status assigned => feedback
2020-04-23 20:15 sfernandez Note Added: 0006247
2020-04-23 20:56 stonstad Note Added: 0006251
2020-04-23 20:56 stonstad Status feedback => assigned
2020-04-23 21:03 stonstad File Added: Stack 04.23.2020.PNG
2020-04-23 21:03 stonstad Note Added: 0006252
2020-04-23 21:05 sfernandez Status assigned => feedback
2020-04-23 21:05 sfernandez Note Added: 0006253
2020-04-23 21:09 stonstad Note Added: 0006255
2020-04-23 21:09 stonstad Status feedback => assigned
2020-04-23 21:09 stonstad Note Edited: 0006255 View Revisions
2020-04-23 21:13 sfernandez Note Added: 0006257
2020-04-23 21:13 stonstad File Added: 04.23.2020_NoHeap.dmp
2020-04-23 21:13 stonstad Note Added: 0006258
2020-04-23 21:26 sfernandez Status assigned => feedback
2020-04-23 21:26 sfernandez Note Added: 0006260
2020-04-24 17:42 stonstad File Added: 04.24.2020.PNG
2020-04-24 17:42 stonstad File Added: 04.24.2020.dmp
2020-04-24 17:42 stonstad Note Added: 0006265
2020-04-24 17:42 stonstad Status feedback => assigned
2020-04-24 17:54 stonstad Note Added: 0006266
2020-04-27 17:06 sfernandez Relationship added has duplicate 0001670
2020-04-27 18:40 sfernandez Status assigned => feedback
2020-04-27 18:40 sfernandez Note Added: 0006286
2020-04-27 22:23 stonstad File Added: 04.27.2020.dmp
2020-04-27 22:23 stonstad File Added: 04.27.2020.PNG
2020-04-27 22:23 stonstad Note Added: 0006287
2020-04-27 22:23 stonstad Status feedback => assigned
2020-04-27 23:29 stonstad Note Added: 0006288
2020-04-27 23:55 sfernandez Note Added: 0006289
2020-04-28 17:07 stonstad Note Added: 0006291
2020-04-28 17:13 sfernandez Status assigned => feedback
2020-04-28 17:13 sfernandez Note Added: 0006294
2020-04-30 22:23 sfernandez Status feedback => resolved
2020-04-30 22:23 sfernandez Resolution open => fixed
2020-04-30 22:23 sfernandez Fixed in Version => 3.0.0