View Issue Details

IDProjectCategoryView StatusLast Update
0001670NoesisGUIUnity3Dpublic2020-05-04 13:39
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionduplicate 
Product Version3.0.0 
Target Version3.0.0Fixed in Version3.0.0 
Summary0001670: Noesis.NoesisGUI_PINVOKE:BaseComponent_Release, 'Attempt to access invalid address.'
DescriptionDifferent crash behavior from 0001662. Not sure if this is a different manifestation of the same error. This is using the debug library.

0x00007FFE7E2AFD5E (Noesis) Boxed_TimeSpan_GetStaticType
0x00007FFE7E24981C (Noesis) ContentControl_Content_get
0x00007FFE7E246462 (Noesis) ContentControl_Content_get
0x00007FFE7E23C1B6 (Noesis) ContentControl_Content_get
0x00007FFE7E23C374 (Noesis) ContentControl_Content_get
  ERROR: SymGetSymFromAddr64, GetLastError: 'Attempt to access invalid address.' (Address: 00007FFE7E0B16D3)
0x00007FFE7E0B16D3 (Noesis) (function-name not available)
0x000001C3266579D7 (Mono JIT Code) (wrapper managed-to-native) Noesis.NoesisGUI_PINVOKE:BaseComponent_Release (intptr)
0x000001C326657893 (Mono JIT Code) [C:\Users\stons\Source\StellarConquest\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\API\Proxies\BaseComponent.cs:62] Noesis.BaseComponent:Release (intptr)
0x000001C32AA04CA3 (Mono JIT Code) [C:\Users\stons\Source\StellarConquest\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\API\Core\Extend.cs:4429] Noesis.Extend:ReleasePending ()
0x000001C3269BF733 (Mono JIT Code) [C:\Users\stons\Source\StellarConquest\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\API\Core\Extend.cs:92] Noesis.Extend:Shutdown ()
0x000001C3269BE3D3 (Mono JIT Code) [C:\Users\stons\Source\StellarConquest\StellarConquest.Presentation.Unity\Assets\NoesisGUI\Plugins\API\Core\Extend.cs:37] Noesis.Extend:OnDomainUnload (object,System.EventArgs)
Steps To ReproduceMade changes to a .cs file which triggered a Noesis reload. Encl. editor log, player log, editor crash dump.
TagsNo tags attached.
PlatformAny

Relationships

duplicate of 0001662 resolvedsfernandez MonoManager Reload Assembly Crashes Editor 

Activities

stonstad

stonstad

2020-04-27 16:54

reporter  

Crash_2020-04-27_144802796.zip (498,555 bytes)
sfernandez

sfernandez

2020-04-27 17:07

manager   ~0006284

I verified is the same bug related with the Rendering event.

Issue History

Date Modified Username Field Change
2020-04-27 16:54 stonstad New Issue
2020-04-27 16:54 stonstad File Added: Crash_2020-04-27_144802796.zip
2020-04-27 17:06 sfernandez Relationship added duplicate of 0001662
2020-04-27 17:07 sfernandez Assigned To => sfernandez
2020-04-27 17:07 sfernandez Status new => assigned
2020-04-27 17:07 sfernandez Target Version => 3.0.0
2020-04-27 17:07 sfernandez Description Updated View Revisions
2020-04-27 17:07 sfernandez Note Added: 0006284
2020-05-04 13:39 sfernandez Status assigned => resolved
2020-05-04 13:39 sfernandez Resolution open => duplicate
2020-05-04 13:39 sfernandez Fixed in Version => 3.0.0