View Issue Details

IDProjectCategoryView StatusLast Update
0001776NoesisGUIC++ SDKpublic2020-08-13 12:19
ReporterasusralisAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.0.4 
Target Version3.0.5Fixed in Version3.0.5 
Summary0001776: Access violation when scrolling in an ItemsControl.
DescriptionThis seemed to have started after going from 3.0.3 -> 3.0.4. It happens when I continuously scroll down or up in an ItemsControl.

TagsNo tags attached.
PlatformAny

Activities

asusralis

asusralis

2020-08-11 16:50

reporter  

Crash_2020-08-11_144423920.rar (437,598 bytes)
sfernandez

sfernandez

2020-08-12 12:52

manager   ~0006570

I found something that can be the cause of the crash, could you please try the following debug library that includes a fix?
https://drive.google.com/file/d/1He5jnBkFqITuIYvN2KWKd_8Dvmu19NKo
asusralis

asusralis

2020-08-12 16:36

reporter   ~0006571

When replacing the .dll at /NoesisGUI/Plugins/Libraries/Windows/x86_64 and restarting my editor results in this error when trying to run:

DllNotFoundException: Noesis
Noesis.Texture.WrapTexture (System.Object texture, System.IntPtr nativePointer, System.Int32 width, System.Int32 height, System.Int32 numLevels) (at Assets/NoesisGUI/Plugins/NoesisTexture.cs:17)
Noesis.TextureSource..ctor (UnityEngine.Texture2D texture) (at Assets/NoesisGUI/Plugins/NoesisTextureSource.cs:12)
sfernandez

sfernandez

2020-08-12 16:41

manager   ~0006572

Probably a dependency not found with the debug CRT, let me generate a new library.
sfernandez

sfernandez

2020-08-12 16:47

manager   ~0006573

Please try again with this one: https://drive.google.com/file/d/1GVpCeqI85DgpYiMZ6WrnPm8HrzCYGLiu
asusralis

asusralis

2020-08-12 16:59

reporter   ~0006574

Okay, that worked. It actually crashed this time right after the control was created, so I'm not sure if this is the same problem or not. Before it was crashing only when I was scrolling up and down.

Crash_2020-08-12_145613208.7z (312,683 bytes)
sfernandez

sfernandez

2020-08-12 17:47

manager   ~0006575

Last crash was because of an assert, please use this one:
https://drive.google.com/file/d/19Ub965DwtUeY30S8MK1wvDm-czu9jwBf
asusralis

asusralis

2020-08-12 18:02

reporter   ~0006576

Okay, this one crashed at the right time.

Crash_2020-08-12_155939901.7z (311,498 bytes)
sfernandez

sfernandez

2020-08-12 18:58

manager   ~0006577

Thanks a lot for the feeback, it helped me identify the problem.

This library should fix it: https://drive.google.com/file/d/1oEzPaSbXd406urlja1294mMtdpdTUvmR
asusralis

asusralis

2020-08-12 22:28

reporter   ~0006578

That fixed it, thanks.
asusralis

asusralis

2020-08-12 22:36

reporter   ~0006579

Last edited: 2020-08-12 22:36

View 2 revisions

Actually, playing a bit with my game resulted in another crash; it seems related to the itemscontrol. I think it happened as I was clicking an item in it, or it was possibly scrolling.



Crash_2020-08-12_203423724.rar (344,636 bytes)
sfernandez

sfernandez

2020-08-13 12:19

manager   ~0006580

Last crash was related to the rendering of effects, I created a new ticket to investigate that: 0001779

Marking this one as solved in relation to the ItemsControl scrolling and shared size groups.

Issue History

Date Modified Username Field Change
2020-08-11 16:50 asusralis New Issue
2020-08-11 16:50 asusralis File Added: Crash_2020-08-11_144423920.rar
2020-08-11 16:52 jsantos Assigned To => sfernandez
2020-08-11 16:52 jsantos Status new => assigned
2020-08-11 16:52 jsantos Target Version => 3.0.5
2020-08-11 16:52 jsantos Description Updated View Revisions
2020-08-12 12:52 sfernandez Status assigned => feedback
2020-08-12 12:52 sfernandez Note Added: 0006570
2020-08-12 16:36 asusralis Note Added: 0006571
2020-08-12 16:36 asusralis Status feedback => assigned
2020-08-12 16:41 sfernandez Note Added: 0006572
2020-08-12 16:47 sfernandez Status assigned => feedback
2020-08-12 16:47 sfernandez Note Added: 0006573
2020-08-12 16:59 asusralis File Added: Crash_2020-08-12_145613208.7z
2020-08-12 16:59 asusralis Note Added: 0006574
2020-08-12 16:59 asusralis Status feedback => assigned
2020-08-12 17:47 sfernandez Status assigned => feedback
2020-08-12 17:47 sfernandez Note Added: 0006575
2020-08-12 18:02 asusralis File Added: Crash_2020-08-12_155939901.7z
2020-08-12 18:02 asusralis Note Added: 0006576
2020-08-12 18:02 asusralis Status feedback => assigned
2020-08-12 18:58 sfernandez Status assigned => feedback
2020-08-12 18:58 sfernandez Note Added: 0006577
2020-08-12 22:28 asusralis Note Added: 0006578
2020-08-12 22:28 asusralis Status feedback => assigned
2020-08-12 22:36 asusralis File Added: Crash_2020-08-12_203423724.rar
2020-08-12 22:36 asusralis Note Added: 0006579
2020-08-12 22:36 asusralis Note Edited: 0006579 View Revisions
2020-08-13 12:19 sfernandez Status assigned => resolved
2020-08-13 12:19 sfernandez Resolution open => fixed
2020-08-13 12:19 sfernandez Fixed in Version => 3.0.5
2020-08-13 12:19 sfernandez Note Added: 0006580