View Issue Details

IDProjectCategoryView StatusLast Update
0001779NoesisGUIUnity3Dpublic2020-08-31 18:17
ReporterasusralisAssigned Tojsantos 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.0.4 
Target Version3.0.5Fixed in Version3.0.5 
Summary0001779: Crash rendering offscreen effects
DescriptionFrom crash dump at issue https://www.noesisengine.com/bugs/view.php?id=1776#c6579

Crash callstack:
 	Noesis.dll!Noesis::BaseVector<float>::operator[](unsigned int i=4) Line 134	C++
>	Noesis.dll!Noesis::VGLContext::DrawGPUBatches() Line 3324	C++
     Noesis.dll!Noesis::VGLContext::Flush(bool endOfFrame=false, bool flipY=false) Line 1464	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderOffscreenNodes() Line 683	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderOffscreen(Noesis::RenderNode * node=0x0000019aeb9b4118, const Noesis::Matrix4 & projection={...}) Line 96	C++
     Noesis.dll!Noesis::RenderTree::RenderOffscreen(const Noesis::Matrix4 & projection={...}) Line 277	C++
     Noesis.dll!Noesis::Renderer::RenderOffscreen(const Noesis::Matrix4 & projection={...}) Line 171	C++
     Noesis.dll!Noesis::Renderer::RenderOffscreen() Line 149	C++
     Noesis.dll!Noesis_GetRenderOffscreenCallback::__l2::<lambda>(int eventId=0, void * data=0x0000019b00ff0980) Line 420	C++
     Noesis.dll!void <lambda>(int, void *)::<lambda_invoker_cdecl>(int eventId=0, void * data=0x0000019b00ff0980) Line 422	C++
     Unity.exe!GfxDeviceWorker::RunCommand(class ThreadedStreamBuffer &)	Unknown
     Unity.exe!GfxDeviceWorker::RunExt(class ThreadedStreamBuffer &)	Unknown
     Unity.exe!GfxDeviceWorker::RunGfxDeviceWorker(void *)	Unknown
     Unity.exe!Thread::RunThreadWrapper(void *)	Unknown
     kernel32.dll!BaseThreadInitThunk()	Unknown
     ntdll.dll!RtlUserThreadStart()	Unknown
TagsNo tags attached.
PlatformAny

Activities

asusralis

asusralis

2020-08-13 12:21

reporter   ~0006581

It happens consistency when clicking on a button in an itemscontrol. it seems the first mouse click does not register with the button, and the second click crashes unity.
sfernandez

sfernandez

2020-08-13 12:31

manager   ~0006582

>> It happens consistency when clicking on a button in an itemscontrol.
Are you using effects (DropShadowEffect or BlurEffect) on that project? Maybe animating effect parameters when clicking the button?

>> it seems the first mouse click does not register with the button, and the second click crashes unity.
Do you mean that first click is not being executed?
asusralis

asusralis

2020-08-13 12:41

reporter   ~0006583

I'm using drop shadows, but not on that button or itemscontrol.

Well, just a minute ago it was requiring two clicks. Now it just crashes on the first click. This creates the same error as above, not sure if this helps: https://files.catbox.moe/2u13qu.mp4
asusralis

asusralis

2020-08-21 19:32

reporter   ~0006589

Hey, did you need any more information for this?
jsantos

jsantos

2020-08-24 13:30

manager   ~0006590

Not for now, thanks! I will be working on this (and hopefully fixing it) this week. I will write again if I need more information.
jsantos

jsantos

2020-08-28 15:04

manager   ~0006597

Last edited: 2020-08-28 15:05

View 2 revisions

Is there by any chance the possibility of getting a working executable where this error is being reproduced? Better if it is standalone, not Unity editor.

jsantos

jsantos

2020-08-31 12:58

manager   ~0006604

Right now, this is the main blocker for releasing 3.0.5
asusralis

asusralis

2020-08-31 13:09

reporter   ~0006605

You want a debug build where the crash is not happening? So on 3.0.3?
jsantos

jsantos

2020-08-31 13:13

manager   ~0006606

Using the same version as the crash reported (the one provided by sergio https://www.noesisengine.com/bugs/view.php?id=1776#c6579)

https://drive.google.com/file/d/1oEzPaSbXd406urlja1294mMtdpdTUvmR

A standalone build where the crash is happening, that way I can debug with Visual Studio, because the minidump is not giving enough information and I am not able to reproduce the issue.
jsantos

jsantos

2020-08-31 18:17

manager   ~0006608

Last edited: 2020-08-31 18:17

View 2 revisions

Thanks for this! I was able to reproduce it and fix it.

By the way, we detected also a Canvas with Left set to Infinite in your game. That's not allowed in WPF, we are going to detect that and raise error in that case.

Issue History

Date Modified Username Field Change
2020-08-13 12:16 sfernandez New Issue
2020-08-13 12:16 sfernandez Reporter sfernandez => asusralis
2020-08-13 12:16 sfernandez Assigned To => jsantos
2020-08-13 12:16 sfernandez Status new => assigned
2020-08-13 12:16 sfernandez Target Version => 3.0.5
2020-08-13 12:21 asusralis Note Added: 0006581
2020-08-13 12:31 sfernandez Status assigned => feedback
2020-08-13 12:31 sfernandez Note Added: 0006582
2020-08-13 12:41 asusralis Note Added: 0006583
2020-08-13 12:41 asusralis Status feedback => assigned
2020-08-21 19:32 asusralis Note Added: 0006589
2020-08-24 13:30 jsantos Note Added: 0006590
2020-08-28 15:04 jsantos Note Added: 0006597
2020-08-28 15:04 jsantos Status assigned => feedback
2020-08-28 15:05 jsantos Note Edited: 0006597 View Revisions
2020-08-31 12:58 jsantos Note Added: 0006604
2020-08-31 13:09 asusralis Note Added: 0006605
2020-08-31 13:09 asusralis Status feedback => assigned
2020-08-31 13:13 jsantos Note Added: 0006606
2020-08-31 13:13 jsantos Status assigned => feedback
2020-08-31 14:07 asusralis Status feedback => assigned
2020-08-31 18:17 jsantos Status assigned => resolved
2020-08-31 18:17 jsantos Resolution open => fixed
2020-08-31 18:17 jsantos Fixed in Version => 3.0.5
2020-08-31 18:17 jsantos Note Added: 0006608
2020-08-31 18:17 jsantos Note Edited: 0006608 View Revisions