View Issue Details

IDProjectCategoryView StatusLast Update
0001871NoesisGUIUnity3Dpublic2021-01-07 21:22
ReporterasusralisAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.6 
Target Version3.0.9Fixed in Version3.0.9 
Summary0001871: Crash in editor.
DescriptionAfter editing a few unity resources and then going to play the game the editor crashes. I tried updating to 3.0.8 to see if it was fixed there but the game almost immediately crashed from something unrelated to this. I am also using a custom .dll given to me from this bug report: https://www.noesisengine.com/bugs/view.php?id=1806
TagsNo tags attached.
PlatformAny

Activities

asusralis

asusralis

2020-12-30 14:16

reporter  

Crash_2020-12-30_002839518.zip (644,235 bytes)
jsantos

jsantos

2020-12-30 15:15

manager   ~0006930

Thanks for the report, could you please also create another ticket for this "I tried updating to 3.0.8 to see if it was fixed there but the game almost immediately crashed from something unrelated to this"
asusralis

asusralis

2020-12-30 15:29

reporter   ~0006931

Sure: https://www.noesisengine.com/bugs/view.php?id=1872
sfernandez

sfernandez

2020-12-30 16:34

manager   ~0006934

Last edited: 2020-12-30 16:37

View 2 revisions

The crash dump points to some code inside DirectX while creating a texture:

 	d3d11.dll!C10and11View<ID3D11DepthStencilView,ID3D10DepthStencilView>::C10and11View<ID3D11DepthStencilView,ID3D10DepthStencilView>	Unknown
     d3d11.dll!CShaderResourceView::CShaderResourceView	Unknown
     d3d11.dll!CDevice::CreateLayeredChild	Unknown
     d3d11.dll!NDXGI::CDeviceChild<IDXGISurface,IUnknown>::FinalConstruct	Unknown
     d3d11.dll!NDXGI::CDevice::CreateLayeredChild	Unknown
     d3d11.dll!NOutermost::CDevice::CreateLayeredChild	Unknown
     d3d11.dll!CDevice::CreateShaderResourceView_Worker	Unknown
     d3d11.dll!CDevice::CreateShaderResourceView	Unknown
>	Noesis.dll!NoesisApp::D3D11RenderDevice::WrapTexture Line 370	C++
     Noesis.dll!NoesisApp::D3D11Factory::WrapTexture Line 28	C++
     [Inline Frame] Noesis.dll!Noesis_WrapD3D11Texture Line 124	C++
     Noesis.dll!Noesis::UnityDeviceD3D11::WrapTexture Line 146	C++
     Noesis.dll!`anonymous namespace'::TextureProviderUnity::LoadTexture Line 604	C++
     Noesis.dll!Noesis::InspectorTextureProvider::LoadTexture Line 201	C++
     Noesis.dll!Noesis::VGLContext::CreateImage Line 547	C++
     Noesis.dll!Noesis::BitmapImageProxy::CreateImage Line 45	C++
     Noesis.dll!Noesis::ImageSourceProxy::GetImage Line 34	C++
     Noesis.dll!Noesis::RenderTreeHelper::DrawCommands Line 261	C++
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderDraw Line 770	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive Line 730	C++
     ...
     [Inline Frame] Noesis.dll!Noesis::RenderTreeHelper::RenderChildren Line 787	C++
     Noesis.dll!Noesis::RenderTreeHelper::RenderNodeRecursive Line 730	C++
     Noesis.dll!Noesis::RenderTreeHelper::Render Line 127	C++
     Noesis.dll!Noesis::RenderTree::Render Line 292	C++
     Noesis.dll!Noesis::Renderer::Render Line 225	C++
     Noesis.dll!Noesis::Renderer::Render Line 187	C++
     Noesis.dll!Noesis_GetRenderOnscreenCallback::__l2::<lambda> Line 445	C++
     Unity.exe!GfxDeviceWorker::RunCommand	Unknown
     Unity.exe!GfxDeviceWorker::RunExt	Unknown
     Unity.exe!GfxDeviceWorker::RunGfxDeviceWorker	Unknown
     Unity.exe!Thread::RunThreadWrapper	Unknown
     kernel32.dll!BaseThreadInitThunk	Unknown
     ntdll.dll!RtlUserThreadStart	Unknown


We'll probably need more help from you to determine the cause of the crash, I'll let you know.

jsantos

jsantos

2020-12-30 17:25

manager   ~0006935

Is there a deterministic way to reproduce this?
sfernandez

sfernandez

2020-12-31 13:18

manager   ~0006941

Now that I have your project, could you please indicate the steps I should follow to reproduce this crash?
Is it possible that it happens after modifying textures outside Unity?
asusralis

asusralis

2021-01-03 14:43

reporter   ~0006943

Sorry, it seems I'm not getting an email when you reply to any thread.

>Is it possible that it happens after modifying textures outside Unity?

Yes, that is what's happening. I edit a few textures and go to play the game and it crashes.

Issue History

Date Modified Username Field Change
2020-12-30 14:16 asusralis New Issue
2020-12-30 14:16 asusralis File Added: Crash_2020-12-30_002839518.zip
2020-12-30 14:59 jsantos Assigned To => sfernandez
2020-12-30 14:59 jsantos Status new => assigned
2020-12-30 14:59 jsantos Target Version => 3.0.9
2020-12-30 15:08 jsantos Category C++ SDK => Unity3D
2020-12-30 15:15 jsantos Note Added: 0006930
2020-12-30 15:29 asusralis Note Added: 0006931
2020-12-30 16:34 sfernandez Note Added: 0006934
2020-12-30 16:37 sfernandez Note Edited: 0006934 View Revisions
2020-12-30 17:25 jsantos Note Added: 0006935
2020-12-30 17:26 jsantos Status assigned => feedback
2020-12-31 13:18 sfernandez Note Added: 0006941
2021-01-03 14:43 asusralis Note Added: 0006943
2021-01-03 14:43 asusralis Status feedback => assigned
2021-01-07 21:22 sfernandez Status assigned => resolved
2021-01-07 21:22 sfernandez Resolution open => fixed
2021-01-07 21:22 sfernandez Fixed in Version => 3.0.9